summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-10 18:46:33 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-10 18:46:33 +0000
commit6fe57ead44683f40537cb403c12e9bf5abc01012 (patch)
tree4788e9f0aa49c85388db24a7df5c9cb38f5c7c2d /sci-mathematics
parentDrop gtk3 support for now as it is currently a bit broken. (diff)
downloadgentoo-2-6fe57ead44683f40537cb403c12e9bf5abc01012.tar.gz
gentoo-2-6fe57ead44683f40537cb403c12e9bf5abc01012.tar.bz2
gentoo-2-6fe57ead44683f40537cb403c12e9bf5abc01012.zip
sci-mathematics/gretl: Version Bump, set gtk version fix (<1.9.9 = gtk2, >=1.9.9 = gtk3), #420559
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gretl/ChangeLog8
-rw-r--r--sci-mathematics/gretl/gretl-1.9.7.ebuild42
-rw-r--r--sci-mathematics/gretl/gretl-1.9.8.ebuild26
-rw-r--r--sci-mathematics/gretl/gretl-1.9.9.ebuild115
-rw-r--r--sci-mathematics/gretl/metadata.xml13
5 files changed, 158 insertions, 46 deletions
diff --git a/sci-mathematics/gretl/ChangeLog b/sci-mathematics/gretl/ChangeLog
index 93b0943c8b1d..a3ff9f94c5c9 100644
--- a/sci-mathematics/gretl/ChangeLog
+++ b/sci-mathematics/gretl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/gretl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/ChangeLog,v 1.38 2012/05/04 07:46:51 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/ChangeLog,v 1.39 2012/06/10 18:46:33 jlec Exp $
+
+*gretl-1.9.9 (10 Jun 2012)
+
+ 10 Jun 2012; Justin Lecher <jlec@gentoo.org> gretl-1.9.7.ebuild,
+ gretl-1.9.8.ebuild, +gretl-1.9.9.ebuild, metadata.xml:
+ Version Bump, set gtk version fix (<1.9.9 = gtk2, >=1.9.9 = gtk3), #420559
04 May 2012; Jeff Horelick <jdhore@gentoo.org> gretl-1.9.7.ebuild,
gretl-1.9.8.ebuild:
diff --git a/sci-mathematics/gretl/gretl-1.9.7.ebuild b/sci-mathematics/gretl/gretl-1.9.7.ebuild
index a1725da77709..37c06d9ec20f 100644
--- a/sci-mathematics/gretl/gretl-1.9.7.ebuild
+++ b/sci-mathematics/gretl/gretl-1.9.7.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.9.7.ebuild,v 1.3 2012/05/04 07:46:51 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.9.7.ebuild,v 1.4 2012/06/10 18:46:32 jlec Exp $
EAPI=4
+
USE_EINSTALL=true
-inherit eutils gnome2 elisp-common
+
+inherit eutils gnome2 elisp-common toolchain-funcs
DESCRIPTION="Regression, econometrics and time-series library"
HOMEPAGE="http://gretl.sourceforge.net/"
@@ -13,31 +15,29 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="accessibility emacs gnome gtk nls odbc openmp readline sse2 R static-libs"
-IUSE="accessibility emacs gnome gtk gtk3 nls odbc openmp readline sse2 R static-libs"
-
-RDEPEND="dev-libs/libxml2:2
+RDEPEND="
dev-libs/glib:2
- >=sci-visualization/gnuplot-4.2
- virtual/lapack
- virtual/latex-base
- sci-libs/fftw:3.0
dev-libs/gmp
+ dev-libs/libxml2:2
dev-libs/mpfr
+ sci-libs/fftw:3.0
+ sci-visualization/gnuplot
+ virtual/lapack
+ virtual/latex-base
readline? ( sys-libs/readline )
accessibility? ( app-accessibility/flite )
- gtk? ( sci-visualization/gnuplot[gd]
+ gtk? (
media-libs/gd[png]
+ sci-visualization/gnuplot[gd]
x11-libs/gtk+:2
x11-libs/gtksourceview:2.0 )
- gtk3? ( sci-visualization/gnuplot[gd]
+ gnome? (
+ sci-visualization/gnuplot[gd]
media-libs/gd[png]
- x11-libs/gtk+:3
- x11-libs/gtksourceview:3.0 )
- gnome? ( sci-visualization/gnuplot[gd]
- media-libs/gd[png]
- gnome-base/libgnomeui
- gnome-base/gconf:2 )
+ gnome-base/libgnomeui
+ gnome-base/gconf:2 )
R? ( dev-lang/R )
odbc? ( dev-db/unixODBC )
emacs? ( virtual/emacs )"
@@ -48,10 +48,7 @@ DEPEND="${RDEPEND}
SITEFILE=50${PN}-gentoo.el
pkg_setup() {
- if use openmp &&
- [[ $(tc-getCC)$ == *gcc* ]] &&
- ( [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] ||
- ! has_version sys-devel/gcc[openmp] )
+ if use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp
then
ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
die "Need an OpenMP capable compiler"
@@ -64,7 +61,6 @@ src_configure() {
--enable-shared \
--with-mpfr \
$(use_enable gtk gui) \
- $(use_enable gtk3) \
$(use_enable nls) \
$(use_enable openmp) \
$(use_enable sse2) \
@@ -91,7 +87,7 @@ src_install() {
else
einstall svprefix="${ED}usr"
fi
- if use gtk || use gtk3 && ! use gnome; then
+ if use gtk && ! use gnome; then
doicon gnome/gretl.png
make_desktop_entry gretl_x11 gretl
fi
diff --git a/sci-mathematics/gretl/gretl-1.9.8.ebuild b/sci-mathematics/gretl/gretl-1.9.8.ebuild
index a768950b3dd0..884bb29a2650 100644
--- a/sci-mathematics/gretl/gretl-1.9.8.ebuild
+++ b/sci-mathematics/gretl/gretl-1.9.8.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.9.8.ebuild,v 1.2 2012/05/04 07:46:51 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.9.8.ebuild,v 1.3 2012/06/10 18:46:33 jlec Exp $
EAPI=4
+
USE_EINSTALL=true
inherit eutils gnome2 elisp-common toolchain-funcs
@@ -14,10 +15,10 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="accessibility emacs gnome gtk nls odbc openmp readline sse2 R static-libs"
-IUSE="accessibility emacs gnome gtk gtk3 nls odbc openmp readline sse2 R static-libs"
-
-RDEPEND="dev-libs/glib:2
+RDEPEND="
+ dev-libs/glib:2
dev-libs/gmp
dev-libs/libxml2:2
dev-libs/mpfr
@@ -27,18 +28,16 @@ RDEPEND="dev-libs/glib:2
virtual/latex-base
accessibility? ( app-accessibility/flite )
emacs? ( virtual/emacs )
- gtk? ( media-libs/gd[png]
+ gtk? (
+ media-libs/gd[png]
sci-visualization/gnuplot[gd]
x11-libs/gtk+:2
x11-libs/gtksourceview:2.0 )
- gtk3? ( media-libs/gd[png]
+ gnome? (
+ media-libs/gd[png]
sci-visualization/gnuplot[gd]
- x11-libs/gtk+:3
- x11-libs/gtksourceview:3.0 )
- gnome? ( media-libs/gd[png]
- sci-visualization/gnuplot[gd]
- gnome-base/libgnomeui
- gnome-base/gconf:2 )
+ gnome-base/libgnomeui
+ gnome-base/gconf:2 )
odbc? ( dev-db/unixODBC )
R? ( dev-lang/R )
readline? ( sys-libs/readline )"
@@ -62,7 +61,6 @@ src_configure() {
--enable-shared \
--with-mpfr \
$(use_enable gtk gui) \
- $(use_enable gtk3) \
$(use_enable nls) \
$(use_enable openmp) \
$(use_enable sse2) \
@@ -89,7 +87,7 @@ src_install() {
else
einstall svprefix="${ED}usr"
fi
- if use gtk || use gtk3 && ! use gnome; then
+ if use gtk && ! use gnome; then
doicon gnome/gretl.png
make_desktop_entry gretl_x11 gretl
fi
diff --git a/sci-mathematics/gretl/gretl-1.9.9.ebuild b/sci-mathematics/gretl/gretl-1.9.9.ebuild
new file mode 100644
index 000000000000..813cfbf051f4
--- /dev/null
+++ b/sci-mathematics/gretl/gretl-1.9.9.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.9.9.ebuild,v 1.1 2012/06/10 18:46:33 jlec Exp $
+
+EAPI=4
+
+USE_EINSTALL=true
+
+inherit eutils gnome2 elisp-common toolchain-funcs
+
+DESCRIPTION="Regression, econometrics and time-series library"
+HOMEPAGE="http://gretl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="accessibility emacs gnome gtk nls odbc openmp readline sse2 R static-libs"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/gmp
+ dev-libs/libxml2:2
+ dev-libs/mpfr
+ sci-libs/fftw:3.0
+ sci-visualization/gnuplot
+ virtual/lapack
+ virtual/latex-base
+ accessibility? ( app-accessibility/flite )
+ emacs? ( virtual/emacs )
+ gtk? (
+ media-libs/gd[png]
+ sci-visualization/gnuplot[gd]
+ x11-libs/gtk+:3
+ x11-libs/gtksourceview:3.0 )
+ gnome? (
+ media-libs/gd[png]
+ sci-visualization/gnuplot[gd]
+ gnome-base/libgnomeui
+ gnome-base/gconf:2 )
+ odbc? ( dev-db/unixODBC )
+ R? ( dev-lang/R )
+ readline? ( sys-libs/readline )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+SITEFILE=50${PN}-gentoo.el
+
+pkg_setup() {
+ if use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp
+ then
+ ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
+ die "Need an OpenMP capable compiler"
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-rpath \
+ --enable-shared \
+ --with-mpfr \
+ $(use_enable gtk gui) \
+ $(use_enable gtk gtk3) \
+ $(use_enable nls) \
+ $(use_enable openmp) \
+ $(use_enable sse2) \
+ $(use_enable static-libs static) \
+ $(use_with accessibility audio) \
+ $(use_with gnome) \
+ $(use_with odbc) \
+ $(use_with readline) \
+ $(use_with R libR) \
+ ${myconf} \
+ LAPACK_LIBS="$(pkg-config --libs lapack)"
+}
+
+src_compile() {
+ emake
+ if use emacs; then
+ elisp-compile utils/emacs/gretl.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ if use gnome; then
+ gnome2_src_install gnome_prefix="${ED}"/usr svprefix="${ED}usr"
+ else
+ einstall svprefix="${ED}usr"
+ fi
+ if use gtk && ! use gnome; then
+ doicon gnome/gretl.png
+ make_desktop_entry gretl_x11 gretl
+ fi
+ if use emacs; then
+ elisp-install ${PN} utils/emacs/gretl.{el,elc} \
+ || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+ fi
+ dodoc README README.audio ChangeLog CompatLog
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elisp-site-regen
+ elog "To begin using gretl-mode for all \".inp\" files that you edit,"
+ elog "add the following line to your \"~/.emacs\" file:"
+ elog " (add-to-list 'auto-mode-alist '(\"\\\\.inp\\\\'\" . gretl-mode))"
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sci-mathematics/gretl/metadata.xml b/sci-mathematics/gretl/metadata.xml
index 13fd2421e47d..5f2eb1ff0372 100644
--- a/sci-mathematics/gretl/metadata.xml
+++ b/sci-mathematics/gretl/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-mathematics</herd>
-<longdescription lang="en">
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
GNU Regression, Econometrics and Time-series Library provides
a library which comprises various functions relating to econometric
estimation, a command-line client program and a GUI. The library is
@@ -14,10 +14,7 @@
data, and uses gnuplot for graphing. It can output regression results
in LaTeX format.
</longdescription>
-<use>
- <flag name='sourceview'>Enable support for <pkg>x11-libs/gtksourceview</pkg>
- </flag>
- <flag name='gtk3'>Use GTK+3 frontend instead of GTK+2 </flag>
- <flag name='R'>Enable support for <pkg>dev-lang/R</pkg></flag>
-</use>
+ <use>
+ <flag name="R">Enable support for <pkg>dev-lang/R</pkg></flag>
+ </use>
</pkgmetadata>