summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2005-12-04 21:41:10 +0000
committerTim Yamin <plasmaroo@gentoo.org>2005-12-04 21:41:10 +0000
commit5c27db397e9580eb1f5f4a7e206322eec549f3aa (patch)
treeb140e69081a6ad48d9232499655827ac31f7b86f /sci-mathematics
parentstable on ppc64 (diff)
downloadgentoo-2-5c27db397e9580eb1f5f4a7e206322eec549f3aa.tar.gz
gentoo-2-5c27db397e9580eb1f5f4a7e206322eec549f3aa.tar.bz2
gentoo-2-5c27db397e9580eb1f5f4a7e206322eec549f3aa.zip
Add compile fixes (#75372, #111923) as well as a gcl fix so compilation works once we're out of the sandbox.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/axiom/ChangeLog8
-rw-r--r--sci-mathematics/axiom/axiom-9999.ebuild17
-rw-r--r--sci-mathematics/axiom/files/gcl-2.6.7.fix-out-of-build-root-compile.Makefile.patch33
-rw-r--r--sci-mathematics/axiom/files/gcl-2.6.7.fix-out-of-build-root-compile.patch.input24
4 files changed, 70 insertions, 12 deletions
diff --git a/sci-mathematics/axiom/ChangeLog b/sci-mathematics/axiom/ChangeLog
index 16c19ae5fd30..cfd8fb8d9e86 100644
--- a/sci-mathematics/axiom/ChangeLog
+++ b/sci-mathematics/axiom/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/axiom
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/axiom/ChangeLog,v 1.1 2005/01/16 16:39:20 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/axiom/ChangeLog,v 1.2 2005/12/04 21:41:10 plasmaroo Exp $
+
+ 04 Dec 2005; <plasmaroo@gentoo.org> axiom-9999.ebuild,
+ +files/gcl-2.6.7.fix-out-of-build-root-compile.Makefile.patch,
+ +files/gcl-2.6.7.fix-out-of-build-root-compile.patch.input:
+ Add compile fixes (#75372, #111923) as well as a gcl fix so compilation works
+ once we're out of the sandbox.
*axiom-9999 (16 Jan 2005)
diff --git a/sci-mathematics/axiom/axiom-9999.ebuild b/sci-mathematics/axiom/axiom-9999.ebuild
index 8051b8e5e0f8..593913fc106b 100644
--- a/sci-mathematics/axiom/axiom-9999.ebuild
+++ b/sci-mathematics/axiom/axiom-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/axiom/axiom-9999.ebuild,v 1.2 2005/11/02 00:09:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/axiom/axiom-9999.ebuild,v 1.3 2005/12/04 21:41:10 plasmaroo Exp $
ECVS_AUTH="ext"
export CVS_RSH="ssh"
@@ -32,21 +32,12 @@ pkg_setup() {
ewarn 'WARNING: This is a *live* *CVS* ebuild and thus may have'
ewarn ' serious stability issues and may even not build...'
echo
- ewarn 'Please make sure you have at least 0.6GB of space for Axiom'
- ewarn 'to build. The compilation will take several *HOURS* so be'
- ewarn 'patient...'
- echo
-
epause 5
}
src_setenv() {
export AXIOM=`pwd`/mnt/linux
export PATH=${AXIOM}/bin:${PATH}
-
- # For TeXMF and sandbox happiness
- export VARTEXFONTS=${WORKDIR}/../temp
- export TEXMF="{${VARTEXFONTS},!!/usr/share/texmf}"
}
src_compile() {
@@ -57,6 +48,10 @@ src_compile() {
# things to compile and work.
sed -i -e 's/--enable-statsysbfd/--enable-locbfd --disable-statsysbfd/' Makefile.pamphlet || die 'Failed to patch the lsp Makefile!'
+ # Fix gcl so the "real" Axiom can compile code after we're out of the chroot
+ cp ${FILESDIR}/gcl-2.6.7.fix-out-of-build-root-compile.patch.input ${S}/zips/gcl-2.6.7.fix-out-of-build-root-compile.patch
+ epatch ${FILESDIR}/gcl-2.6.7.fix-out-of-build-root-compile.Makefile.patch || die 'Failed to patch the lsp pamphlet!'
+
# Sandbox happiness, fix noweb
cd ${WORKDIR}
mkdir noweb
@@ -82,7 +77,7 @@ src_install() {
dodir /usr/bin
einstall INSTALL=${D}/opt/axiom COMMAND=${D}/usr/bin/axiom || die 'Failed to install Axiom!'
- sed -e '1d;2i AXIOM=/opt/axiom' -i ${D}/usr/bin/axiom || die 'Failed to patch axiom runscript!'
+ sed -e '2d;3i AXIOM=/opt/axiom' -i ${D}/usr/bin/axiom ${D}/opt/axiom/mnt/linux/bin/axiom || die 'Failed to patch axiom runscript!'
# Get rid of /mnt/linux
cd ${D}/opt/axiom
diff --git a/sci-mathematics/axiom/files/gcl-2.6.7.fix-out-of-build-root-compile.Makefile.patch b/sci-mathematics/axiom/files/gcl-2.6.7.fix-out-of-build-root-compile.Makefile.patch
new file mode 100644
index 000000000000..bc4e3fa8b5ec
--- /dev/null
+++ b/sci-mathematics/axiom/files/gcl-2.6.7.fix-out-of-build-root-compile.Makefile.patch
@@ -0,0 +1,33 @@
+Index: Makefile.pamphlet
+===================================================================
+RCS file: /cvsroot/axiom/axiom/lsp/Makefile.pamphlet,v
+retrieving revision 1.16
+diff -u -r1.16 Makefile.pamphlet
+--- lsp/Makefile.pamphlet 5 Sep 2005 23:44:08 -0000 1.16
++++ lsp/Makefile.pamphlet 4 Dec 2005 21:25:58 -0000
+@@ -15,6 +15,17 @@
+ over the gcl Makefiles.
+
+ Patches are applied to the distribution before we do the configure.
++\section{Gnu Common Lisp 2.6.7}
++\subsubsection{fix-out-of-build-root-compile.patch}
++GCL's compiler system includes a -I<gclbuildroot> flag in the gcc args;
++which causes issues if <gclbuildroot> does not exist at a later date and
++the Axiom user invokes a command that requires compilation - the gcc call
++will fail and this patch rectifies the issue. Dec 4 2005, Tim Yamin.
++<<gcl-2.6.7.fix-out-of-build-root-compile.patch>>=
++ @(cd ${GCLVERSION}/cmpnew ; \
++ echo 29 applying fix-out-of-build-root-compile patch ; \
++ ${PATCH} <${SPD}/zips/${GCLVERSION}.fix-out-of-build-root-compile.patch )
++@
+ \section{Gnu Common Lisp 2.6.7pre}
+ \subsection{run-process patch}
+ The gcl-2.6.6.h.linux.h.patch has been accepted into the mainline lisp
+@@ -1019,6 +1030,7 @@
+ <<gcl-2.6.7.toploop.patch>>
+ <<gcl-2.6.7.tail-recursive.patch>>
+ <<gcl-2.6.7.collectfn.fix>>
++<<gcl-2.6.7.fix-out-of-build-root-compile.patch>>
+ <<gclConfigureMake>>
+ @echo 13 finished system build on `date` | tee >gcldir
+
diff --git a/sci-mathematics/axiom/files/gcl-2.6.7.fix-out-of-build-root-compile.patch.input b/sci-mathematics/axiom/files/gcl-2.6.7.fix-out-of-build-root-compile.patch.input
new file mode 100644
index 000000000000..9b73a20026ab
--- /dev/null
+++ b/sci-mathematics/axiom/files/gcl-2.6.7.fix-out-of-build-root-compile.patch.input
@@ -0,0 +1,24 @@
+--- gcl_cmpmain.lsp 2005-05-06 22:56:55.000000000 +0100
++++ gcl_cmpmain.lsp.new 2005-12-04 20:56:31.000000000 +0000
+@@ -545,9 +545,8 @@
+ (setq na (namestring
+ (make-pathname :name name :type (pathname-type(first args)))))
+ #+(or dos winnt)
+- (format nil "~a -I~a ~a ~a -c -w ~s -o ~s"
++ (format nil "~a ~a ~a -c -w ~s -o ~s"
+ *cc*
+- (concatenate 'string si::*system-directory* "../h")
+ (if (and (boundp '*c-debug*) *c-debug*) " -g " "")
+ (case *speed*
+ (3 *opt-three* )
+@@ -558,9 +557,8 @@
+ )
+
+ #-(or dos winnt)
+- (format nil "~a -I~a ~a ~a -c ~s -o ~s ~a"
++ (format nil "~a ~a ~a -c ~s -o ~s ~a"
+ *cc*
+- (concatenate 'string si::*system-directory* "../h")
+ (if (and (boundp '*c-debug*) *c-debug*) " -g " "")
+ (case *speed*
+ (3 *opt-three* )