summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2009-03-18 23:50:09 +0000
committerAndrey Grozin <grozin@gentoo.org>2009-03-18 23:50:09 +0000
commit49b73451f2fbf80eae50b89c488b52dc9b1617bb (patch)
tree641df5cd711ed1bbc5231f13cb0d94f16187f4b7 /sci-mathematics
parentBump to 0.8.13. Build fixes. (diff)
downloadgentoo-2-49b73451f2fbf80eae50b89c488b52dc9b1617bb.tar.gz
gentoo-2-49b73451f2fbf80eae50b89c488b52dc9b1617bb.tar.bz2
gentoo-2-49b73451f2fbf80eae50b89c488b52dc9b1617bb.zip
maxima no longer installs imaxima - there is a separate package (bug #260663, thanks to Ulrich Mueller). rmaxima is produced when no lisp USE flags are given (bug #261455). Old versions cleaned.
(Portage version: 2.2_rc26/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/maxima/ChangeLog13
-rw-r--r--sci-mathematics/maxima/files/50maxima-gentoo.el12
-rw-r--r--sci-mathematics/maxima/maxima-5.13.0-r1.ebuild195
-rw-r--r--sci-mathematics/maxima/maxima-5.15.0-r1.ebuild231
-rw-r--r--sci-mathematics/maxima/maxima-5.17.1-r1.ebuild (renamed from sci-mathematics/maxima/maxima-5.16.3.ebuild)42
-rw-r--r--sci-mathematics/maxima/maxima-5.17.1.ebuild194
6 files changed, 35 insertions, 652 deletions
diff --git a/sci-mathematics/maxima/ChangeLog b/sci-mathematics/maxima/ChangeLog
index f4597872e993..20565d225b72 100644
--- a/sci-mathematics/maxima/ChangeLog
+++ b/sci-mathematics/maxima/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-mathematics/maxima
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/ChangeLog,v 1.61 2008/12/20 09:36:19 grozin Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/ChangeLog,v 1.62 2009/03/18 23:50:09 grozin Exp $
+
+*maxima-5.17.1-r1 (19 Mar 2009)
+
+ 19 Mar 2009; Andrey Grozin <grozin@gentoo.org> files/50maxima-gentoo.el,
+ -maxima-5.13.0-r1.ebuild, -maxima-5.15.0-r1.ebuild, -maxima-5.16.3.ebuild,
+ -maxima-5.17.1.ebuild, +maxima-5.17.1-r1.ebuild:
+ maxima no longer installs imaxima - there is a separate package (bug
+ #260663, thanks to Ulrich Mueller). rmaxima is produced when no lisp USE
+ flags are given (bug #261455). Old versions cleaned.
*maxima-5.17.1 (20 Dec 2008)
diff --git a/sci-mathematics/maxima/files/50maxima-gentoo.el b/sci-mathematics/maxima/files/50maxima-gentoo.el
index 829c705aadcd..20c7399164f7 100644
--- a/sci-mathematics/maxima/files/50maxima-gentoo.el
+++ b/sci-mathematics/maxima/files/50maxima-gentoo.el
@@ -1,16 +1,12 @@
-;; maxima mode
+
+;;; maxima site-lisp configuration
+
(add-to-list 'load-path "@SITELISP@")
(autoload 'maxima-mode "maxima" "Maxima mode" t)
(autoload 'maxima "maxima" "Maxima interactive" t)
-(setq auto-mode-alist (cons '("\\.max" . maxima-mode) auto-mode-alist))
(autoload 'dbl "dbl" "Make a debugger to run lisp, maxima and or gdb in" t)
-(autoload 'gcl-mode "gcl" "Major mode for editing maxima code and interacting with debugger" t)
-(setq auto-mode-alist (cons '("\\.ma?[cx]\\'" . maxima-mode) auto-mode-alist))
+(add-to-list 'auto-mode-alist '("\\.ma?[cx]\\'" . maxima-mode))
;; emaxima mode
(autoload 'emaxima-mode "emaxima" "EMaxima" t)
(add-hook 'emaxima-mode-hook 'emaxima-mark-file-as-emaxima)
-
-;; imaxima
-(autoload 'imaxima "imaxima" "Image support for Maxima." t)
-(autoload 'imath-mode "imath" "Interactive Math minor mode." t)
diff --git a/sci-mathematics/maxima/maxima-5.13.0-r1.ebuild b/sci-mathematics/maxima/maxima-5.13.0-r1.ebuild
deleted file mode 100644
index 1b11a929c72a..000000000000
--- a/sci-mathematics/maxima/maxima-5.13.0-r1.ebuild
+++ /dev/null
@@ -1,195 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/maxima-5.13.0-r1.ebuild,v 1.11 2008/02/07 13:22:45 bicatali Exp $
-
-inherit eutils elisp-common
-
-DESCRIPTION="Free computer algebra environment based on Macsyma"
-HOMEPAGE="http://maxima.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2 AECA"
-SLOT="0"
-KEYWORDS="amd64 ppc sparc x86"
-IUSE="cmucl clisp sbcl gcl latex emacs tk nls unicode"
-
-# rlwrap is recommended for cmucl and sbcl
-# tetex>=3, so no use of virtual/latex-base (bug #203558)
-RDEPEND=">=sci-visualization/gnuplot-4.0
- x11-misc/xdg-utils
- latex? ( || ( dev-texlive/texlive-latexrecommended
- >=app-text/tetex-3
- app-text/ptex ) )
- emacs? ( virtual/emacs
- latex? ( || ( app-emacs/auctex app-xemacs/auctex ) ) )
- sbcl? ( dev-lisp/sbcl app-misc/rlwrap )
- !sbcl? (
- clisp? ( dev-lisp/clisp )
- !clisp? (
- cmucl? ( >=dev-lisp/cmucl-19a app-misc/rlwrap )
- !cmucl? (
- gcl? ( dev-lisp/gcl )
- !gcl? ( dev-lisp/sbcl app-misc/rlwrap )
- )
- )
- )
- tk? ( dev-lang/tk )"
-
-DEPEND="${RDEPEND}
- sys-apps/texinfo"
-
-LANGS="es pt pt_BR"
-for lang in ${LANGS}; do
- IUSE="${IUSE} linguas_${lang}"
-done
-
-RESTRICT="clisp? ( strip )"
-
-pkg_setup() {
- # Don't install in the main tree, as this may cause file collisions
- if use latex; then
- local TEXMFPATH="$(kpsewhich -var-value=TEXMFSITE)"
- local TEXMFCONFIGFILE="$(kpsewhich texmf.cnf)"
-
- if [ -z "${TEXMFPATH}" ]; then
- eerror "You haven't defined the TEXMFSITE variable in your TeX config."
- eerror "Please do so in the file ${TEXMFCONFIGFILE:-/var/lib/texmf/web2c/texmf.cnf}"
- die "Define TEXMFSITE in TeX configuration!"
- else
- # go through the colon separated list of directories (maybe only one) provided in the variable
- # TEXMFPATH (generated from TEXMFSITE from TeX's config) and choose only the first entry.
- # All entries are separated by colons, even when defined with semi-colons, kpsewhich changes
- # the output to a generic format, so IFS has to be redefined.
- local IFS="${IFS}:"
-
- for strippedpath in ${TEXMFPATH}; do
- if [ -d ${strippedpath} ]; then
- MAXIMA_TEXMFDIR="${strippedpath}"
- break
- fi
- done
-
- # verify if an existing path was chosen to prevent from installing into the wrong directory
- if [ -z ${MAXIMA_TEXMFDIR} ]; then
- eerror "TEXMFSITE does not contain any existing directory."
- eerror "Please define an existing directory in your TeX config file"
- eerror "${TEXMFCONFIGFILE:-/var/lib/texmf/web2c/texmf.cnf} or create at least one of the there specified directories"
- die "TEXMFSITE variable did not contain an existing directory"
- fi
- fi
- fi
-
- if ! built_with_use sci-visualization/gnuplot gd; then
- elog "To benefit full plotting capability of maxima,"
- elog "enable the gd USE flag enabled for sci-visualization/gnuplot"
- elog "Then re-emerge maxima"
- epause 5
- fi
-
- # lisp priorities
- if use sbcl; then
- MAXIMA_LISP=sbcl
- elif use clisp; then
- MAXIMA_LISP=clisp
- elif use cmucl; then
- MAXIMA_LISP=cmucl
- elif use gcl; then
- MAXIMA_LISP=gcl
- else
- MAXIMA_LISP=sbcl
- fi
- einfo "Selected lisp: ${MAXIMA_LISP}"
-
- if [[ ${MAXIMA_LISP} == gcl ]]; then
- ewarn "Using gcl: if it breaks, recompile with another lisp or use default (sbcl)."
- if ! built_with_use dev-lisp/gcl ansi; then
- eerror "GCL must be installed with ANSI."
- eerror "Try USE=\"ansi\" emerge gcl"
- die "This package needs gcl with USE=ansi"
- fi
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # use xdg-open to view ps, pdf
- epatch "${FILESDIR}"/${PN}-xdg-utils.patch
- # avoid bugs and warning at init (see bug #203748)
- epatch "${FILESDIR}"/${PN}-no-init-files.patch
- # remove rmaxima if neither cmucl nor sbcl
- if [[ ${MAXIMA_LISP} != cmucl ]] || [[ ${MAXIMA_LISP} != sbcl ]]; then
- sed -i \
- -e '/^@WIN32_FALSE@bin_SCRIPTS/s/rmaxima//' \
- src/Makefile.in \
- || die "sed for rmaxima failed"
- fi
-}
-
-src_compile() {
- local myconf="--enable-${MAXIMA_LISP}"
- # remove xmaxima if no tk
- if use tk; then
- myconf="${myconf} --with-wish=wish"
- else
- myconf="${myconf} --with-wish=none"
- sed -i \
- -e '/^SUBDIRS/s/xmaxima//' \
- interfaces/Makefile.in || die "sed for tk failed"
- fi
-
- # enable existing translated doc
- if use nls; then
- for lang in ${LANGS}; do
- if use "linguas_${lang}"; then
- myconf="${myconf} --enable-lang-${lang}"
- use unicode && myconf="${myconf} --enable-lang-${lang}-utf8"
- fi
- done
- fi
-
- econf ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- einstall emacsdir="${D}${SITELISP}/${PN}" || die "einstall failed"
-
- use tk && make_desktop_entry xmaxima xmaxima \
- /usr/share/${PN}/${PV}/xmaxima/maxima-new.png \
- "Science;Math;Education"
-
- use emacs && \
- elisp-site-file-install "${FILESDIR}"/50maxima-gentoo.el
-
- if use latex; then
- insinto "${MAXIMA_TEXMFDIR}"/tex/latex/emaxima
- doins interfaces/emacs/emaxima/emaxima.sty
- fi
-
- # do not use dodoc because interfaces can't read compressed files
- # read COPYING before attempt to remove it
- insinto /usr/share/${PN}/${PV}/doc
- doins AUTHORS COPYING ChangeLog-${PV} README README.lisps
- dodir /usr/share/doc
- dosym /usr/share/${PN}/${PV}/doc /usr/share/doc/${PF}
-}
-
-pkg_preinst() {
- # some lisps do not read compress info files (bug #176411)
- for infofile in "${D}"/usr/share/info/*.bz2 ; do
- bunzip2 "${infofile}"
- done
- for infofile in "${D}"/usr/share/info/*.gz ; do
- gunzip "${infofile}"
- done
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- use latex && mktexlsr
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sci-mathematics/maxima/maxima-5.15.0-r1.ebuild b/sci-mathematics/maxima/maxima-5.15.0-r1.ebuild
deleted file mode 100644
index a358967b60df..000000000000
--- a/sci-mathematics/maxima/maxima-5.15.0-r1.ebuild
+++ /dev/null
@@ -1,231 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/maxima-5.15.0-r1.ebuild,v 1.5 2008/09/03 03:03:38 aballier Exp $
-inherit eutils elisp-common
-
-DESCRIPTION="Free computer algebra environment based on Macsyma"
-HOMEPAGE="http://maxima.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2 AECA"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-
-# Supported lisps with readline
-SUPP_RL="gcl clisp"
-# Supported lisps without readline
-SUPP_NORL="cmucl sbcl"
-SUPP_LISPS="${SUPP_RL} ${SUPP_NORL}"
-# Default lisp if none selected
-DEF_LISP="sbcl"
-
-IUSE="latex emacs tk nls unicode xemacs X ${SUPP_LISPS} ${IUSE}"
-
-# Languages
-LANGS="es pt pt_BR"
-for lang in ${LANGS}; do
- IUSE="${IUSE} linguas_${lang}"
-done
-
-# >=maxima-5.15.0 includes imaxima; it depends on dev-tex/mh
-RDEPEND="!app-emacs/imaxima
- X? ( x11-misc/xdg-utils
- sci-visualization/gnuplot
- tk? ( dev-lang/tk ) )
- latex? ( || ( dev-texlive/texlive-latexrecommended
- >=app-text/tetex-3
- app-text/ptex ) )
- emacs? ( virtual/emacs
- latex? ( app-emacs/auctex
- || ( dev-tex/mh =dev-texlive/texlive-mathextra-2007* ) ) )
- xemacs? ( virtual/xemacs
- latex? ( app-emacs/auctex
- || ( dev-tex/mh =dev-texlive/texlive-mathextra-2007* ) ) )"
-
-# create lisp dependencies
-for LISP in ${SUPP_LISPS}; do
- RDEPEND="${RDEPEND} ${LISP}? ( dev-lisp/${LISP} )"
- DEF_DEP="${DEF_DEP} !${LISP}? ( "
-done
-DEF_DEP="${DEF_DEP} dev-lisp/${DEF_LISP}"
-for LISP in ${SUPP_NORL}; do
- RDEPEND="${RDEPEND} ${LISP}? ( app-misc/rlwrap )"
- [[ ${LISP} = ${DEF_LISP} ]] && \
- DEF_DEP="${DEF_DEP} app-misc/rlwrap"
-done
-for LISP in ${SUPP_LISPS}; do
- DEF_DEP="${DEF_DEP} )"
-done
-
-RDEPEND="${RDEPEND}
- ${DEF_DEP}"
-
-DEPEND="${RDEPEND}
- sys-apps/texinfo"
-
-pkg_setup() {
- LISPS=""
-
- for LISP in ${SUPP_LISPS}; do
- use ${LISP} && LISPS="${LISPS} ${LISP}"
- done
-
- if [ -z "${LISPS}" ]; then
- ewarn "No lisp specified in USE flags, choosing ${DEF_LISP} as default"
- LISPS="${DEF_LISP}"
- fi
-
- RL=""
-
- for LISP in ${SUPP_NORL}; do
- use ${LISP} && RL="yes"
- done
-
- if use gcl; then
- if ! built_with_use dev-lisp/gcl ansi; then
- eerror "gcl must be emerged with the USE flag ansi"
- die "This package needs gcl with USE=ansi"
- fi
- # gcl in the main tree is broken (bug #205803)
- ewarn "Please use gcl from http://repo.or.cz/w/gentoo-lisp-overlay.git"
- fi
-
- # Calculating MAXIMA_TEXMFDIR
- if use latex; then
- local TEXMFPATH="$(kpsewhich -var-value=TEXMFSITE)"
- local TEXMFCONFIGFILE="$(kpsewhich texmf.cnf)"
-
- if [ -z "${TEXMFPATH}" ]; then
- eerror "You haven't defined the TEXMFSITE variable in your TeX config."
- eerror "Please do so in the file ${TEXMFCONFIGFILE:-/var/lib/texmf/web2c/texmf.cnf}"
- die "Define TEXMFSITE in TeX configuration!"
- else
- # go through the colon separated list of directories
- # (maybe only one) provided in the variable
- # TEXMFPATH (generated from TEXMFSITE from TeX's config)
- # and choose only the first entry.
- # All entries are separated by colons, even when defined
- # with semi-colons, kpsewhich changes
- # the output to a generic format, so IFS has to be redefined.
- local IFS="${IFS}:"
-
- for strippedpath in ${TEXMFPATH}; do
- if [ -d ${strippedpath} ]; then
- MAXIMA_TEXMFDIR="${strippedpath}"
- break
- fi
- done
-
- # verify if an existing path was chosen to prevent from
- # installing into the wrong directory
- if [ -z ${MAXIMA_TEXMFDIR} ]; then
- eerror "TEXMFSITE does not contain any existing directory."
- eerror "Please define an existing directory in your TeX config file"
- eerror "${TEXMFCONFIGFILE:-/var/lib/texmf/web2c/texmf.cnf} or create at least one of the there specified directories"
- die "TEXMFSITE variable did not contain an existing directory"
- fi
- fi
- fi
-
- if use X && ! built_with_use sci-visualization/gnuplot gd wxwindows; then
- elog "To benefit full plotting capability of maxima,"
- elog "enable the gd USE flag for sci-visualization/gnuplot"
- elog "And if you are planning to use wxmaxima, you want to"
- elog "also add the wxwindows flag to gnuplot."
- epause 5
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # use xdg-open to view ps, pdf
- epatch "${FILESDIR}"/${PN}-xdg-utils.patch
- epatch "${FILESDIR}"/${PN}-no-init-files.patch
- # remove rmaxima if neither cmucl nor sbcl
- if [ -z "${RL}" ]; then
- sed -i \
- -e '/^@WIN32_FALSE@bin_SCRIPTS/s/rmaxima//' \
- "${S}"/src/Makefile.in \
- || die "sed for rmaxima failed"
- fi
-}
-
-src_compile() {
- local myconf=""
- for LISP in ${LISPS}; do
- myconf="${myconf} --enable-${LISP}"
- done
-
- # remove xmaxima if no tk
- if use tk; then
- myconf="${myconf} --with-wish=wish"
- else
- myconf="${myconf} --with-wish=none"
- sed -i \
- -e '/^SUBDIRS/s/xmaxima//' \
- interfaces/Makefile.in || die "sed for tk failed"
- fi
-
- # enable existing translated doc
- if use nls; then
- for lang in ${LANGS}; do
- if use "linguas_${lang}"; then
- myconf="${myconf} --enable-lang-${lang}"
- use unicode && myconf="${myconf} --enable-lang-${lang}-utf8"
- fi
- done
- fi
-
- econf ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- einstall emacsdir="${D}${SITELISP}/${PN}" || die "einstall failed"
-
- use tk && make_desktop_entry xmaxima xmaxima \
- /usr/share/${PN}/${PV}/xmaxima/maxima-new.png \
- "Science;Math;Education"
-
- if use latex; then
- insinto "${MAXIMA_TEXMFDIR}"/tex/latex/emaxima
- doins interfaces/emacs/emaxima/emaxima.sty
- fi
-
- # do not use dodoc because interfaces can't read compressed files
- # read COPYING before attempt to remove it from dodoc
- insinto /usr/share/${PN}/${PV}/doc
- doins AUTHORS COPYING README README.lisps || die
- dodir /usr/share/doc
- dosym ../${PN}/${PV}/doc /usr/share/doc/${PF} || die
-
- if use emacs; then
- elisp-site-file-install "${FILESDIR}"/50maxima-gentoo.el
- # imaxima docs
- cd interfaces/emacs/imaxima
- insinto /usr/share/${PN}/${PV}/doc/imaxima
- doins ChangeLog NEWS README || die "installing imaxima docs failed"
- insinto /usr/share/${PN}/${PV}/doc/imaxima/imath-example
- doins imath-example/*.txt || die "installing imaxima docs failed"
- fi
-}
-
-pkg_preinst() {
- # some lisps do not read compress info files (bug #176411)
- for infofile in "${D}"/usr/share/info/*.bz2 ; do
- bunzip2 "${infofile}"
- done
- for infofile in "${D}"/usr/share/info/*.gz ; do
- gunzip "${infofile}"
- done
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- use latex && mktexlsr
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sci-mathematics/maxima/maxima-5.16.3.ebuild b/sci-mathematics/maxima/maxima-5.17.1-r1.ebuild
index 1409c5e809e4..bd2a0ca15cd5 100644
--- a/sci-mathematics/maxima/maxima-5.16.3.ebuild
+++ b/sci-mathematics/maxima/maxima-5.17.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/maxima-5.16.3.ebuild,v 1.3 2008/11/29 04:02:07 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/maxima-5.17.1-r1.ebuild,v 1.1 2009/03/18 23:50:09 grozin Exp $
inherit eutils elisp-common
DESCRIPTION="Free computer algebra environment based on Macsyma"
@@ -9,7 +9,8 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2 AECA"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+# ~sparc will be added back after keywording app-emacs/imaxima
+KEYWORDS="~amd64 ~ppc ~x86"
# Supported lisps with readline
SUPP_RL="gcl clisp"
@@ -27,19 +28,18 @@ for lang in ${LANGS}; do
IUSE="${IUSE} linguas_${lang}"
done
-# >=maxima-5.15.0 includes imaxima; it depends on dev-tex/mh
-RDEPEND="!app-emacs/imaxima
- X? ( x11-misc/xdg-utils
+RDEPEND="X? ( x11-misc/xdg-utils
sci-visualization/gnuplot
tk? ( dev-lang/tk ) )
latex? ( || ( dev-texlive/texlive-latexrecommended
>=app-text/tetex-3
app-text/ptex ) )
emacs? ( virtual/emacs
- latex? ( app-emacs/auctex dev-tex/mh ) )
+ latex? ( app-emacs/auctex ) )
xemacs? ( virtual/xemacs
- latex? ( app-emacs/auctex
- || ( dev-tex/mh =dev-texlive/texlive-mathextra-2007* ) ) )"
+ latex? ( app-emacs/auctex ) )"
+
+PDEPEND="emacs? ( app-emacs/imaxima )"
# create lisp dependencies
for LISP in ${SUPP_LISPS}; do
@@ -71,24 +71,25 @@ pkg_setup() {
use ${LISP} && LISPS="${LISPS} ${LISP}"
done
- if [ -z "${LISPS}" ]; then
- ewarn "No lisp specified in USE flags, choosing ${DEF_LISP} as default"
- LISPS="${DEF_LISP}"
- fi
-
RL=""
for LISP in ${SUPP_NORL}; do
use ${LISP} && RL="yes"
done
+ if [ -z "${LISPS}" ]; then
+ ewarn "No lisp specified in USE flags, choosing ${DEF_LISP} as default"
+ LISPS="${DEF_LISP}"
+ RL="yes"
+ fi
+
if use gcl; then
if ! built_with_use dev-lisp/gcl ansi; then
eerror "gcl must be emerged with the USE flag ansi"
die "This package needs gcl with USE=ansi"
fi
# gcl in the main tree is broken (bug #205803)
- ewarn "Please use gcl from http://repo.or.cz/w/gentoo-lisp-overlay.git"
+ ewarn "Please use gcl from the lisp overlay"
fi
if use X && ! built_with_use sci-visualization/gnuplot gd wxwindows; then
@@ -112,6 +113,9 @@ src_unpack() {
-i "${S}"/src/Makefile.in \
|| die "sed for rmaxima failed"
fi
+ # don't install imaxima, since we have a separate package for it
+ sed -i -e '/^SUBDIRS/s/imaxima//' interfaces/emacs/Makefile.in \
+ || die "sed for imaxima failed"
}
src_compile() {
@@ -164,13 +168,7 @@ src_install() {
dosym ../${PN}/${PV}/doc /usr/share/doc/${PF} || die
if use emacs; then
- elisp-site-file-install "${FILESDIR}"/50maxima-gentoo.el
- # imaxima docs
- cd interfaces/emacs/imaxima
- insinto /usr/share/${PN}/${PV}/doc/imaxima
- doins ChangeLog NEWS README || die "installing imaxima docs failed"
- insinto /usr/share/${PN}/${PV}/doc/imaxima/imath-example
- doins imath-example/*.txt || die "installing imaxima docs failed"
+ elisp-site-file-install "${FILESDIR}"/50maxima-gentoo.el || die
fi
}
diff --git a/sci-mathematics/maxima/maxima-5.17.1.ebuild b/sci-mathematics/maxima/maxima-5.17.1.ebuild
deleted file mode 100644
index 773cf6458930..000000000000
--- a/sci-mathematics/maxima/maxima-5.17.1.ebuild
+++ /dev/null
@@ -1,194 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/maxima-5.17.1.ebuild,v 1.1 2008/12/20 09:36:19 grozin Exp $
-inherit eutils elisp-common
-
-DESCRIPTION="Free computer algebra environment based on Macsyma"
-HOMEPAGE="http://maxima.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2 AECA"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-
-# Supported lisps with readline
-SUPP_RL="gcl clisp"
-# Supported lisps without readline
-SUPP_NORL="cmucl sbcl"
-SUPP_LISPS="${SUPP_RL} ${SUPP_NORL}"
-# Default lisp if none selected
-DEF_LISP="sbcl"
-
-IUSE="latex emacs tk nls unicode xemacs X ${SUPP_LISPS} ${IUSE}"
-
-# Languages
-LANGS="es pt pt_BR"
-for lang in ${LANGS}; do
- IUSE="${IUSE} linguas_${lang}"
-done
-
-# >=maxima-5.15.0 includes imaxima; it depends on dev-tex/mh
-RDEPEND="!app-emacs/imaxima
- X? ( x11-misc/xdg-utils
- sci-visualization/gnuplot
- tk? ( dev-lang/tk ) )
- latex? ( || ( dev-texlive/texlive-latexrecommended
- >=app-text/tetex-3
- app-text/ptex ) )
- emacs? ( virtual/emacs
- latex? ( app-emacs/auctex dev-tex/mh ) )
- xemacs? ( virtual/xemacs
- latex? ( app-emacs/auctex
- || ( dev-tex/mh =dev-texlive/texlive-mathextra-2007* ) ) )"
-
-# create lisp dependencies
-for LISP in ${SUPP_LISPS}; do
- RDEPEND="${RDEPEND} ${LISP}? ( dev-lisp/${LISP} )"
- DEF_DEP="${DEF_DEP} !${LISP}? ( "
-done
-DEF_DEP="${DEF_DEP} dev-lisp/${DEF_LISP}"
-for LISP in ${SUPP_NORL}; do
- RDEPEND="${RDEPEND} ${LISP}? ( app-misc/rlwrap )"
- [[ ${LISP} = ${DEF_LISP} ]] && \
- DEF_DEP="${DEF_DEP} app-misc/rlwrap"
-done
-for LISP in ${SUPP_LISPS}; do
- DEF_DEP="${DEF_DEP} )"
-done
-
-RDEPEND="${RDEPEND}
- ${DEF_DEP}"
-
-DEPEND="${RDEPEND}
- sys-apps/texinfo"
-
-TEXMF=/usr/share/texmf-site
-
-pkg_setup() {
- LISPS=""
-
- for LISP in ${SUPP_LISPS}; do
- use ${LISP} && LISPS="${LISPS} ${LISP}"
- done
-
- if [ -z "${LISPS}" ]; then
- ewarn "No lisp specified in USE flags, choosing ${DEF_LISP} as default"
- LISPS="${DEF_LISP}"
- fi
-
- RL=""
-
- for LISP in ${SUPP_NORL}; do
- use ${LISP} && RL="yes"
- done
-
- if use gcl; then
- if ! built_with_use dev-lisp/gcl ansi; then
- eerror "gcl must be emerged with the USE flag ansi"
- die "This package needs gcl with USE=ansi"
- fi
- # gcl in the main tree is broken (bug #205803)
- ewarn "Please use gcl from http://repo.or.cz/w/gentoo-lisp-overlay.git"
- fi
-
- if use X && ! built_with_use sci-visualization/gnuplot gd wxwindows; then
- elog "To benefit full plotting capability of maxima,"
- elog "enable the gd USE flag for sci-visualization/gnuplot"
- elog "And if you are planning to use wxmaxima, you want to"
- elog "also add the wxwindows flag to gnuplot."
- epause 5
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # use xdg-open to view ps, pdf
- epatch "${FILESDIR}"/${PN}-xdg-utils.patch
- epatch "${FILESDIR}"/${PN}-no-init-files.patch
- # remove rmaxima if neither cmucl nor sbcl
- if [ -z "${RL}" ]; then
- sed -e '/^@WIN32_FALSE@bin_SCRIPTS/s/rmaxima//' \
- -i "${S}"/src/Makefile.in \
- || die "sed for rmaxima failed"
- fi
-}
-
-src_compile() {
- local myconf=""
- for LISP in ${LISPS}; do
- myconf="${myconf} --enable-${LISP}"
- done
-
- # remove xmaxima if no tk
- if use tk; then
- myconf="${myconf} --with-wish=wish"
- else
- myconf="${myconf} --with-wish=none"
- sed -i \
- -e '/^SUBDIRS/s/xmaxima//' \
- interfaces/Makefile.in || die "sed for tk failed"
- fi
-
- # enable existing translated doc
- if use nls; then
- for lang in ${LANGS}; do
- if use "linguas_${lang}"; then
- myconf="${myconf} --enable-lang-${lang}"
- use unicode && myconf="${myconf} --enable-lang-${lang}-utf8"
- fi
- done
- fi
-
- econf ${myconf}
- emake || die "emake failed"
-}
-
-src_install() {
- einstall emacsdir="${D}${SITELISP}/${PN}" || die "einstall failed"
-
- use tk && make_desktop_entry xmaxima xmaxima \
- /usr/share/${PN}/${PV}/xmaxima/maxima-new.png \
- "Science;Math;Education"
-
- if use latex; then
- insinto ${TEXMF}/tex/latex/emaxima
- doins interfaces/emacs/emaxima/emaxima.sty
- fi
-
- # do not use dodoc because interfaces can't read compressed files
- # read COPYING before attempt to remove it from dodoc
- insinto /usr/share/${PN}/${PV}/doc
- doins AUTHORS COPYING README README.lisps || die
- dodir /usr/share/doc
- dosym ../${PN}/${PV}/doc /usr/share/doc/${PF} || die
-
- if use emacs; then
- elisp-site-file-install "${FILESDIR}"/50maxima-gentoo.el
- # imaxima docs
- cd interfaces/emacs/imaxima
- insinto /usr/share/${PN}/${PV}/doc/imaxima
- doins ChangeLog NEWS README || die "installing imaxima docs failed"
- insinto /usr/share/${PN}/${PV}/doc/imaxima/imath-example
- doins imath-example/*.txt || die "installing imaxima docs failed"
- fi
-}
-
-pkg_preinst() {
- # some lisps do not read compress info files (bug #176411)
- for infofile in "${D}"/usr/share/info/*.bz2 ; do
- bunzip2 "${infofile}"
- done
- for infofile in "${D}"/usr/share/info/*.gz ; do
- gunzip "${infofile}"
- done
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- use latex && mktexlsr
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}