summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2013-04-20 14:56:08 +0000
committerAndrey Grozin <grozin@gentoo.org>2013-04-20 14:56:08 +0000
commit3458c2f43718967ed43c58a325f7b12dd001ab17 (patch)
treef1de70b0fbc1838f4c12a8a2e8801818d543388b /sci-mathematics
parentRemove old versions. (diff)
downloadgentoo-2-3458c2f43718967ed43c58a325f7b12dd001ab17.tar.gz
gentoo-2-3458c2f43718967ed43c58a325f7b12dd001ab17.tar.bz2
gentoo-2-3458c2f43718967ed43c58a325f7b12dd001ab17.zip
Version bump
(Portage version: 2.2.0_alpha173/cvs/Linux i686, signed Manifest commit with key 0x3AFFCE974D34BD8C!)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/fricas/ChangeLog10
-rw-r--r--sci-mathematics/fricas/fricas-1.2.0.ebuild90
-rw-r--r--sci-mathematics/fricas/metadata.xml2
3 files changed, 99 insertions, 3 deletions
diff --git a/sci-mathematics/fricas/ChangeLog b/sci-mathematics/fricas/ChangeLog
index 86c3a9497d74..9b09827088f9 100644
--- a/sci-mathematics/fricas/ChangeLog
+++ b/sci-mathematics/fricas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/fricas
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fricas/ChangeLog,v 1.17 2012/09/18 15:32:40 grozin Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fricas/ChangeLog,v 1.18 2013/04/20 14:56:08 grozin Exp $
+
+*fricas-1.2.0 (20 Apr 2013)
+
+ 20 Apr 2013; Andrey Grozin <grozin@gentoo.org> +fricas-1.2.0.ebuild,
+ metadata.xml:
+ Version bump
*fricas-1.1.8 (18 Sep 2012)
diff --git a/sci-mathematics/fricas/fricas-1.2.0.ebuild b/sci-mathematics/fricas/fricas-1.2.0.ebuild
new file mode 100644
index 000000000000..6bf7f3a9f16c
--- /dev/null
+++ b/sci-mathematics/fricas/fricas-1.2.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fricas/fricas-1.2.0.ebuild,v 1.1 2013/04/20 14:56:08 grozin Exp $
+EAPI=5
+inherit eutils multilib elisp-common autotools
+
+DESCRIPTION="FriCAS is a fork of Axiom computer algebra system"
+HOMEPAGE="http://${PN}.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-full.tar.bz2"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Supported lisps, number 0 is the default
+LISPS=( sbcl cmucl gcl ecl clisp clozurecl )
+# command name: . means just ${LISP}
+COMS=( . lisp . . . ccl )
+
+IUSE="${LISPS[*]} X emacs gmp"
+RDEPEND="X? ( x11-libs/libXpm x11-libs/libICE )
+ emacs? ( virtual/emacs )
+ gmp? ( dev-libs/gmp )"
+
+# Generating lisp deps
+n=${#LISPS[*]}
+for ((n--; n > 0; n--)); do
+ LISP=${LISPS[$n]}
+ RDEPEND="${RDEPEND} ${LISP}? ( dev-lisp/${LISP}:= ) !${LISP}? ("
+done
+RDEPEND="${RDEPEND} dev-lisp/${LISPS[0]}:="
+n=${#LISPS[*]}
+for ((n--; n > 0; n--)); do
+ RDEPEND="${RDEPEND} )"
+done
+
+DEPEND="${RDEPEND}"
+
+# necessary for clisp and gcl
+RESTRICT="strip"
+
+src_configure() {
+ local LISP n
+ LISP=sbcl
+ n=${#LISPS[*]}
+ for ((n--; n > 0; n--)); do
+ if use ${LISPS[$n]}; then
+ LISP=${COMS[$n]}
+ if [ "${LISP}" = "." ]; then
+ LISP=${LISPS[$n]}
+ fi
+ fi
+ done
+ einfo "Using lisp: ${LISP}"
+
+ # aldor is not yet in portage
+ econf --disable-aldor --with-lisp=${LISP} $(use_with X x) $(use_with gmp)
+}
+
+src_compile() {
+ # bug #300132
+ emake -j1
+}
+
+src_test() {
+ emake -j1 all-input
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ dodoc README FAQ
+
+ if use emacs; then
+ sed -e "s|(setq load-path (cons (quote \"/usr/$(get_libdir)/fricas/emacs\") load-path)) ||" \
+ -i "${D}"/usr/bin/efricas \
+ || die "sed efricas failed"
+ elisp-install ${PN} "${D}"/usr/$(get_libdir)/${PN}/emacs/*.el
+ elisp-site-file-install "${FILESDIR}"/64${PN}-gentoo.el
+ else
+ rm "${D}"/usr/bin/efricas || die "rm efricas failed"
+ fi
+ rm -r "${D}"/usr/$(get_libdir)/${PN}/emacs || die "rm -r emacs failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sci-mathematics/fricas/metadata.xml b/sci-mathematics/fricas/metadata.xml
index 128f19c5c089..36dc623ca456 100644
--- a/sci-mathematics/fricas/metadata.xml
+++ b/sci-mathematics/fricas/metadata.xml
@@ -21,6 +21,6 @@ FriCAS is a fork of Axiom computer algebra system.
<flag name='ecl'>Add support for Embeddable Common Lisp
(<pkg>dev-lisp/ecls</pkg>)</flag>
<flag name='clozurecl'>Add support for Clozure Common Lisp
- (<pkg>dev-lisp/closurecl</pkg>)</flag>
+ (<pkg>dev-lisp/clozurecl</pkg>)</flag>
</use>
</pkgmetadata>