summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-06-19 16:17:15 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-06-19 16:17:15 +0000
commit2ca394b29a52608ef7ac9c591129558fb52bd56a (patch)
treef1df9c7978e3c84d557c8fcf29f1098b422dce2d /sci-mathematics
parentremove old (diff)
downloadgentoo-2-2ca394b29a52608ef7ac9c591129558fb52bd56a.tar.gz
gentoo-2-2ca394b29a52608ef7ac9c591129558fb52bd56a.tar.bz2
gentoo-2-2ca394b29a52608ef7ac9c591129558fb52bd56a.zip
More texinfo fix, thanks Caster Ti.Vector (bug #473756)
(Portage version: 2.2.01.22013-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/ChangeLog7
-rw-r--r--sci-mathematics/octave/files/octave-3.6.3-rcond.patch210
-rw-r--r--sci-mathematics/octave/files/octave-3.6.4-texinfo.patch72
-rw-r--r--sci-mathematics/octave/octave-3.6.3.ebuild130
-rw-r--r--sci-mathematics/octave/octave-3.6.4.ebuild5
5 files changed, 54 insertions, 370 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index 9dc9044cd6c3..39ebce9b8459 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/octave
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.138 2013/05/22 04:27:11 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.139 2013/06/19 16:17:15 bicatali Exp $
+
+ 19 Jun 2013; Sébastien Fabbro <bicatali@gentoo.org>
+ -files/octave-3.6.3-rcond.patch, -octave-3.6.3.ebuild,
+ files/octave-3.6.4-texinfo.patch, octave-3.6.4.ebuild:
+ More texinfo fix, thanks Caster Ti.Vector (bug #473756)
22 May 2013; Sébastien Fabbro <bicatali@gentoo.org>
+files/octave-3.6.4-texinfo.patch, octave-3.6.4.ebuild:
diff --git a/sci-mathematics/octave/files/octave-3.6.3-rcond.patch b/sci-mathematics/octave/files/octave-3.6.3-rcond.patch
deleted file mode 100644
index 45dcecc07f00..000000000000
--- a/sci-mathematics/octave/files/octave-3.6.3-rcond.patch
+++ /dev/null
@@ -1,210 +0,0 @@
-Description: Fix rcond function
- Use new copy of data for full factorization if positive definite cholesky
- factorization fails.
-Origin: upstream, http://hg.savannah.gnu.org/hgweb/octave/rev/197774b411ec
-Bug: http://savannah.gnu.org/bugs/?37336
-Applied-Upstream: version, 3.6.4
-Last-Update: 2012-09-14
----
-This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
-diff --git a/liboctave/CMatrix.cc b/liboctave/CMatrix.cc
---- a/liboctave/CMatrix.cc
-+++ b/liboctave/CMatrix.cc
-@@ -1786,13 +1786,15 @@
- else if (typ == MatrixType::Full || typ == MatrixType::Hermitian)
- {
- double anorm = -1.0;
-- ComplexMatrix atmp = *this;
-- Complex *tmp_data = atmp.fortran_vec ();
-
- if (typ == MatrixType::Hermitian)
- {
- octave_idx_type info = 0;
- char job = 'L';
-+
-+ ComplexMatrix atmp = *this;
-+ Complex *tmp_data = atmp.fortran_vec ();
-+
- anorm = atmp.abs().sum().
- row(static_cast<octave_idx_type>(0)).max();
-
-@@ -1829,6 +1831,9 @@
- {
- octave_idx_type info = 0;
-
-+ ComplexMatrix atmp = *this;
-+ Complex *tmp_data = atmp.fortran_vec ();
-+
- Array<octave_idx_type> ipvt (dim_vector (nr, 1));
- octave_idx_type *pipvt = ipvt.fortran_vec ();
-
-@@ -2098,8 +2103,10 @@
- {
- info = 0;
- char job = 'L';
-+
- ComplexMatrix atmp = *this;
- Complex *tmp_data = atmp.fortran_vec ();
-+
- anorm = atmp.abs().sum().row(static_cast<octave_idx_type>(0)).max();
-
- F77_XFCN (zpotrf, ZPOTRF, (F77_CONST_CHAR_ARG2 (&job, 1), nr,
-diff --git a/liboctave/dMatrix.cc b/liboctave/dMatrix.cc
---- a/liboctave/dMatrix.cc
-+++ b/liboctave/dMatrix.cc
-@@ -1454,13 +1454,15 @@
- else if (typ == MatrixType::Full || typ == MatrixType::Hermitian)
- {
- double anorm = -1.0;
-- Matrix atmp = *this;
-- double *tmp_data = atmp.fortran_vec ();
-
- if (typ == MatrixType::Hermitian)
- {
- octave_idx_type info = 0;
- char job = 'L';
-+
-+ Matrix atmp = *this;
-+ double *tmp_data = atmp.fortran_vec ();
-+
- anorm = atmp.abs().sum().
- row(static_cast<octave_idx_type>(0)).max();
-
-@@ -1495,6 +1497,9 @@
- {
- octave_idx_type info = 0;
-
-+ Matrix atmp = *this;
-+ double *tmp_data = atmp.fortran_vec ();
-+
- Array<octave_idx_type> ipvt (dim_vector (nr, 1));
- octave_idx_type *pipvt = ipvt.fortran_vec ();
-
-@@ -1760,8 +1765,10 @@
- {
- info = 0;
- char job = 'L';
-+
- Matrix atmp = *this;
- double *tmp_data = atmp.fortran_vec ();
-+
- anorm = atmp.abs().sum().row(static_cast<octave_idx_type>(0)).max();
-
- F77_XFCN (dpotrf, DPOTRF, (F77_CONST_CHAR_ARG2 (&job, 1), nr,
-@@ -1838,6 +1845,7 @@
-
- Matrix atmp = *this;
- double *tmp_data = atmp.fortran_vec ();
-+
- if(anorm < 0.)
- anorm = atmp.abs().sum().row(static_cast<octave_idx_type>(0)).max();
-
-diff --git a/liboctave/fCMatrix.cc b/liboctave/fCMatrix.cc
---- a/liboctave/fCMatrix.cc
-+++ b/liboctave/fCMatrix.cc
-@@ -1782,13 +1782,15 @@
- else if (typ == MatrixType::Full || typ == MatrixType::Hermitian)
- {
- float anorm = -1.0;
-- FloatComplexMatrix atmp = *this;
-- FloatComplex *tmp_data = atmp.fortran_vec ();
-
- if (typ == MatrixType::Hermitian)
- {
- octave_idx_type info = 0;
- char job = 'L';
-+
-+ FloatComplexMatrix atmp = *this;
-+ FloatComplex *tmp_data = atmp.fortran_vec ();
-+
- anorm = atmp.abs().sum().
- row(static_cast<octave_idx_type>(0)).max();
-
-@@ -1825,6 +1827,9 @@
- {
- octave_idx_type info = 0;
-
-+ FloatComplexMatrix atmp = *this;
-+ FloatComplex *tmp_data = atmp.fortran_vec ();
-+
- Array<octave_idx_type> ipvt (dim_vector (nr, 1));
- octave_idx_type *pipvt = ipvt.fortran_vec ();
-
-@@ -2094,8 +2099,10 @@
- {
- info = 0;
- char job = 'L';
-+
- FloatComplexMatrix atmp = *this;
- FloatComplex *tmp_data = atmp.fortran_vec ();
-+
- anorm = atmp.abs().sum().row(static_cast<octave_idx_type>(0)).max();
-
- F77_XFCN (cpotrf, CPOTRF, (F77_CONST_CHAR_ARG2 (&job, 1), nr,
-diff --git a/liboctave/fMatrix.cc b/liboctave/fMatrix.cc
---- a/liboctave/fMatrix.cc
-+++ b/liboctave/fMatrix.cc
-@@ -1454,13 +1454,15 @@
- else if (typ == MatrixType::Full || typ == MatrixType::Hermitian)
- {
- float anorm = -1.0;
-- FloatMatrix atmp = *this;
-- float *tmp_data = atmp.fortran_vec ();
-
- if (typ == MatrixType::Hermitian)
- {
- octave_idx_type info = 0;
- char job = 'L';
-+
-+ FloatMatrix atmp = *this;
-+ float *tmp_data = atmp.fortran_vec ();
-+
- anorm = atmp.abs().sum().
- row(static_cast<octave_idx_type>(0)).max();
-
-@@ -1495,6 +1497,9 @@
- {
- octave_idx_type info = 0;
-
-+ FloatMatrix atmp = *this;
-+ float *tmp_data = atmp.fortran_vec ();
-+
- Array<octave_idx_type> ipvt (dim_vector (nr, 1));
- octave_idx_type *pipvt = ipvt.fortran_vec ();
-
-@@ -1760,8 +1765,10 @@
- {
- info = 0;
- char job = 'L';
-+
- FloatMatrix atmp = *this;
- float *tmp_data = atmp.fortran_vec ();
-+
- anorm = atmp.abs().sum().row(static_cast<octave_idx_type>(0)).max();
-
- F77_XFCN (spotrf, SPOTRF, (F77_CONST_CHAR_ARG2 (&job, 1), nr,
-@@ -1838,6 +1845,7 @@
-
- FloatMatrix atmp = *this;
- float *tmp_data = atmp.fortran_vec ();
-+
- if(anorm < 0.)
- anorm = atmp.abs().sum().row(static_cast<octave_idx_type>(0)).max();
-
-diff --git a/src/DLD-FUNCTIONS/rcond.cc b/src/DLD-FUNCTIONS/rcond.cc
---- a/src/DLD-FUNCTIONS/rcond.cc
-+++ b/src/DLD-FUNCTIONS/rcond.cc
-@@ -93,4 +93,12 @@
- %!assert( rcond ([1 1; 2 1]), 1/9)
- %!assert( rcond (magic (4)), 0, eps)
-
-+%!shared x, sx
-+%! x = [-5.25, -2.25; -2.25, 1] * eps () + ones (2) / 2;
-+%! sx = [-5.25, -2.25; -2.25, 1] * eps ("single") + ones (2) / 2;
-+%!assert (rcond (x) < eps ());
-+%!assert (rcond (sx) < eps ('single'));
-+%!assert (rcond (x*i) < eps ());
-+%!assert (rcond (sx*i) < eps ('single'));
-+
- */
-
diff --git a/sci-mathematics/octave/files/octave-3.6.4-texinfo.patch b/sci-mathematics/octave/files/octave-3.6.4-texinfo.patch
index be67d23c98b9..67f876f7bc42 100644
--- a/sci-mathematics/octave/files/octave-3.6.4-texinfo.patch
+++ b/sci-mathematics/octave/files/octave-3.6.4-texinfo.patch
@@ -1,6 +1,6 @@
-diff -ur octave-3.6.4-orig/doc/interpreter/audio.texi octave-3.6.4/doc/interpreter/audio.texi
---- octave-3.6.4-orig/doc/interpreter/audio.texi 2013-02-21 21:37:50.000000000 +0100
-+++ octave-3.6.4/doc/interpreter/audio.texi 2013-05-01 23:23:21.338665377 +0200
+diff -Nur octave-3.6.4.orig/doc/interpreter/audio.texi octave-3.6.4/doc/interpreter/audio.texi
+--- octave-3.6.4.orig/doc/interpreter/audio.texi 2013-02-21 12:37:50.000000000 -0800
++++ octave-3.6.4/doc/interpreter/audio.texi 2013-06-19 08:52:43.259790240 -0700
@@ -146,18 +146,18 @@
Load the RIFF/WAVE sound file @var{filename}, and return the samples
in vector @var{y}. If the file contains multichannel data, then
@@ -28,9 +28,9 @@ diff -ur octave-3.6.4-orig/doc/interpreter/audio.texi octave-3.6.4/doc/interpret
Return the number of samples (@var{n}) and channels (@var{ch})
instead of the audio data.
@seealso{@ref{doc-wavwrite,,wavwrite}}
-diff -ur octave-3.6.4-orig/doc/interpreter/io.texi octave-3.6.4/doc/interpreter/io.texi
---- octave-3.6.4-orig/doc/interpreter/io.texi 2013-02-21 21:37:51.000000000 +0100
-+++ octave-3.6.4/doc/interpreter/io.texi 2013-05-01 22:59:08.537582265 +0200
+diff -Nur octave-3.6.4.orig/doc/interpreter/io.texi octave-3.6.4/doc/interpreter/io.texi
+--- octave-3.6.4.orig/doc/interpreter/io.texi 2013-02-21 12:37:51.000000000 -0800
++++ octave-3.6.4/doc/interpreter/io.texi 2013-06-19 08:52:43.259790240 -0700
@@ -1391,22 +1391,22 @@
for the file. Valid values for @var{arch} are:
@@ -60,9 +60,9 @@ diff -ur octave-3.6.4-orig/doc/interpreter/io.texi octave-3.6.4/doc/interpreter/
Cray floating format.
@end table
-diff -ur octave-3.6.4-orig/doc/interpreter/octave.texi octave-3.6.4/doc/interpreter/octave.texi
---- octave-3.6.4-orig/doc/interpreter/octave.texi 2013-02-21 21:19:23.000000000 +0100
-+++ octave-3.6.4/doc/interpreter/octave.texi 2013-05-01 22:58:26.561420772 +0200
+diff -Nur octave-3.6.4.orig/doc/interpreter/octave.texi octave-3.6.4/doc/interpreter/octave.texi
+--- octave-3.6.4.orig/doc/interpreter/octave.texi 2013-02-21 12:19:23.000000000 -0800
++++ octave-3.6.4/doc/interpreter/octave.texi 2013-06-19 08:52:43.259790240 -0700
@@ -129,7 +129,9 @@
@sp 2
@multitable @columnfractions 0.4 0.025 0.65
@@ -74,9 +74,9 @@ diff -ur octave-3.6.4-orig/doc/interpreter/octave.texi octave-3.6.4/doc/interpre
@tab
@c this is a spacer column
@tab
-diff -ur octave-3.6.4-orig/doc/interpreter/plot.texi octave-3.6.4/doc/interpreter/plot.texi
---- octave-3.6.4-orig/doc/interpreter/plot.texi 2013-02-21 21:37:52.000000000 +0100
-+++ octave-3.6.4/doc/interpreter/plot.texi 2013-05-01 23:07:36.586442176 +0200
+diff -Nur octave-3.6.4.orig/doc/interpreter/plot.texi octave-3.6.4/doc/interpreter/plot.texi
+--- octave-3.6.4.orig/doc/interpreter/plot.texi 2013-02-21 12:37:52.000000000 -0800
++++ octave-3.6.4/doc/interpreter/plot.texi 2013-06-19 08:52:43.260790204 -0700
@@ -2707,21 +2707,20 @@
Set the data aspect ratio of the current axes. The aspect ratio is
a normalized 3-element vector representing the span of the x, y, and
@@ -200,9 +200,9 @@ diff -ur octave-3.6.4-orig/doc/interpreter/plot.texi octave-3.6.4/doc/interprete
Return a structure, @var{appdata}, whose fields correspond to the appdata
properties.
@end deftypefn
-diff -ur octave-3.6.4-orig/doc/interpreter/poly.texi octave-3.6.4/doc/interpreter/poly.texi
---- octave-3.6.4-orig/doc/interpreter/poly.texi 2013-02-21 21:37:52.000000000 +0100
-+++ octave-3.6.4/doc/interpreter/poly.texi 2013-05-01 23:28:59.515000917 +0200
+diff -Nur octave-3.6.4.orig/doc/interpreter/poly.texi octave-3.6.4/doc/interpreter/poly.texi
+--- octave-3.6.4.orig/doc/interpreter/poly.texi 2013-02-21 12:37:52.000000000 -0800
++++ octave-3.6.4/doc/interpreter/poly.texi 2013-06-19 08:52:43.260790204 -0700
@@ -82,8 +82,8 @@
(@var{x}-@var{mu}(1))/@var{mu}(2).
If @var{x} is a vector or matrix, the polynomial is evaluated for each of
@@ -214,9 +214,9 @@ diff -ur octave-3.6.4-orig/doc/interpreter/poly.texi octave-3.6.4/doc/interprete
@deftypefnx {Function File} {[@var{y}, @var{dy}] =} polyval (@var{p}, @var{x}, @var{s}, @var{mu})
In addition to evaluating the polynomial, the second output
represents the prediction interval, @var{y} +/- @var{dy}, which
-diff -ur octave-3.6.4-orig/doc/interpreter/set.texi octave-3.6.4/doc/interpreter/set.texi
---- octave-3.6.4-orig/doc/interpreter/set.texi 2013-02-21 21:37:52.000000000 +0100
-+++ octave-3.6.4/doc/interpreter/set.texi 2013-05-01 23:30:00.161810855 +0200
+diff -Nur octave-3.6.4.orig/doc/interpreter/set.texi octave-3.6.4/doc/interpreter/set.texi
+--- octave-3.6.4.orig/doc/interpreter/set.texi 2013-02-21 12:37:52.000000000 -0800
++++ octave-3.6.4/doc/interpreter/set.texi 2013-06-19 08:52:43.260790204 -0700
@@ -150,8 +150,9 @@
3 4
@end group
@@ -228,9 +228,9 @@ diff -ur octave-3.6.4-orig/doc/interpreter/set.texi octave-3.6.4/doc/interpreter
Return index vectors @var{ia} and @var{ib} such that @code{a(ia)} and
@code{b(ib)} are disjoint sets whose union is @var{c}.
-diff -ur octave-3.6.4-orig/doc/interpreter/signal.texi octave-3.6.4/doc/interpreter/signal.texi
---- octave-3.6.4-orig/doc/interpreter/signal.texi 2013-02-21 21:37:52.000000000 +0100
-+++ octave-3.6.4/doc/interpreter/signal.texi 2013-05-01 23:31:41.111833440 +0200
+diff -Nur octave-3.6.4.orig/doc/interpreter/signal.texi octave-3.6.4/doc/interpreter/signal.texi
+--- octave-3.6.4.orig/doc/interpreter/signal.texi 2013-02-21 12:37:52.000000000 -0800
++++ octave-3.6.4/doc/interpreter/signal.texi 2013-06-19 08:52:43.261790169 -0700
@@ -454,17 +454,17 @@
For fastest computation, @var{n} should factor into a small number of
@@ -255,9 +255,9 @@ diff -ur octave-3.6.4-orig/doc/interpreter/signal.texi octave-3.6.4/doc/interpre
Plot the pass band, stop band and phase response of @var{h} rather
than returning them.
@end deftypefn
-diff -ur octave-3.6.4-orig/doc/interpreter/strings.texi octave-3.6.4/doc/interpreter/strings.texi
---- octave-3.6.4-orig/doc/interpreter/strings.texi 2013-02-21 21:37:52.000000000 +0100
-+++ octave-3.6.4/doc/interpreter/strings.texi 2013-05-01 22:27:29.646311770 +0200
+diff -Nur octave-3.6.4.orig/doc/interpreter/strings.texi octave-3.6.4/doc/interpreter/strings.texi
+--- octave-3.6.4.orig/doc/interpreter/strings.texi 2013-02-21 12:37:52.000000000 -0800
++++ octave-3.6.4/doc/interpreter/strings.texi 2013-06-19 08:52:43.261790169 -0700
@@ -1136,7 +1136,7 @@
@item %s
The word is parsed as a string.
@@ -267,9 +267,9 @@ diff -ur octave-3.6.4-orig/doc/interpreter/strings.texi octave-3.6.4/doc/interpr
@itemx %n
The word is parsed as a number and converted to double.
-diff -ur octave-3.6.4-orig/doc/interpreter/system.texi octave-3.6.4/doc/interpreter/system.texi
---- octave-3.6.4-orig/doc/interpreter/system.texi 2013-02-21 21:37:52.000000000 +0100
-+++ octave-3.6.4/doc/interpreter/system.texi 2013-05-01 23:45:09.981978551 +0200
+diff -Nur octave-3.6.4.orig/doc/interpreter/system.texi octave-3.6.4/doc/interpreter/system.texi
+--- octave-3.6.4.orig/doc/interpreter/system.texi 2013-02-21 12:37:52.000000000 -0800
++++ octave-3.6.4/doc/interpreter/system.texi 2013-06-19 08:52:43.261790169 -0700
@@ -839,7 +839,7 @@
@deftypefnx {Function File} {} datetick (@var{axis}, @var{form})
@deftypefnx {Function File} {} datetick (@dots{}, "keeplimits")
@@ -358,3 +358,21 @@ diff -ur octave-3.6.4-orig/doc/interpreter/system.texi octave-3.6.4/doc/interpre
Check out a license for @var{feature}, returning 1 on success and 0
on failure.
+diff -Nur octave-3.6.4.orig/doc/liboctave/liboctave.texi octave-3.6.4/doc/liboctave/liboctave.texi
+--- octave-3.6.4.orig/doc/liboctave/liboctave.texi 2013-02-21 12:19:23.000000000 -0800
++++ octave-3.6.4/doc/liboctave/liboctave.texi 2013-06-19 08:54:27.914379692 -0700
+@@ -80,10 +80,10 @@
+ @end ifnottex
+
+ @titlepage
+-@title{Octave C++ Classes}
+-@subtitle{Edition 1.0 for Octave version @value{VERSION}}
+-@subtitle{September 1993}
+-@author{John W. Eaton}
++@title@{Octave C++ Classes@}
++@subtitle@{Edition 1.0 for Octave version @value{VERSION}@}
++@subtitle@{September 1993@}
++@author@{John W. Eaton@}
+ @page
+ @vskip 0pt plus 1filll
+ Copyright @copyright{} 1996, 1997 John W. Eaton.
diff --git a/sci-mathematics/octave/octave-3.6.3.ebuild b/sci-mathematics/octave/octave-3.6.3.ebuild
deleted file mode 100644
index efbd05a5f5cd..000000000000
--- a/sci-mathematics/octave/octave-3.6.3.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.6.3.ebuild,v 1.6 2013/01/11 21:44:11 bicatali Exp $
-
-EAPI=4
-
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-inherit autotools-utils multilib toolchain-funcs fortran-2
-
-DESCRIPTION="High-level interactive language for numerical computations"
-LICENSE="GPL-3"
-HOMEPAGE="http://www.octave.org/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
-
-SLOT="0"
-IUSE="curl doc fftw +glpk gnuplot hdf5 +imagemagick opengl postscript
- +qhull +qrupdate readline +sparse static-libs X zlib"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-
-RDEPEND="
- app-text/ghostscript-gpl
- dev-libs/libpcre
- sys-libs/ncurses
- virtual/lapack
- curl? ( net-misc/curl )
- fftw? ( sci-libs/fftw:3.0 )
- glpk? ( sci-mathematics/glpk )
- gnuplot? ( sci-visualization/gnuplot )
- hdf5? ( sci-libs/hdf5 )
- imagemagick? ( || (
- media-gfx/graphicsmagick[cxx]
- media-gfx/imagemagick[cxx] ) )
- opengl? (
- media-libs/freetype:2
- media-libs/fontconfig
- >=x11-libs/fltk-1.3:1[opengl]
- virtual/glu )
- postscript? (
- app-text/epstool
- media-gfx/pstoedit
- media-gfx/transfig )
- qhull? ( media-libs/qhull )
- qrupdate? ( sci-libs/qrupdate )
- readline? ( sys-libs/readline )
- sparse? (
- sci-libs/arpack
- sci-libs/camd
- sci-libs/ccolamd
- sci-libs/cholmod
- sci-libs/colamd
- sci-libs/cxsparse
- sci-libs/umfpack )
- X? ( x11-libs/libX11 )
- zlib? ( sys-libs/zlib )"
-
-DEPEND="${RDEPEND}
- doc? (
- virtual/latex-base
- dev-texlive/texlive-genericrecommended
- sys-apps/texinfo )
- dev-util/gperf
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.4.3-{pkgbuilddir,help,texi}.patch
- "${FILESDIR}"/${PN}-3.6.3-{rcond,legendtext}.patch
-)
-
-src_prepare() {
- # nasty prefix hack for fltk:1 linking
- if use prefix && use opengl; then
- sed -i \
- -e "s:ldflags\`:ldflags\` -Wl,-rpath,${EPREFIX}/usr/$(get_libdir)/fltk-1:" \
- configure.ac
- fi
- autotools-utils_src_prepare
-}
-
-src_configure() {
- # occasional fail on install, force regeneration (bug #401189)
- rm doc/interpreter/contributors.texi || die
-
- # unfortunate dependency on mpi from hdf5 (bug #302621)
- use hdf5 && has_version sci-libs/hdf5[mpi] && \
- export CXX=mpicxx CC=mpicc FC=mpif77 F77=mpif77
-
- local myeconfargs=(
- --localstatedir="${EPREFIX}/var/state/octave"
- --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
- --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
- $(use_enable doc docs)
- $(use_enable readline)
- $(use_with curl)
- $(use_with fftw fftw3)
- $(use_with fftw fftw3f)
- $(use_with glpk)
- $(use_with hdf5)
- $(use_with opengl)
- $(use_with qhull)
- $(use_with qrupdate)
- $(use_with sparse arpack)
- $(use_with sparse umfpack)
- $(use_with sparse colamd)
- $(use_with sparse ccolamd)
- $(use_with sparse cholmod)
- $(use_with sparse cxsparse)
- $(use_with X x)
- $(use_with zlib z)
- )
- if use imagemagick; then
- if has_version media-gfx/graphicsmagick[cxx]; then
- myeconfargs+=( "--with-magick=GraphicsMagick" )
- else
- myeconfargs+=( "--with-magick=ImageMagick" )
- fi
- else
- myeconfargs+=( "--without-magick" )
- fi
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
- use doc && dodoc $(find doc -name \*.pdf)
- [[ -e test/fntests.log ]] && dodoc test/fntests.log
- echo "LDPATH=${EPREFIX}/usr/$(get_libdir)/${P}" > 99octave
- doenvd 99octave
-}
diff --git a/sci-mathematics/octave/octave-3.6.4.ebuild b/sci-mathematics/octave/octave-3.6.4.ebuild
index 7759c25fd2b8..626ac116c194 100644
--- a/sci-mathematics/octave/octave-3.6.4.ebuild
+++ b/sci-mathematics/octave/octave-3.6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.6.4.ebuild,v 1.2 2013/05/22 04:27:11 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.6.4.ebuild,v 1.3 2013/06/19 16:17:15 bicatali Exp $
EAPI=5
@@ -91,6 +91,7 @@ src_configure() {
--localstatedir="${EPREFIX}/var/state/octave"
--with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
--with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+ $(use_enable prefix rpath)
$(use_enable doc docs)
$(use_enable readline)
$(use_with curl)
@@ -126,6 +127,6 @@ src_install() {
autotools-utils_src_install
use doc && dodoc $(find doc -name \*.pdf)
[[ -e test/fntests.log ]] && dodoc test/fntests.log
- echo "LDPATH=${EPREFIX}/usr/$(get_libdir)/${P}" > 99octave
+ echo "LDPATH=${EROOT%/}/usr/$(get_libdir)/${P}" > 99octave
doenvd 99octave
}