summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-04-08 14:11:53 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-04-08 14:11:53 +0000
commit25da17bdd906f19ef6993589199617d6d9abdb9f (patch)
tree51d3411dd9bcd44edd794d0d7d4d0895b11c568a /sci-mathematics
parentinitial import (diff)
downloadgentoo-2-25da17bdd906f19ef6993589199617d6d9abdb9f.tar.gz
gentoo-2-25da17bdd906f19ef6993589199617d6d9abdb9f.tar.bz2
gentoo-2-25da17bdd906f19ef6993589199617d6d9abdb9f.zip
Version bump, closes bug 88254.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/mathomatic/ChangeLog9
-rw-r--r--sci-mathematics/mathomatic/Manifest3
-rw-r--r--sci-mathematics/mathomatic/files/digest-mathomatic-12.2c1
-rw-r--r--sci-mathematics/mathomatic/files/mathomatic-12.2c-makefile.patch13
-rw-r--r--sci-mathematics/mathomatic/mathomatic-12.2c.ebuild48
5 files changed, 73 insertions, 1 deletions
diff --git a/sci-mathematics/mathomatic/ChangeLog b/sci-mathematics/mathomatic/ChangeLog
index 6793e55c6582..3286cb542697 100644
--- a/sci-mathematics/mathomatic/ChangeLog
+++ b/sci-mathematics/mathomatic/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/mathomatic
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.3 2005/01/28 09:26:50 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.4 2005/04/08 14:11:53 cryos Exp $
+
+*mathomatic-12.2c (08 Apr 2005)
+
+ 08 Apr 2005; Marcus D. Hanwell <cryos@gentoo.org>
+ +files/mathomatic-12.2c-makefile.patch, +mathomatic-12.2c.ebuild:
+ Version bump, tidied ebuild up, made it respect user CFLAGS and added
+ src_test(). Closes bug 88254.
*mathomatic-11.7 (28 Jan 2005)
diff --git a/sci-mathematics/mathomatic/Manifest b/sci-mathematics/mathomatic/Manifest
index a320af4e32ce..20c87daccaf1 100644
--- a/sci-mathematics/mathomatic/Manifest
+++ b/sci-mathematics/mathomatic/Manifest
@@ -1,7 +1,10 @@
MD5 f7fc6104064e4205a348d72d3eceda8f mathomatic-11.1c.ebuild 1107
+MD5 68f3bbe0149a8925b6cdfaae70bd11bd mathomatic-12.2c.ebuild 1079
MD5 4d58b16a85fe02815b2a687dc304c3d2 mathomatic-11.7.ebuild 1045
MD5 d30029d34b71fbd4e473fb12b97f1a9f ChangeLog 998
MD5 3abf3c126ea8c41fa253de334525981d metadata.xml 454
MD5 f7d0b9c7af7201990a0beeadca7abf3f files/gentoo-mathomatic-11.1c.diff 957
MD5 29133f46e7d703ecfcbc9a083f272147 files/digest-mathomatic-11.1c 65
+MD5 a66d3410ebf4f68fa8f3d06b96db5e3c files/digest-mathomatic-12.2c 65
+MD5 5737182ffa7a3ae2f1a78636dc359916 files/mathomatic-12.2c-makefile.patch 428
MD5 33639f3880a1701b152bba5a2a9d61e5 files/digest-mathomatic-11.7 64
diff --git a/sci-mathematics/mathomatic/files/digest-mathomatic-12.2c b/sci-mathematics/mathomatic/files/digest-mathomatic-12.2c
new file mode 100644
index 000000000000..e7952d6cb467
--- /dev/null
+++ b/sci-mathematics/mathomatic/files/digest-mathomatic-12.2c
@@ -0,0 +1 @@
+MD5 d55931a8c047670db8e9377db94a64c3 mathomatic-12.2c.tgz 120410
diff --git a/sci-mathematics/mathomatic/files/mathomatic-12.2c-makefile.patch b/sci-mathematics/mathomatic/files/mathomatic-12.2c-makefile.patch
new file mode 100644
index 000000000000..bc29d3ea5a84
--- /dev/null
+++ b/sci-mathematics/mathomatic/files/mathomatic-12.2c-makefile.patch
@@ -0,0 +1,13 @@
+--- mathomatic-12.2c/makefile 2005-04-03 16:17:49.000000000 +0100
++++ mathomatic-12.2c-cryos/makefile 2005-04-08 15:02:20.000000000 +0100
+@@ -1,8 +1,8 @@
+ # Makefile for compiling Mathomatic under UNIX, GNU/Linux, and MacOS-X.
+
+ VERSION = `cat VERSION`
+-CFLAGS = -O -DUNIX -DVERSION=\"$(VERSION)\"
+-LDFLAGS = -s
++CFLAGS += -DUNIX -DVERSION=\"$(VERSION)\"
++LDFLAGS += -s
+ LIBS = -lm
+
+ CFLAGS += $(READLINE:1=-DREADLINE)
diff --git a/sci-mathematics/mathomatic/mathomatic-12.2c.ebuild b/sci-mathematics/mathomatic/mathomatic-12.2c.ebuild
new file mode 100644
index 000000000000..c9b87c7f2222
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-12.2c.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-12.2c.ebuild,v 1.1 2005/04/08 14:11:53 cryos Exp $
+
+inherit eutils
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.com/"
+SRC_URI="http://www.panix.com/~gesslein/${P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="icc"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses
+ icc? ( dev-lang/icc )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-makefile.patch
+}
+
+src_compile() {
+ if use icc; then
+ CC="icc" CFLAGS="-O3 -axKWNBP -ipo" LDFLAGS="-O3 -axKWNBP -ipo -limf" emake || die "emake failed"
+ else
+ emake || die "emake failed"
+ fi
+}
+
+src_test()
+{
+ make test || die "make test failed."
+}
+
+src_install() {
+ einstall || die "einstall failed."
+ dodoc changes.txt README.txt
+
+ dodir /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins tests/*in
+ dohtml ${D}/usr/doc/mathomatic/*.htm
+ rm -rf ${D}/usr/doc/mathomatic
+}