summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-08-24 13:39:48 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-08-24 13:39:48 +0000
commit14a226ae7aa99d46c3bd9134fcd166324177729c (patch)
tree3120419b4579cb5d506b375791c8f386329a46c1 /sci-mathematics
parentversion bump (diff)
downloadgentoo-2-14a226ae7aa99d46c3bd9134fcd166324177729c.tar.gz
gentoo-2-14a226ae7aa99d46c3bd9134fcd166324177729c.tar.bz2
gentoo-2-14a226ae7aa99d46c3bd9134fcd166324177729c.zip
fix build with lablgtk 2.16
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/coq/ChangeLog6
-rw-r--r--sci-mathematics/coq/coq-8.3_p4.ebuild3
-rw-r--r--sci-mathematics/coq/files/lablgtk216.patch45
3 files changed, 52 insertions, 2 deletions
diff --git a/sci-mathematics/coq/ChangeLog b/sci-mathematics/coq/ChangeLog
index 44cc26d91b70..20229384bfcc 100644
--- a/sci-mathematics/coq/ChangeLog
+++ b/sci-mathematics/coq/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/coq
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.70 2012/05/17 14:52:29 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.71 2012/08/24 13:39:48 aballier Exp $
+
+ 24 Aug 2012; Alexis Ballier <aballier@gentoo.org> +files/lablgtk216.patch,
+ coq-8.3_p4.ebuild:
+ fix build with lablgtk 2.16
*coq-8.3_p4 (17 May 2012)
diff --git a/sci-mathematics/coq/coq-8.3_p4.ebuild b/sci-mathematics/coq/coq-8.3_p4.ebuild
index 208172c49e02..9a0eb00cebf4 100644
--- a/sci-mathematics/coq/coq-8.3_p4.ebuild
+++ b/sci-mathematics/coq/coq-8.3_p4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.3_p4.ebuild,v 1.1 2012/05/17 14:52:29 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.3_p4.ebuild,v 1.2 2012/08/24 13:39:48 aballier Exp $
EAPI="2"
@@ -40,6 +40,7 @@ src_prepare() {
# wild sed which replaces \"$LABLGTKLIB\" by $LABLGTKLIB. Note
# during pl2-bump: Hmm, my patch did not get applied upstream?
sed -i "s/\\\\\"\\\$LABLGTKLIB\\\\\"/\\\$LABLGTKLIB/" configure
+ has_version '>=dev-ml/lablgtk-2.16' && epatch "${FILESDIR}/lablgtk216.patch"
}
src_configure() {
diff --git a/sci-mathematics/coq/files/lablgtk216.patch b/sci-mathematics/coq/files/lablgtk216.patch
new file mode 100644
index 000000000000..d123e89683e1
--- /dev/null
+++ b/sci-mathematics/coq/files/lablgtk216.patch
@@ -0,0 +1,45 @@
+Fix build with lablgtk 2.16.
+Apply conditionally because it uses new types introduced in this version.
+
+
+Index: coq-8.3pl4/ide/preferences.ml
+===================================================================
+--- coq-8.3pl4.orig/ide/preferences.ml
++++ coq-8.3pl4/ide/preferences.ml
+@@ -31,6 +31,10 @@ let mod_to_str (m:Gdk.Tags.modifier) =
+ | `CONTROL -> "CONTROL"
+ | `LOCK -> "LOCK"
+ | `SHIFT -> "SHIFT"
++ | `HYPER -> "HYPER"
++ | `META -> "META"
++ | `RELEASE -> "RELEASE"
++ | `SUPER -> "SUPER"
+
+ let (str_to_mod:string -> Gdk.Tags.modifier) =
+ function
+@@ -47,6 +51,10 @@ let (str_to_mod:string -> Gdk.Tags.modif
+ | "CONTROL" -> `CONTROL
+ | "LOCK" -> `LOCK
+ | "SHIFT" -> `SHIFT
++ | "HYPER" -> `HYPER
++ | "META" -> `META
++ | "RELEASE" -> `RELEASE
++ | "SUPER" -> `SUPER
+ | s -> `MOD1
+
+ type pref =
+Index: coq-8.3pl4/ide/utils/okey.ml
+===================================================================
+--- coq-8.3pl4.orig/ide/utils/okey.ml
++++ coq-8.3pl4/ide/utils/okey.ml
+@@ -47,6 +47,10 @@ let int_of_modifier = function
+ | `BUTTON3 -> 1024
+ | `BUTTON4 -> 2048
+ | `BUTTON5 -> 4096
++ | `HYPER -> 8192
++ | `META -> 16384
++ | `RELEASE -> 32768
++ | `SUPER -> 65536
+
+ let print_modifier l =
+ List.iter