summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-01-25 10:38:47 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-01-25 10:38:47 +0000
commit12342496cb25554884639a84dc39e33c8a7dad4a (patch)
treede7f81cf0fa02b13cb591dd4302df4ffbea587d8 /sci-mathematics
parentdev-util/poseidonCE moved to java junkyard. Only package using licence. see #... (diff)
downloadgentoo-2-12342496cb25554884639a84dc39e33c8a7dad4a.tar.gz
gentoo-2-12342496cb25554884639a84dc39e33c8a7dad4a.tar.bz2
gentoo-2-12342496cb25554884639a84dc39e33c8a7dad4a.zip
Version bump. Respect user flags and install primes stuff, desktop entries.
(Portage version: 2.1.4)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/mathomatic/ChangeLog10
-rw-r--r--sci-mathematics/mathomatic/files/digest-mathomatic-12.8.53
-rw-r--r--sci-mathematics/mathomatic/mathomatic-12.8.5.ebuild47
3 files changed, 58 insertions, 2 deletions
diff --git a/sci-mathematics/mathomatic/ChangeLog b/sci-mathematics/mathomatic/ChangeLog
index ed9c5f97b3fc..b10812a5b81f 100644
--- a/sci-mathematics/mathomatic/ChangeLog
+++ b/sci-mathematics/mathomatic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/mathomatic
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.21 2007/11/05 15:13:22 cryos Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.22 2008/01/25 10:38:46 bicatali Exp $
+
+*mathomatic-12.8.5 (25 Jan 2008)
+
+ 25 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +mathomatic-12.8.5.ebuild:
+ Version bump. Respect user flags and install primes stuff, desktop entries.
05 Nov 2007; Marcus D. Hanwell <cryos@gentoo.org>
mathomatic-12.7.9.ebuild:
diff --git a/sci-mathematics/mathomatic/files/digest-mathomatic-12.8.5 b/sci-mathematics/mathomatic/files/digest-mathomatic-12.8.5
new file mode 100644
index 000000000000..420f1f5f192a
--- /dev/null
+++ b/sci-mathematics/mathomatic/files/digest-mathomatic-12.8.5
@@ -0,0 +1,3 @@
+MD5 d2d2584c075dd91b9ad750c4e50e97f6 mathomatic-12.8.5.tar.bz2 137897
+RMD160 5bb6735bb7ac6eddadef9afcf43388c54a3e02fb mathomatic-12.8.5.tar.bz2 137897
+SHA256 483354bae13320c92ebcafdba0a64e28d341731884011234f302f62469147363 mathomatic-12.8.5.tar.bz2 137897
diff --git a/sci-mathematics/mathomatic/mathomatic-12.8.5.ebuild b/sci-mathematics/mathomatic/mathomatic-12.8.5.ebuild
new file mode 100644
index 000000000000..f04fb13a88c4
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-12.8.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-12.8.5.ebuild,v 1.1 2008/01/25 10:38:46 bicatali Exp $
+
+inherit eutils
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.com/"
+SRC_URI="http://www.panix.com/~gesslein/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses"
+
+src_compile() {
+ # respect user flags
+ sed -i \
+ -e '/^CFLAGS/ s/-O.//' \
+ -e '/^LDFLAGS/s/+= -lm/:= -lm $(LDFLAGS)/' \
+ makefile primes/makefile || die "sed failed"
+ emake READLINE=1 || die "emake failed"
+ emake -C primes || die "emake in primes failed"
+}
+
+src_test() {
+ emake test || die "emake test failed"
+ emake -C primes test || die "emake test in primes failed"
+}
+
+src_install() {
+ # It was easier just to install the files manually
+ dobin mathomatic primes/matho-{primes,pascal,sumsq} || die
+ dodoc changes.txt README.txt AUTHORS || die
+ doman mathomatic.1 primes/*.1 || die
+ doicon mathomatic.png || die
+ domenu mathomatic.desktop || die
+ newdoc primes/README.txt README-primes.txt || die
+ if use doc; then
+ dohtml doc/* || die
+ insinto /usr/share/doc/${PF}
+ doins tests factorial m4 || die
+ fi
+}