summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-03-06 08:50:00 +0000
committerUlrich Müller <ulm@gentoo.org>2010-03-06 08:50:00 +0000
commit0ab3e63b0ec5457e2e2cd86c62c3e7d908f00505 (patch)
treec0aaa701deed1f75b111b592ca524ecc0f62d3a5 /sci-mathematics
parentMoved dev-util/colorcvs to dev-vcs/colorcvs (diff)
downloadgentoo-2-0ab3e63b0ec5457e2e2cd86c62c3e7d908f00505.tar.gz
gentoo-2-0ab3e63b0ec5457e2e2cd86c62c3e7d908f00505.tar.bz2
gentoo-2-0ab3e63b0ec5457e2e2cd86c62c3e7d908f00505.zip
Fix test for Emacs version in maxima.el, bug 307349.
(Portage version: 2.2_rc63/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/maxima/ChangeLog8
-rw-r--r--sci-mathematics/maxima/files/maxima-5.20.1-emacs-version.patch12
-rw-r--r--sci-mathematics/maxima/maxima-5.20.1-r1.ebuild (renamed from sci-mathematics/maxima/maxima-5.20.1.ebuild)4
3 files changed, 22 insertions, 2 deletions
diff --git a/sci-mathematics/maxima/ChangeLog b/sci-mathematics/maxima/ChangeLog
index 5d3e0a3206d5..8b34c4951b63 100644
--- a/sci-mathematics/maxima/ChangeLog
+++ b/sci-mathematics/maxima/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/maxima
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/ChangeLog,v 1.75 2010/01/14 01:00:04 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/ChangeLog,v 1.76 2010/03/06 08:49:59 ulm Exp $
+
+*maxima-5.20.1-r1 (06 Mar 2010)
+
+ 06 Mar 2010; Ulrich Mueller <ulm@gentoo.org> -maxima-5.20.1.ebuild,
+ +maxima-5.20.1-r1.ebuild, +files/maxima-5.20.1-emacs-version.patch:
+ Fix test for Emacs version in maxima.el, bug 307349.
14 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org>
-maxima-5.14.0.ebuild, -maxima-5.17.1-r1.ebuild, maxima-5.18.1.ebuild,
diff --git a/sci-mathematics/maxima/files/maxima-5.20.1-emacs-version.patch b/sci-mathematics/maxima/files/maxima-5.20.1-emacs-version.patch
new file mode 100644
index 000000000000..d0ab0a5e768d
--- /dev/null
+++ b/sci-mathematics/maxima/files/maxima-5.20.1-emacs-version.patch
@@ -0,0 +1,12 @@
+http://bugs.gentoo.org/307349
+
+--- maxima-5.20.1-orig/interfaces/emacs/emaxima/maxima.el
++++ maxima-5.20.1/interfaces/emacs/emaxima/maxima.el
+@@ -2109,6 +2109,7 @@
+ ;;; The next functions are from comint.el in cvs emacs
+ (if (and
+ (not maxima-running-xemacs)
++ (<= emacs-major-version 21)
+ (or
+ (< emacs-major-version 21)
+ (< emacs-minor-version 3)))
diff --git a/sci-mathematics/maxima/maxima-5.20.1.ebuild b/sci-mathematics/maxima/maxima-5.20.1-r1.ebuild
index 9f9b23df5842..4b8f12657393 100644
--- a/sci-mathematics/maxima/maxima-5.20.1.ebuild
+++ b/sci-mathematics/maxima/maxima-5.20.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/maxima-5.20.1.ebuild,v 1.3 2010/01/14 01:00:04 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/maxima-5.20.1-r1.ebuild,v 1.1 2010/03/06 08:49:59 ulm Exp $
EAPI=2
inherit eutils elisp-common
@@ -105,6 +105,8 @@ src_prepare() {
# ClozureCL executable name is now ccl
epatch "${FILESDIR}"/${PN}-clozurecl.patch
+ epatch "${FILESDIR}"/${P}-emacs-version.patch
+
# remove rmaxima if not needed
if [ -z "${RL}" ]; then
sed -e '/^@WIN32_FALSE@bin_SCRIPTS/s/rmaxima//' \