summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-07 09:58:11 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-07 09:58:11 +0000
commit07e04771faf9e6954d76ee1b76b407719ba719bd (patch)
tree733c68206bad1437ddc1c746f74dea967f1cda5e /sci-mathematics/yafu
parentsci-mathematics/msieve: Version Bump; fixing several QA issues; drop old fixe... (diff)
downloadgentoo-2-07e04771faf9e6954d76ee1b76b407719ba719bd.tar.gz
gentoo-2-07e04771faf9e6954d76ee1b76b407719ba719bd.tar.bz2
gentoo-2-07e04771faf9e6954d76ee1b76b407719ba719bd.zip
sci-mathematics/yafu: Version Bump; fixing several QA issues; drop old fixes #444185
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-mathematics/yafu')
-rw-r--r--sci-mathematics/yafu/ChangeLog8
-rw-r--r--sci-mathematics/yafu/metadata.xml14
-rw-r--r--sci-mathematics/yafu/yafu-1.34.3.ebuild (renamed from sci-mathematics/yafu/yafu-1.33-r2.ebuild)42
-rw-r--r--sci-mathematics/yafu/yafu-9999.ebuild39
4 files changed, 49 insertions, 54 deletions
diff --git a/sci-mathematics/yafu/ChangeLog b/sci-mathematics/yafu/ChangeLog
index a7a470e6ab34..f66c6df00bc7 100644
--- a/sci-mathematics/yafu/ChangeLog
+++ b/sci-mathematics/yafu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/yafu
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yafu/ChangeLog,v 1.7 2013/01/06 15:39:41 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yafu/ChangeLog,v 1.8 2013/03/07 09:58:11 jlec Exp $
+
+*yafu-1.34.3 (07 Mar 2013)
+
+ 07 Mar 2013; Justin Lecher <jlec@gentoo.org> -yafu-1.33-r2.ebuild,
+ +yafu-1.34.3.ebuild, yafu-9999.ebuild, metadata.xml:
+ Version Bump; fixing several QA issues; drop old fixes #444185
06 Jan 2013; Patrick Lauer <patrick@gentoo.org> yafu-9999.ebuild:
Fixing ggnfs default paths for live ebuild too
diff --git a/sci-mathematics/yafu/metadata.xml b/sci-mathematics/yafu/metadata.xml
index 024d53db2936..0bc3be1ea5ed 100644
--- a/sci-mathematics/yafu/metadata.xml
+++ b/sci-mathematics/yafu/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>patrick@gentoo.org</email>
- <name>Patrick Lauer</name>
- </maintainer>
- <use>
- <flag name="sieve">Use msieve for the sieving steps of NFS</flag>
- </use>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+ <use>
+ <flag name="sieve">Use msieve for the sieving steps of NFS</flag>
+ </use>
</pkgmetadata>
diff --git a/sci-mathematics/yafu/yafu-1.33-r2.ebuild b/sci-mathematics/yafu/yafu-1.34.3.ebuild
index a6d63db3cf36..85a85d8d13b5 100644
--- a/sci-mathematics/yafu/yafu-1.33-r2.ebuild
+++ b/sci-mathematics/yafu/yafu-1.34.3.ebuild
@@ -1,23 +1,26 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yafu/yafu-1.33-r2.ebuild,v 1.1 2013/01/06 15:37:17 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yafu/yafu-1.34.3.ebuild,v 1.1 2013/03/07 09:58:11 jlec Exp $
+
+EAPI=5
+
+inherit eutils versionator
-EAPI=4
DESCRIPTION="Yet another factoring utility"
HOMEPAGE="http://sourceforge.net/projects/yafu/"
-SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
-
-inherit eutils
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${PN}-$(get_version_component_range 1-2)-src.zip"
-LICENSE="public-domain"
SLOT="0"
+LICENSE="public-domain"
KEYWORDS="~amd64 ~x86"
# nfs is overloaded, so using less confusing sieve here
IUSE="+sieve"
-DEPEND="dev-libs/gmp
+DEPEND="
+ dev-libs/gmp
sci-mathematics/gmp-ecm
- sieve? ( sci-mathematics/msieve
+ sieve? (
+ sci-mathematics/msieve
sci-mathematics/ggnfs )"
RDEPEND="${DEPEND}"
@@ -29,31 +32,22 @@ src_prepare() {
sed -i -e 's:\"config.h\":<gmp-ecm/config.h>:g' top/driver.c || die "Failed to rectify things"
sed -i -e 's:# LIBS += -L../msieve/lib/linux/x86_64:LIBS += -lmsieve -lz -ldl:' Makefile || die "Failed to rectify things"
sed -i -e 's:CFLAGS = -g:#CFLAGS = -g:' Makefile || die "Failed to rectify things"
+ sed -i -e '/$(LIBS)$/s:$(CC):$(CC) $(LDFLAGS):g' Makefile || die
# proper ggnfs default path
sed -i -e 's~strcpy(fobj->nfs_obj.ggnfs_dir,"./");~strcpy(fobj->nfs_obj.ggnfs_dir,"/usr/bin/");~' factor/factor_common.c || die "Failed to rectify things"
-
}
src_compile() {
+ local VAR=""
# hmm, not that useful:
#VAR="TIMING=1 "
- if use sieve; then
- VAR+="NFS=1"
- fi
- if use amd64; then
- emake $VAR x86_64 || die "Failed to build"
- fi
- if use x86; then
- emake $VAR x86 || die "Failed to build"
- fi
+ use sieve && VAR+="NFS=1"
+ use amd64 && emake $VAR x86_64
+ use x86 && emake $VAR x86
}
src_install() {
- mkdir -p "${D}/usr/bin/"
- cp "${S}/yafu" "${D}/usr/bin/" || die "Failed to install"
- mkdir -p "${D}/usr/share/doc/${PN}"
- cp "${S}/docfile.txt" "${D}/usr/share/doc/${PN}/yafu.txt" || die "Failed to install"
- cp "${S}/README" "${D}/usr/share/doc/${PN}/" || die "Failed to install"
- cp "${S}/yafu.ini" "${D}/usr/share/doc/${PN}/yafu.ini.example" || die "Failed to install"
+ dobin "${S}/yafu"
+ dodoc docfile.txt README yafu.ini
}
diff --git a/sci-mathematics/yafu/yafu-9999.ebuild b/sci-mathematics/yafu/yafu-9999.ebuild
index 41e0e6d21dda..53cf76c2c558 100644
--- a/sci-mathematics/yafu/yafu-9999.ebuild
+++ b/sci-mathematics/yafu/yafu-9999.ebuild
@@ -1,24 +1,27 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yafu/yafu-9999.ebuild,v 1.2 2013/01/06 15:39:41 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yafu/yafu-9999.ebuild,v 1.3 2013/03/07 09:58:11 jlec Exp $
+
+EAPI=5
+
+inherit eutils subversion versionator
-EAPI=4
DESCRIPTION="Yet another factoring utility"
HOMEPAGE="http://sourceforge.net/projects/yafu/"
#SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
ESVN_REPO_URI="https://yafu.svn.sourceforge.net/svnroot/yafu"
-inherit eutils subversion
-
-LICENSE="public-domain"
SLOT="0"
+LICENSE="public-domain"
KEYWORDS=""
# nfs is overloaded, so using less confusing sieve here
IUSE="+sieve"
-DEPEND="dev-libs/gmp
+DEPEND="
+ dev-libs/gmp
sci-mathematics/gmp-ecm
- sieve? ( sci-mathematics/msieve
+ sieve? (
+ sci-mathematics/msieve
sci-mathematics/ggnfs )"
RDEPEND="${DEPEND}"
@@ -31,31 +34,23 @@ src_prepare() {
sed -i -e 's:\"config.h\":<gmp-ecm/config.h>:g' top/driver.c || die "Failed to rectify things"
sed -i -e 's:# LIBS += -L../msieve/lib/linux/x86_64:LIBS += -lmsieve -lz -ldl:' Makefile || die "Failed to rectify things"
sed -i -e 's:CFLAGS = -g:#CFLAGS = -g:' Makefile || die "Failed to rectify things"
+ sed -i -e '/$(LIBS)$/s:$(CC):$(CC) $(LDFLAGS):g' Makefile || die
# proper ggnfs default path
sed -i -e 's~strcpy(fobj->nfs_obj.ggnfs_dir,"./");~strcpy(fobj->nfs_obj.ggnfs_dir,"/usr/bin/");~' factor/factor_common.c || die "Failed to rectify things"
}
src_compile() {
+ local VAR=""
cd trunk
# hmm, not that useful:
#VAR="TIMING=1 "
- if use sieve; then
- VAR+="NFS=1"
- fi
- if use amd64; then
- emake $VAR x86_64 || die "Failed to build"
- fi
- if use x86; then
- emake $VAR x86 || die "Failed to build"
- fi
+ use sieve && VAR+="NFS=1"
+ use amd64 && emake $VAR x86_64
+ use x86 && emake $VAR x86
}
src_install() {
- mkdir -p "${D}/usr/bin/"
- cp "${S}/trunk/yafu" "${D}/usr/bin/" || die "Failed to install"
- mkdir -p "${D}/usr/share/doc/${PN}"
- cp "${S}/trunk/docfile.txt" "${D}/usr/share/doc/${PN}/yafu.txt" || die "Failed to install"
- cp "${S}/trunk/README" "${D}/usr/share/doc/${PN}/" || die "Failed to install"
- cp "${S}/trunk/yafu.ini" "${D}/usr/share/doc/${PN}/yafu.ini.example" || die "Failed to install"
+ dobin "${S}/yafu"
+ dodoc docfile.txt README yafu.ini
}