summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2005-01-14 17:05:53 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2005-01-14 17:05:53 +0000
commit0a1e6ff4e7b5296fb3fd69e07f4772a45d19efb5 (patch)
tree3cb78e7e28d82e89b6cdd004fd255b2b3ea4bef2 /sci-mathematics/yacas
parentAdd media-libs/giflib to DEPEND to resolve stupid header file problems #77809. (diff)
downloadgentoo-2-0a1e6ff4e7b5296fb3fd69e07f4772a45d19efb5.tar.gz
gentoo-2-0a1e6ff4e7b5296fb3fd69e07f4772a45d19efb5.tar.bz2
gentoo-2-0a1e6ff4e7b5296fb3fd69e07f4772a45d19efb5.zip
version bump and some fixes, see changelog
Diffstat (limited to 'sci-mathematics/yacas')
-rw-r--r--sci-mathematics/yacas/ChangeLog12
-rw-r--r--sci-mathematics/yacas/Manifest2
-rw-r--r--sci-mathematics/yacas/files/1.0.57.patch59
-rw-r--r--sci-mathematics/yacas/files/digest-yacas-1.0.571
-rw-r--r--sci-mathematics/yacas/yacas-1.0.57.ebuild45
5 files changed, 118 insertions, 1 deletions
diff --git a/sci-mathematics/yacas/ChangeLog b/sci-mathematics/yacas/ChangeLog
index d0ba2aafc015..ab2436bf283d 100644
--- a/sci-mathematics/yacas/ChangeLog
+++ b/sci-mathematics/yacas/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sci-mathematics/yacas
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/ChangeLog,v 1.3 2005/01/14 09:12:36 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/ChangeLog,v 1.4 2005/01/14 17:05:53 phosphan Exp $
+
+*yacas-1.0.57 (14 Jan 2005)
+
+ 14 Jan 2005; Patrick Kursawe <phosphan@gentoo.org> +files/1.0.57.patch,
+ +yacas-1.0.57.ebuild:
+ Removing GMP support because it looks like it is not maintained upstream (does
+ not compile without the patches from 1.0.56 and fails on several tests).
+ Added optional media-libs/glut dependency.
+ Switching off the plugin size optimization because it causes yacas to segfault
+ when trying to build the plugins (source: BSD ports).
14 Jan 2005; Patrick Kursawe <phosphan@gentoo.org>
+files/opengl-gcc3.4.patch, yacas-1.0.56.ebuild:
diff --git a/sci-mathematics/yacas/Manifest b/sci-mathematics/yacas/Manifest
index f2248d7b1930..d16e888bf94e 100644
--- a/sci-mathematics/yacas/Manifest
+++ b/sci-mathematics/yacas/Manifest
@@ -1,5 +1,7 @@
+MD5 0569d94a0aee21f8cd42ed9feee6dd20 yacas-1.0.57.ebuild 1258
MD5 20a61dc92ddb7f0745c4bdb15abb999f yacas-1.0.56.ebuild 1337
MD5 bfacb9cce56757c49dddc40737b74520 ChangeLog 1986
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 5c748030f6e6f803d4e272ce57a31361 files/digest-yacas-1.0.56 130
+MD5 e222e9a7debd7c3e79ee700005276c93 files/digest-yacas-1.0.57 65
MD5 b49a5413d88ccb8242bc01dedb22afd0 files/opengl-gcc3.4.patch 227
diff --git a/sci-mathematics/yacas/files/1.0.57.patch b/sci-mathematics/yacas/files/1.0.57.patch
new file mode 100644
index 000000000000..3e0bbb5958fb
--- /dev/null
+++ b/sci-mathematics/yacas/files/1.0.57.patch
@@ -0,0 +1,59 @@
+diff -ru ../yacas-1.0.57.orig/./plugins/filescanner/plugin.cc ./plugins/filescanner/plugin.cc
+--- ../yacas-1.0.57.orig/./plugins/filescanner/plugin.cc 2003-08-24 17:43:25.000000000 +0200
++++ ./plugins/filescanner/plugin.cc 2005-01-14 10:24:32.001007832 +0100
+@@ -81,7 +81,7 @@
+ return NEW FileScannerPlugin;
+ }
+
+-};
++}
+
+
+
+diff -ru ../yacas-1.0.57.orig/./plugins/pcre/plugin.cc ./plugins/pcre/plugin.cc
+--- ../yacas-1.0.57.orig/./plugins/pcre/plugin.cc 2003-08-24 17:39:59.000000000 +0200
++++ ./plugins/pcre/plugin.cc 2005-01-14 10:24:32.000007971 +0100
+@@ -180,7 +180,7 @@
+ return NEW PcrePlugin;
+ }
+
+-};
++}
+
+
+
+--- plugins/opengl/openglapi.stub 2005-01-11 17:45:19.164377640 +0000
++++ plugins/opengl/openglapi.stub.new 2005-01-11 17:45:26.625243416 +0000
+@@ -144,7 +144,7 @@
+ {
+ return NULL;
+ }
+-};
++}
+ #endif //HAVE_GL_GLUT_H
+ ");
+
+diff -ru ../yacas-1.0.57.orig/scripts/compile.rep/compilecpp.ys ./scripts/compile.rep/compilecpp.ys
+--- ../yacas-1.0.57.orig/scripts/compile.rep/compilecpp.ys 2004-12-20 19:10:26.000000000 +0100
++++ ./scripts/compile.rep/compilecpp.ys 2005-01-14 15:01:24.416631846 +0100
+@@ -395,7 +395,7 @@
+
+ // The define OPTIMIZE_COMPILED_PLUGIN_SIZE should be defined somewhere else.
+ #ifndef WIN32 // some macro expansion is failing on Win platform, no idea why.
+-#define OPTIMIZE_COMPILED_PLUGIN_SIZE
++//#define OPTIMIZE_COMPILED_PLUGIN_SIZE
+ #endif // WIN32
+
+ #ifdef OPTIMIZE_COMPILED_PLUGIN_SIZE
+diff -ru ../yacas-1.0.57.orig/src/libmath.cpp ./src/libmath.cpp
+--- ../yacas-1.0.57.orig/src/libmath.cpp 2004-12-25 11:33:49.000000000 +0100
++++ ./src/libmath.cpp 2005-01-14 15:00:20.263439049 +0100
+@@ -17,7 +17,7 @@
+
+ // The define OPTIMIZE_COMPILED_PLUGIN_SIZE should be defined somewhere else.
+ #ifndef WIN32 // some macro expansion is failing on Win platform, no idea why.
+-#define OPTIMIZE_COMPILED_PLUGIN_SIZE
++//#define OPTIMIZE_COMPILED_PLUGIN_SIZE
+ #endif // WIN32
+
+ #ifdef OPTIMIZE_COMPILED_PLUGIN_SIZE
diff --git a/sci-mathematics/yacas/files/digest-yacas-1.0.57 b/sci-mathematics/yacas/files/digest-yacas-1.0.57
new file mode 100644
index 000000000000..f2622f493613
--- /dev/null
+++ b/sci-mathematics/yacas/files/digest-yacas-1.0.57
@@ -0,0 +1 @@
+MD5 0e5161457cb7d818aa8009676998696b yacas-1.0.57.tar.gz 1974503
diff --git a/sci-mathematics/yacas/yacas-1.0.57.ebuild b/sci-mathematics/yacas/yacas-1.0.57.ebuild
new file mode 100644
index 000000000000..8405b4783a9f
--- /dev/null
+++ b/sci-mathematics/yacas/yacas-1.0.57.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.0.57.ebuild,v 1.1 2005/01/14 17:05:53 phosphan Exp $
+
+inherit eutils
+
+IUSE="glut"
+
+DESCRIPTION="very powerful general purpose Computer Algebra System"
+HOMEPAGE="http://yacas.sourceforge.net/"
+SRC_URI="http://${PN}.sourceforge.net/backups/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+DEPEND="virtual/libc
+ >=sys-apps/sed-4
+ glut? ( media-libs/glut )"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}.patch
+ if ! use glut; then
+ sed -e 's:opengl::g' -i plugins/Makefile.in || die "sed (opengl) failed"
+ sed -e 's/\(^PLUGINDOCSCHAPTERS.*\)opengl.chapt\(.*\)/\1 \2/' -i \
+ manmake/Makefile.in || die 'sed (manmake) failed'
+ fi
+}
+
+src_compile() {
+ econf --with-numlib=native || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install-strip || die
+
+ dodoc AUTHORS INSTALL NEWS README TODO
+ mv ${D}/usr/share/${PN}/documentation ${D}/usr/share/doc/${PF}/html
+ rmdir ${D}/usr/include/
+ rm ${D}/usr/share/${PN}/include/win32*
+}