summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-10-09 10:08:43 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-10-09 10:08:43 +0000
commitbf5371462a56979a9d5ec7e5c12c13ca4ef7ccae (patch)
tree662c0cd3360ed9ab34ab2dfb762b519138ad27d7 /sci-mathematics/wxmaxima
parentia64 stable wrt #240375 (diff)
downloadgentoo-2-bf5371462a56979a9d5ec7e5c12c13ca4ef7ccae.tar.gz
gentoo-2-bf5371462a56979a9d5ec7e5c12c13ca4ef7ccae.tar.bz2
gentoo-2-bf5371462a56979a9d5ec7e5c12c13ca4ef7ccae.zip
Version bump
(Portage version: 2.2_rc11/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-mathematics/wxmaxima')
-rw-r--r--sci-mathematics/wxmaxima/ChangeLog8
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-0.7.6.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/sci-mathematics/wxmaxima/ChangeLog b/sci-mathematics/wxmaxima/ChangeLog
index dffa7d02ad90..adc63e3a762d 100644
--- a/sci-mathematics/wxmaxima/ChangeLog
+++ b/sci-mathematics/wxmaxima/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/wxmaxima
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/ChangeLog,v 1.18 2008/06/19 15:16:24 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/ChangeLog,v 1.19 2008/10/09 10:08:43 bicatali Exp $
+
+*wxmaxima-0.7.6 (09 Oct 2008)
+
+ 09 Oct 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +wxmaxima-0.7.6.ebuild:
+ Version bump
19 Jun 2008; Sébastien Fabbro <bicatali@gentoo.org>
wxmaxima-0.7.5.ebuild:
diff --git a/sci-mathematics/wxmaxima/wxmaxima-0.7.6.ebuild b/sci-mathematics/wxmaxima/wxmaxima-0.7.6.ebuild
new file mode 100644
index 000000000000..21ea9d96ec94
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-0.7.6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/wxmaxima-0.7.6.ebuild,v 1.1 2008/10/09 10:08:43 bicatali Exp $
+
+WX_GTK_VER="2.8"
+EAPI="2"
+inherit eutils wxwidgets fdo-mime
+
+MYP=wxMaxima-${PV}
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit."
+HOMEPAGE="http://wxmaxima.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="unicode"
+
+DEPEND=">=dev-libs/libxml2-2.5.0
+ x11-libs/wxGTK:2.8"
+RDEPEND="${DEPEND}
+ sci-visualization/gnuplot[wxwindows]
+ >=sci-mathematics/maxima-5.15.0"
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ # consistent package names
+ sed -i \
+ -e "s:${datadir}/wxMaxima:${datadir}/${PN}:g" \
+ Makefile.in data/Makefile.in || die "sed failed"
+
+ sed -i \
+ -e 's:share/wxMaxima:share/wxmaxima:g' \
+ src/wxMaxima.cpp || die "sed failed"
+}
+
+src_configure() {
+ econf \
+ --enable-dnd \
+ --enable-printing \
+ --with-wx-config=${WX_CONFIG} \
+ $(use_unicode unicode-glyphs)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon wxmaxima.png
+ make_desktop_entry wxmaxima wxMaxima wxmaxima
+ dodir /usr/share/doc/${PF}
+ dosym /usr/share/${PN}/README /usr/share/doc/${PF}/README
+ dodoc AUTHORS
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}