summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-04-09 06:40:05 +0000
committerJustin Lecher <jlec@gentoo.org>2013-04-09 06:40:05 +0000
commit4d6481f0b1d43ed9ee8cc3705f36de97a8c0897e (patch)
treec307358df9ac3412754d0ad6ad56d8c97de4f616 /sci-mathematics/wxmaxima
parentsci-chemistry/gabedit: Version Bump, #465128 (diff)
downloadgentoo-2-4d6481f0b1d43ed9ee8cc3705f36de97a8c0897e.tar.gz
gentoo-2-4d6481f0b1d43ed9ee8cc3705f36de97a8c0897e.tar.bz2
gentoo-2-4d6481f0b1d43ed9ee8cc3705f36de97a8c0897e.zip
sci-mathematics/wxmaxima: Add LINGUAS support and various other fixes, thanks Julian Ospald (hasufell) for the patch, #463624
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-mathematics/wxmaxima')
-rw-r--r--sci-mathematics/wxmaxima/ChangeLog9
-rw-r--r--sci-mathematics/wxmaxima/metadata.xml4
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-12.09.0.ebuild43
3 files changed, 40 insertions, 16 deletions
diff --git a/sci-mathematics/wxmaxima/ChangeLog b/sci-mathematics/wxmaxima/ChangeLog
index dd9091b8127e..4853fd0ad11c 100644
--- a/sci-mathematics/wxmaxima/ChangeLog
+++ b/sci-mathematics/wxmaxima/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/wxmaxima
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/ChangeLog,v 1.40 2012/09/16 15:57:30 grozin Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/ChangeLog,v 1.41 2013/04/09 06:40:05 jlec Exp $
+
+ 09 Apr 2013; Justin Lecher <jlec@gentoo.org> wxmaxima-12.09.0.ebuild,
+ metadata.xml:
+ Add LINGUAS support and various other fixes, thanks Julian Ospald (hasufell)
+ for the patch, #463624
*wxmaxima-12.09.0 (16 Sep 2012)
diff --git a/sci-mathematics/wxmaxima/metadata.xml b/sci-mathematics/wxmaxima/metadata.xml
index 1abfd4dd7951..e7440d19a252 100644
--- a/sci-mathematics/wxmaxima/metadata.xml
+++ b/sci-mathematics/wxmaxima/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-mathematics</herd>
-<longdescription lang="en">
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
wxMaxima is a wxWidgets GUI for the computer algebra system maxima.
Most of maxima functions are accessible through menus, some have
dialogs. The input line has command history (up-key, down-key) and
diff --git a/sci-mathematics/wxmaxima/wxmaxima-12.09.0.ebuild b/sci-mathematics/wxmaxima/wxmaxima-12.09.0.ebuild
index 890a6a5e7cae..c3784e17a861 100644
--- a/sci-mathematics/wxmaxima/wxmaxima-12.09.0.ebuild
+++ b/sci-mathematics/wxmaxima/wxmaxima-12.09.0.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/wxmaxima-12.09.0.ebuild,v 1.1 2012/09/16 15:57:30 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/wxmaxima-12.09.0.ebuild,v 1.2 2013/04/09 06:40:05 jlec Exp $
+
+EAPI=5
-EAPI=4
WX_GTK_VER="2.8"
-inherit eutils wxwidgets fdo-mime
+
+inherit eutils gnome2-utils wxwidgets fdo-mime
MYP=wxMaxima-${PV}
@@ -15,10 +17,10 @@ SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="unicode"
-DEPEND="dev-libs/libxml2:2
- x11-libs/wxGTK:2.8"
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}"
RDEPEND="${DEPEND}
media-fonts/jsmath
sci-visualization/gnuplot[wxwidgets]
@@ -27,6 +29,8 @@ RDEPEND="${DEPEND}
S="${WORKDIR}/${MYP}"
src_prepare() {
+ local i
+
# consistent package names
sed -e "s:\${datadir}/wxMaxima:\${datadir}/${PN}:g" \
-i Makefile.in data/Makefile.in || die "sed failed"
@@ -34,28 +38,43 @@ src_prepare() {
sed -e 's:share/wxMaxima:share/wxmaxima:g' \
-i src/wxMaxima.cpp src/wxMaximaFrame.cpp src/Config.cpp \
|| die "sed failed"
+
+ # correct gettext behavior
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(cd "${S}"/locales ; echo *.mo) ; do
+ if ! has ${i%.mo} ${LINGUAS} ; then
+ sed -i \
+ -e "/^WXMAXIMA_LINGUAS/s# ${i%.mo}##" \
+ -e "/^WXWIN_LINGUAS/s# ${i%.mo}##" \
+ locales/Makefile.in || die
+ fi
+ done
+ fi
}
src_configure() {
econf \
- --enable-dnd \
--enable-printing \
- --with-wx-config=${WX_CONFIG} \
- $(use_enable unicode unicode-glyphs)
+ --with-wx-config=${WX_CONFIG}
}
src_install () {
default
- doicon data/wxmaxima.png
+ doicon -s 128 data/wxmaxima.png
make_desktop_entry wxmaxima wxMaxima wxmaxima
- dodir /usr/share/doc/${PF}
dosym /usr/share/${PN}/README /usr/share/doc/${PF}/README
}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
pkg_postinst() {
+ gnome2_icon_cache_update
fdo-mime_desktop_database_update
}
pkg_postrm() {
+ gnome2_icon_cache_update
fdo-mime_desktop_database_update
}