summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2010-11-09 17:48:56 +0000
committerThomas Kahle <tomka@gentoo.org>2010-11-09 17:48:56 +0000
commitf4a4080aef93d4eb3c15bd9bb861e2eb05e10361 (patch)
treed4d553dbe7c34058797f47a9fc74467270b0ae50 /sci-mathematics/topcom/topcom-0.16.2.ebuild
parentVersion bump to 3.1.0. Start cf-execd after cf-serverd. (diff)
downloadgentoo-2-f4a4080aef93d4eb3c15bd9bb861e2eb05e10361.tar.gz
gentoo-2-f4a4080aef93d4eb3c15bd9bb861e2eb05e10361.tar.bz2
gentoo-2-f4a4080aef93d4eb3c15bd9bb861e2eb05e10361.zip
New package: sci-mathematics/topcom, revised import from sci overlay, fixes bug 285619
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics/topcom/topcom-0.16.2.ebuild')
-rw-r--r--sci-mathematics/topcom/topcom-0.16.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-mathematics/topcom/topcom-0.16.2.ebuild b/sci-mathematics/topcom/topcom-0.16.2.ebuild
new file mode 100644
index 000000000000..869cd6d81722
--- /dev/null
+++ b/sci-mathematics/topcom/topcom-0.16.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/topcom/topcom-0.16.2.ebuild,v 1.1 2010/11/09 17:48:55 tomka Exp $
+
+EAPI="2"
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="A package for computing Triangulations Of Point Configurations and Oriented Matroids."
+SRC_URI="http://www.uni-bayreuth.de/departments/wirtschaftsmathematik/rambau/Software/TOPCOM-$PV.tar.gz
+ doc? ( http://www.rambau.wm.uni-bayreuth.de/TOPCOM/TOPCOM-manual.html )"
+HOMEPAGE="http://www.rambau.wm.uni-bayreuth.de/TOPCOM/"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="doc examples"
+
+DEPEND=">=dev-libs/gmp-4.1-r1
+ >=sci-libs/cddlib-094f"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/TOPCOM-${PV}
+
+src_prepare () {
+ # Don't compile internal GMP and CDD ...
+ epatch "${FILESDIR}"/${PN}-${PV}-no-internal-libs.patch
+
+ # ... and link in tree versions:
+ append-libs -lgmp -lgmpxx -lcddgmp
+
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die
+
+ if use doc; then
+ dohtml "${DISTDIR}"/TOPCOM-manual.html || die
+ fi
+
+ if use examples; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -R "${S}"/examples/* "${D}"/usr/share/doc/${PF}/examples || die
+ fi
+}