summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-08-10 05:56:51 +0000
committerJustin Lecher <jlec@gentoo.org>2012-08-10 05:56:51 +0000
commit28deca57b301cfdbac97fd7d40a15203afab1476 (patch)
treeb9e8bd7c943f01eb2121aee9aca756b1b9ef4aad /sci-mathematics/spass
parentBuild with -fPIC on s390x #430554 by Raúl Porcel. (diff)
downloadgentoo-2-28deca57b301cfdbac97fd7d40a15203afab1476.tar.gz
gentoo-2-28deca57b301cfdbac97fd7d40a15203afab1476.tar.bz2
gentoo-2-28deca57b301cfdbac97fd7d40a15203afab1476.zip
sci-mathematics/spass: Respect CFLAGS, #430676; add missing USE=examples
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/spass')
-rw-r--r--sci-mathematics/spass/ChangeLog5
-rw-r--r--sci-mathematics/spass/metadata.xml16
-rw-r--r--sci-mathematics/spass/spass-3.7.ebuild32
3 files changed, 29 insertions, 24 deletions
diff --git a/sci-mathematics/spass/ChangeLog b/sci-mathematics/spass/ChangeLog
index 25ab86f80a91..298e8b0b4fa6 100644
--- a/sci-mathematics/spass/ChangeLog
+++ b/sci-mathematics/spass/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/spass
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spass/ChangeLog,v 1.2 2012/08/10 00:31:56 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spass/ChangeLog,v 1.3 2012/08/10 05:56:51 jlec Exp $
+
+ 10 Aug 2012; Justin Lecher <jlec@gentoo.org> spass-3.7.ebuild, metadata.xml:
+ Respect CFLAGS, #430676; add missing USE=examples
10 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> metadata.xml:
Fix metadata.
diff --git a/sci-mathematics/spass/metadata.xml b/sci-mathematics/spass/metadata.xml
index 55174776cec2..c836a3b70c4d 100644
--- a/sci-mathematics/spass/metadata.xml
+++ b/sci-mathematics/spass/metadata.xml
@@ -1,15 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
- <email>gienah@gentoo.org</email>
-</maintainer>
-<herd>sci-mathematics</herd>
-<longdescription lang='en'>
+ <maintainer>
+ <email>gienah@gentoo.org</email>
+ </maintainer>
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
SPASS: An Automated Theorem Prover for First-Order Logic with Equality.
</longdescription>
-<use>
- <flag name='isabelle'>Add integration support for the Isabelle/HOL
+ <use>
+ <flag name="isabelle">Add integration support for the Isabelle/HOL
theorem prover.</flag>
-</use>
+ </use>
</pkgmetadata>
diff --git a/sci-mathematics/spass/spass-3.7.ebuild b/sci-mathematics/spass/spass-3.7.ebuild
index b2c167570ec6..8fa6746b9f9b 100644
--- a/sci-mathematics/spass/spass-3.7.ebuild
+++ b/sci-mathematics/spass/spass-3.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spass/spass-3.7.ebuild,v 1.1 2012/05/30 00:53:38 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spass/spass-3.7.ebuild,v 1.2 2012/08/10 05:56:51 jlec Exp $
-EAPI="4"
+EAPI=4
inherit versionator
@@ -15,32 +15,34 @@ SRC_URI="http://www.spass-prover.org/download/sources/${MY_P}.tgz"
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc isabelle"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples isabelle"
RDEPEND=""
DEPEND="${RDEPEND}
- isabelle? (
- >=sci-mathematics/isabelle-2011.1-r1
- )"
+ isabelle? ( >=sci-mathematics/isabelle-2011.1-r1 )"
S="${WORKDIR}/SPASS-${PV}"
+src_prepare() {
+ #epatch "${FILESDIR}"/${P}-fla
+ sed \
+ -e "s:-O3:${CFLAGS}:g" \
+ -i configure || die
+}
+
src_install() {
- emake DESTDIR="${D}" install
+ default
if use examples; then
- dodir /usr/share/${PN}/examples
- insinto /usr/share/${PN}/examples
+ insinto /usr/share/${PN}/
doins -r examples
fi
if use isabelle; then
- ISABELLE_HOME="$(isabelle getenv ISABELLE_HOME | cut -d'=' -f 2)" \
- || die "isabelle getenv ISABELLE_HOME failed"
- if [[ -z "${ISABELLE_HOME}" ]]; then
- die "ISABELLE_HOME empty"
- fi
+ ISABELLE_HOME="$(isabelle getenv ISABELLE_HOME | cut -d'=' -f 2)"
+ [[ -z "${ISABELLE_HOME}" ]] || die "ISABELLE_HOME empty"
+
dodir "${ISABELLE_HOME}/contrib/${PN}-${PV}/etc"
cat <<- EOF >> "${S}/settings"
SPASS_HOME="${ROOT}usr/bin"