summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-07-04 15:17:32 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-07-04 15:17:32 +0000
commit68aa59afa83eb7088023bfb0fa3adaebdb681e39 (patch)
treed4008457983cdec2f163c4d686aad662d2609d6a /sci-mathematics/scilab
parentFix Manifest (a couple of files mysteriously ended up with an off-by-one size... (diff)
downloadgentoo-2-68aa59afa83eb7088023bfb0fa3adaebdb681e39.tar.gz
gentoo-2-68aa59afa83eb7088023bfb0fa3adaebdb681e39.tar.bz2
gentoo-2-68aa59afa83eb7088023bfb0fa3adaebdb681e39.zip
Added patch from CVS head to fix crashing scicos due to gtk. This fixes bug #138252.
(Portage version: 2.1.1_pre2-r1)
Diffstat (limited to 'sci-mathematics/scilab')
-rw-r--r--sci-mathematics/scilab/ChangeLog7
-rw-r--r--sci-mathematics/scilab/files/scilab-4.0-gtk-fix.patch23
-rw-r--r--sci-mathematics/scilab/scilab-4.0.ebuild3
3 files changed, 31 insertions, 2 deletions
diff --git a/sci-mathematics/scilab/ChangeLog b/sci-mathematics/scilab/ChangeLog
index 0f803fe5ba6b..b6ae451b7b8f 100644
--- a/sci-mathematics/scilab/ChangeLog
+++ b/sci-mathematics/scilab/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/scilab
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/ChangeLog,v 1.23 2006/06/01 15:34:16 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/ChangeLog,v 1.24 2006/07/04 15:17:32 markusle Exp $
+
+ 04 Jul 2006; Markus Dittrich <markusle@gentoo.org>
+ +files/scilab-4.0-gtk-fix.patch, scilab-4.0.ebuild:
+ Added patch from CVS head to fix crashing scicos due to gtk.
+ This fixes bug #138252.
01 Jun 2006; Markus Dittrich <markusle@gentoo.org> scilab-4.0.ebuild:
Fixed small typo and appended -pthread to LDFLAGS to fix linking
diff --git a/sci-mathematics/scilab/files/scilab-4.0-gtk-fix.patch b/sci-mathematics/scilab/files/scilab-4.0-gtk-fix.patch
new file mode 100644
index 000000000000..a6b01366c1b0
--- /dev/null
+++ b/sci-mathematics/scilab/files/scilab-4.0-gtk-fix.patch
@@ -0,0 +1,23 @@
+--- scilab-4.0/routines/graphics/periGtk.c 2006-02-08 11:33:40.000000000 -0500
++++ scilab-4.0-b4-20060515/routines/graphics/periGtk.c 2006-02-20 04:05:05.000000000 -0500
+@@ -395,16 +395,17 @@
+ GdkEventButton *event,
+ BCG *gc)
+ {
++ int display_double_click_distance;
+ static GdkDisplay *display=NULL;
++ if ( display == NULL) display=gdk_display_get_default();
+
+ /* to compile with gdk<2.4 */
+ #if GTK_MAJOR_VERSION==2 && GTK_MINOR_VERSION>=4
+- int display_double_click_distance = display->double_click_distance;
++ display_double_click_distance = display->double_click_distance;
+ #else
+- int display_double_click_distance=5;
++ display_double_click_distance=5;
+ #endif
+
+- if ( display == NULL) display=gdk_display_get_default();
+ if ((event->time < (last_press.time + 2*display->double_click_time)) &&
+ (event->window == last_press.window) &&
+ (event->button == last_press.button) &&
diff --git a/sci-mathematics/scilab/scilab-4.0.ebuild b/sci-mathematics/scilab/scilab-4.0.ebuild
index 88049a55da15..54e2a30b6bba 100644
--- a/sci-mathematics/scilab/scilab-4.0.ebuild
+++ b/sci-mathematics/scilab/scilab-4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/scilab-4.0.ebuild,v 1.4 2006/06/01 15:34:16 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/scilab-4.0.ebuild,v 1.5 2006/07/04 15:17:32 markusle Exp $
inherit eutils fortran toolchain-funcs multilib autotools
@@ -48,6 +48,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-gtk-fix.patch
# fix gfortran problems on ppc
if [[ "${ARCH}" == "ppc" ]];then