summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-06-24 16:09:15 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-06-24 16:09:15 +0000
commit49bb1de2c0dff64599134d9bacd1c8ce3c86f583 (patch)
tree8af286fd993999d89a276a97effbb2bbc14e2bae /sci-mathematics/scilab
parentFix for glibc-2.11, fix for bug 315595 (diff)
downloadgentoo-2-49bb1de2c0dff64599134d9bacd1c8ce3c86f583.tar.gz
gentoo-2-49bb1de2c0dff64599134d9bacd1c8ce3c86f583.tar.bz2
gentoo-2-49bb1de2c0dff64599134d9bacd1c8ce3c86f583.zip
Fix build with GCC-4.5 wrt bug 321209. Thanks Diego for reporting.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/scilab')
-rw-r--r--sci-mathematics/scilab/ChangeLog6
-rw-r--r--sci-mathematics/scilab/files/scilab-4.1.2-gcc45.patch27
-rw-r--r--sci-mathematics/scilab/scilab-4.1.2-r2.ebuild5
3 files changed, 35 insertions, 3 deletions
diff --git a/sci-mathematics/scilab/ChangeLog b/sci-mathematics/scilab/ChangeLog
index 3e50c1c7cc08..2b8f4ffe164c 100644
--- a/sci-mathematics/scilab/ChangeLog
+++ b/sci-mathematics/scilab/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/scilab
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/ChangeLog,v 1.48 2010/06/22 12:50:37 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/ChangeLog,v 1.49 2010/06/24 16:09:15 xarthisius Exp $
+
+ 24 Jun 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ scilab-4.1.2-r2.ebuild, +files/scilab-4.1.2-gcc45.patch:
+ Fix build with GCC-4.5 wrt bug 321209. Thanks Diego for reporting.
22 Jun 2010; Justin Lecher <jlec@gentoo.org> -scilab-4.0.ebuild:
Removed broken version, #147900 & #155893
diff --git a/sci-mathematics/scilab/files/scilab-4.1.2-gcc45.patch b/sci-mathematics/scilab/files/scilab-4.1.2-gcc45.patch
new file mode 100644
index 000000000000..d256625a6765
--- /dev/null
+++ b/sci-mathematics/scilab/files/scilab-4.1.2-gcc45.patch
@@ -0,0 +1,27 @@
+Fixing build with gcc 4.5.
+
+http://bugs.gentoo.org/show_bug.cgi?id=321209
+
+--- routines/system/msgs.f
++++ routines/system/msgs.f
+@@ -82,7 +82,7 @@
+ call showstack()
+ goto 9999
+ 109 continue
+- write(buf(1:5),'(1pI5)') ierr
++ write(buf(1:5),'(I5)') ierr
+ call basout(io, wte, 'rank defficient. rank = '//buf(1:5))
+ goto 9999
+ 110 continue
+--- routines/system/Makefile.in
++++ routines/system/Makefile.in
+@@ -41,6 +41,9 @@
+ getsym.o: getsym.f
+ $(FC) @FC_OPTIONS2@ -c getsym.f -o getsym.o
+
++algebre.o: algebre.f
++ $(FC) $(FC_OPTIONS) -fno-range-check -c $< -o $@
++
+ allops.o: ../stack.h
+ bexec.o: ../stack.h
+ clause.o: ../stack.h
diff --git a/sci-mathematics/scilab/scilab-4.1.2-r2.ebuild b/sci-mathematics/scilab/scilab-4.1.2-r2.ebuild
index 1ea6f2019656..3e052f8fe68e 100644
--- a/sci-mathematics/scilab/scilab-4.1.2-r2.ebuild
+++ b/sci-mathematics/scilab/scilab-4.1.2-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/scilab-4.1.2-r2.ebuild,v 1.1 2009/08/10 13:41:15 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/scilab-4.1.2-r2.ebuild,v 1.2 2010/06/24 16:09:15 xarthisius Exp $
inherit eutils fortran toolchain-funcs multilib autotools java-pkg-opt-2
@@ -49,6 +49,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-4.1-examples.patch
epatch "${FILESDIR}"/${P}-java-config.patch
epatch "${FILESDIR}"/${P}-tmp-fix.patch
+ epatch "${FILESDIR}"/${P}-gcc45.patch
eautoconf
sed -e '/^ATLAS_LAPACKBLAS\>/s,=.*,= $(ATLASDIR)/liblapack.so $(ATLASDIR)/libblas.so $(ATLASDIR)/libcblas.so,' \