summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2011-01-05 11:40:19 +0000
committerAndrey Grozin <grozin@gentoo.org>2011-01-05 11:40:19 +0000
commitcc5ce31aecc68903be00c8e9138925e5d74f24b8 (patch)
tree2955dcd7f6a954c5094b57bf5eecc72774f7eebb /sci-mathematics/reduce
parentMaking cyana work in 2011 (diff)
downloadgentoo-2-cc5ce31aecc68903be00c8e9138925e5d74f24b8.tar.gz
gentoo-2-cc5ce31aecc68903be00c8e9138925e5d74f24b8.tar.bz2
gentoo-2-cc5ce31aecc68903be00c8e9138925e5d74f24b8.zip
Initial import
(Portage version: 2.2.0_alpha12/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics/reduce')
-rw-r--r--sci-mathematics/reduce/ChangeLog10
-rw-r--r--sci-mathematics/reduce/files/64reduce-gentoo.el4
-rwxr-xr-xsci-mathematics/reduce/files/reduce2
-rw-r--r--sci-mathematics/reduce/metadata.xml13
-rw-r--r--sci-mathematics/reduce/reduce-20101007.ebuild83
5 files changed, 112 insertions, 0 deletions
diff --git a/sci-mathematics/reduce/ChangeLog b/sci-mathematics/reduce/ChangeLog
new file mode 100644
index 000000000000..0d263f3591d9
--- /dev/null
+++ b/sci-mathematics/reduce/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-mathematics/reduce
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/reduce/ChangeLog,v 1.1 2011/01/05 11:40:19 grozin Exp $
+
+*reduce-20101007 (05 Jan 2011)
+
+ 05 Jan 2011; Andrey Grozin <grozin@gentoo.org> +files/64reduce-gentoo.el,
+ +reduce-20101007.ebuild, +files/reduce, +metadata.xml:
+ Initial import
+
diff --git a/sci-mathematics/reduce/files/64reduce-gentoo.el b/sci-mathematics/reduce/files/64reduce-gentoo.el
new file mode 100644
index 000000000000..2c20bff93ede
--- /dev/null
+++ b/sci-mathematics/reduce/files/64reduce-gentoo.el
@@ -0,0 +1,4 @@
+;; site-init for sci-mathematics/reduce
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'reduce-mode "reduce-mode" "Major mode for REDUCE code editing" t)
+(add-to-list 'auto-mode-alist '("\\.red\\'" . reduce-mode))
diff --git a/sci-mathematics/reduce/files/reduce b/sci-mathematics/reduce/files/reduce
new file mode 100755
index 000000000000..ff40e3e073ab
--- /dev/null
+++ b/sci-mathematics/reduce/files/reduce
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /usr/lib/reduce/reduce $*
diff --git a/sci-mathematics/reduce/metadata.xml b/sci-mathematics/reduce/metadata.xml
new file mode 100644
index 000000000000..523cb94a8164
--- /dev/null
+++ b/sci-mathematics/reduce/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-mathematics</herd>
+<maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+</maintainer>
+<longdescription lang="en">
+A general-purpose computer algebra system.
+Powerful, mature and efficient.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-mathematics/reduce/reduce-20101007.ebuild b/sci-mathematics/reduce/reduce-20101007.ebuild
new file mode 100644
index 000000000000..d56b99d493f7
--- /dev/null
+++ b/sci-mathematics/reduce/reduce-20101007.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/reduce/reduce-20101007.ebuild,v 1.1 2011/01/05 11:40:19 grozin Exp $
+EAPI="2"
+inherit elisp-common
+MY_PN=${PN}-algebra
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A general-purpose computer algebra system"
+HOMEPAGE="http://reduce-algebra.sourceforge.net/
+ http://reduce-algebra.com/"
+IUSE="doc emacs gnuplot X"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.bz2"
+LICENSE="BSD-2 X? ( LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~x86"
+
+RDEPEND="X? ( x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXft )
+ gnuplot? ( sci-visualization/gnuplot )
+ emacs? ( virtual/emacs )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ # If you pass --prefix to this damn configure,
+ # make (not make install!) will try to install stuff
+ # into the live file system => sandbox violation
+ # Therefore, I cannot use econf here
+ # Also, make calls configure in maintainer mode in subdirs *by design*
+ # The trunk sucks less => WONTFIX until the next release
+ ./configure --with-csl $(use_with X fox)
+ # psl build requires Internet connection at build time
+ # we cannot support it
+}
+
+src_compile() {
+ default_src_compile
+
+ pushd cslbuild/*/csl/reduce.doc > /dev/null
+ rm -f *.txt *.tex
+ popd > /dev/null
+
+ if use emacs; then
+ einfo "Compiling emacs lisp files"
+ elisp-compile generic/emacs/*.el || die "elisp-compile failed"
+ fi
+}
+
+src_test() {
+ emake testall || die "emake testall failed"
+}
+
+src_install() {
+ pushd cslbuild/*/csl > /dev/null
+ exeinto /usr/lib/${PN}
+ doexe reduce
+ insinto /usr/lib/${PN}
+ doins reduce.img
+ doins -r reduce.doc
+ if use X; then
+ doins -r reduce.fonts
+ fi
+ popd > /dev/null
+ exeinto /usr/bin
+ doexe "${FILESDIR}/reduce"
+ dodoc README BUILDING DEPENDENCY_TRACKING
+ dosym /usr/lib/${PN}/${PN}.doc /usr/share/doc/${PF}/html
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/*
+ fi
+
+ if use emacs; then
+ pushd generic/emacs > /dev/null
+ elisp-install ${PN} *.el *.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/64${PN}-gentoo.el"
+ popd > /dev/null
+ fi
+}