summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-24 13:50:00 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-24 13:50:00 +0000
commitebc5f8295f3d295c64096ce823f90a45a377c285 (patch)
treef1f2b15fb11b08ca35f80f58bac98a8ef351ae5e /sci-mathematics/qtoctave
parentUpdate to latest beta; drop all keywords but the two that haven't updated fro... (diff)
downloadgentoo-2-ebc5f8295f3d295c64096ce823f90a45a377c285.tar.gz
gentoo-2-ebc5f8295f3d295c64096ce823f90a45a377c285.tar.bz2
gentoo-2-ebc5f8295f3d295c64096ce823f90a45a377c285.zip
Added fix for insecure runpaths, #291595, some QA
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/qtoctave')
-rw-r--r--sci-mathematics/qtoctave/ChangeLog6
-rw-r--r--sci-mathematics/qtoctave/files/qtoctave-0.8.2-rpath.patch17
-rw-r--r--sci-mathematics/qtoctave/qtoctave-0.8.2.ebuild24
3 files changed, 31 insertions, 16 deletions
diff --git a/sci-mathematics/qtoctave/ChangeLog b/sci-mathematics/qtoctave/ChangeLog
index 04d014ada941..676aee3a905c 100644
--- a/sci-mathematics/qtoctave/ChangeLog
+++ b/sci-mathematics/qtoctave/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/qtoctave
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/ChangeLog,v 1.9 2010/06/16 15:30:24 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/ChangeLog,v 1.10 2010/06/24 13:50:00 jlec Exp $
+
+ 24 Jun 2010; Justin Lecher <jlec@gentoo.org> qtoctave-0.8.2.ebuild,
+ +files/qtoctave-0.8.2-rpath.patch:
+ Added fix for insecure runpaths, #291595, some QA
16 Jun 2010; Sébastien Fabbro <bicatali@gentoo.org>
qtoctave-0.9.1.ebuild, +files/qtoctave-0.9.1-qtinfo.patch:
diff --git a/sci-mathematics/qtoctave/files/qtoctave-0.8.2-rpath.patch b/sci-mathematics/qtoctave/files/qtoctave-0.8.2-rpath.patch
new file mode 100644
index 000000000000..041ea19709e6
--- /dev/null
+++ b/sci-mathematics/qtoctave/files/qtoctave-0.8.2-rpath.patch
@@ -0,0 +1,17 @@
+diff --git a/qtoctave/src/CMakeLists.txt b/qtoctave/src/CMakeLists.txt
+index 77f7438..6e32a70 100644
+--- a/qtoctave/src/CMakeLists.txt
++++ b/qtoctave/src/CMakeLists.txt
+@@ -28,12 +28,6 @@ add_executable(qtoctave
+ ${qtoctave_sources} ${qtoctave_moc_sources} ${qtoctave_ui_headers} ${qtoctave_moc_headers}
+ )
+
+-SET_TARGET_PROPERTIES(qtoctave
+- PROPERTIES INSTALL_RPATH ":usr/lib"
+- BUILD_WITH_INSTALL_RPATH true
+- INSTALL_RPATH_USE_LINK_PATH true
+-)
+-
+ TARGET_LINK_LIBRARIES(qtoctave ${Qt4_LIBRARIES} ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY} ${QT_QTXML_LIBRARY} ${QT_QTSVG_LIBRARY})
+
+ install (
diff --git a/sci-mathematics/qtoctave/qtoctave-0.8.2.ebuild b/sci-mathematics/qtoctave/qtoctave-0.8.2.ebuild
index 242ba1c244b9..9374501c777d 100644
--- a/sci-mathematics/qtoctave/qtoctave-0.8.2.ebuild
+++ b/sci-mathematics/qtoctave/qtoctave-0.8.2.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/qtoctave-0.8.2.ebuild,v 1.3 2009/12/04 04:37:20 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/qtoctave-0.8.2.ebuild,v 1.4 2010/06/24 13:50:00 jlec Exp $
EAPI="2"
CMAKE_IN_SOURCE_BUILD=1
-inherit cmake-utils
+
+inherit cmake-utils multilib
DESCRIPTION="QtOctave is a Qt4 front-end for Octave"
HOMEPAGE="http://forja.rediris.es/projects/csl-qtoctave/"
@@ -24,16 +25,9 @@ RDEPEND="${DEPEND}
S="${WORKDIR}"/${P}/${PN}
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.8.1-gcc4.4.patch
-}
-
-src_compile() {
- mycmakeargs="-DCMAKE_SKIP_RPATH:BOOL=YES"
- cmake-utils_src_compile
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.1-gcc4.4.patch
+ "${FILESDIR}"/${P}-rpath.patch
+ )
-src_install() {
- cmake-utils_src_install
- dodoc readme.txt news.txt
-}
+DOCS=(readme.txt news.txt)