summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-11-02 16:03:51 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-11-02 16:03:51 +0000
commit046de61750199a165c7d319285fa73ad5045e0ea (patch)
tree63c4c88838c3aa7469c366cf724c3d62e9d8c32c /sci-mathematics/qtoctave
parentVersion bump. Remove old. Fixes bug 242168. (diff)
downloadgentoo-2-046de61750199a165c7d319285fa73ad5045e0ea.tar.gz
gentoo-2-046de61750199a165c7d319285fa73ad5045e0ea.tar.bz2
gentoo-2-046de61750199a165c7d319285fa73ad5045e0ea.zip
Initial commit (fixes bug #198485).
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-SENTINEL-1 i686)
Diffstat (limited to 'sci-mathematics/qtoctave')
-rw-r--r--sci-mathematics/qtoctave/ChangeLog11
-rw-r--r--sci-mathematics/qtoctave/Manifest4
-rw-r--r--sci-mathematics/qtoctave/metadata.xml5
-rw-r--r--sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild36
4 files changed, 56 insertions, 0 deletions
diff --git a/sci-mathematics/qtoctave/ChangeLog b/sci-mathematics/qtoctave/ChangeLog
new file mode 100644
index 000000000000..1a634b57fbc5
--- /dev/null
+++ b/sci-mathematics/qtoctave/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-mathematics/qtoctave
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header:
+
+*qtoctave-0.8.1 (02 Nov 2008)
+
+ 02 Nov 2008; Markus Dittrich <markusle@gentoo.org> +metadata.xml,
+ +qtoctave-0.8.1.ebuild:
+ Initial commit (fixes bug #198485). Many thanks go to Juan Aguado
+ <juantxorena@gmail.com> for his ebuilds.
+
diff --git a/sci-mathematics/qtoctave/Manifest b/sci-mathematics/qtoctave/Manifest
new file mode 100644
index 000000000000..471a58c9af04
--- /dev/null
+++ b/sci-mathematics/qtoctave/Manifest
@@ -0,0 +1,4 @@
+DIST qtoctave-0.8.1.tar.gz 1707919 RMD160 41bb670f630ce08ce5b440b2c8dbe16fdbe282b0 SHA1 e7cb555eed318c0e62b2de974e5904e40579d2c4 SHA256 d5654f5aaa2ea86b473accb49cea4a85c2899d2822fe4c3d980f0260bbe87498
+EBUILD qtoctave-0.8.1.ebuild 736 RMD160 301043d7ea5c0fcb03648cb5ff4419f5807df822 SHA1 f93c8bc7040c39a2eb6a8f930817099eb34476b6 SHA256 84ab341e6926bdf5c33a1545ac554aebd90796950fb99b6b40cf07c4a4289b68
+MISC ChangeLog 360 RMD160 9d60d99bfa4b98c5d2d53c4f75952e782824371c SHA1 32b03f4f4edc38c036cb32fa04bbc061526f54b2 SHA256 a0e14a0fade67025b251f3cd1c28e8c493339f525b3b7fc3e9f8454fbbb3e99f
+MISC metadata.xml 168 RMD160 d98790cf055dc0f820c63d65f485b9dcfa8950f4 SHA1 95c9e4f7368f82053d631bbcd469612c92ca13cb SHA256 c0cc8d6ab9385750af753ddc504299ed90a70b5c4c655f6c77d865917a8829c9
diff --git a/sci-mathematics/qtoctave/metadata.xml b/sci-mathematics/qtoctave/metadata.xml
new file mode 100644
index 000000000000..5a2f1c7b832e
--- /dev/null
+++ b/sci-mathematics/qtoctave/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-mathematics</herd>
+</pkgmetadata>
diff --git a/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild b/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild
new file mode 100644
index 000000000000..45826525c183
--- /dev/null
+++ b/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild,v 1.1 2008/11/02 16:03:51 markusle Exp $
+
+EAPI="1"
+
+inherit cmake-utils
+
+DESCRIPTION="QtOctave is a Qt4 front-end for Octave"
+HOMEPAGE="http://forja.rediris.es/projects/csl-qtoctave/"
+SRC_URI="http://forja.rediris.es/frs/download.php/877/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="|| ( ( x11-libs/qt-gui:4
+ x11-libs/qt-svg:4 )
+ >=x11-libs/qt-4.3:4 )"
+
+RDEPEND="${DEPEND}
+ >=sci-mathematics/octave-3.0.0"
+
+S="${WORKDIR}"/${P}/${PN}
+
+src_compile() {
+ mycmakeargs="-DCMAKE_SKIP_RPATH:BOOL=YES"
+ cmake-utils_src_configurein
+ cmake-utils_src_make
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc readme.txt news.txt
+}