summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-05-28 17:01:26 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-05-28 17:01:26 +0000
commite5fa10edc5e8a3af56f68a21dd56731052cbf753 (patch)
tree857beb6055635f5e63dd9e28ae00bd880f1fb745 /sci-mathematics/pspp
parentFix bug #509532 - Build failure with unresolved overloaded function type (diff)
downloadgentoo-2-e5fa10edc5e8a3af56f68a21dd56731052cbf753.tar.gz
gentoo-2-e5fa10edc5e8a3af56f68a21dd56731052cbf753.tar.bz2
gentoo-2-e5fa10edc5e8a3af56f68a21dd56731052cbf753.zip
Version bump
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-mathematics/pspp')
-rw-r--r--sci-mathematics/pspp/ChangeLog12
-rw-r--r--sci-mathematics/pspp/files/pspp-0.6.0-as-needed.patch12
-rw-r--r--sci-mathematics/pspp/files/pspp-0.6.2-gtk.patch56
-rw-r--r--sci-mathematics/pspp/files/pspp-0.6.2-no-test-pgsql.patch15
-rw-r--r--sci-mathematics/pspp/files/pspp-0.8.0-as-needed.patch11
-rw-r--r--sci-mathematics/pspp/pspp-0.6.2-r1.ebuild91
-rw-r--r--sci-mathematics/pspp/pspp-0.8.3.ebuild (renamed from sci-mathematics/pspp/pspp-0.8.0.ebuild)44
7 files changed, 33 insertions, 208 deletions
diff --git a/sci-mathematics/pspp/ChangeLog b/sci-mathematics/pspp/ChangeLog
index 6162e7b97f8a..f3b4ae184617 100644
--- a/sci-mathematics/pspp/ChangeLog
+++ b/sci-mathematics/pspp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-mathematics/pspp
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/ChangeLog,v 1.28 2013/10/31 15:47:52 bicatali Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/ChangeLog,v 1.29 2014/05/28 17:01:25 bicatali Exp $
+
+*pspp-0.8.3 (28 May 2014)
+
+ 28 May 2014; Sébastien Fabbro <bicatali@gentoo.org> +pspp-0.8.3.ebuild,
+ -files/pspp-0.6.0-as-needed.patch, -files/pspp-0.6.2-gtk.patch,
+ -files/pspp-0.6.2-no-test-pgsql.patch, -files/pspp-0.8.0-as-needed.patch,
+ -pspp-0.6.2-r1.ebuild, -pspp-0.8.0.ebuild:
+ Version bump
31 Oct 2013; Sébastien Fabbro <bicatali@gentoo.org> pspp-0.8.1-r1.ebuild:
Install emacs files (broken by out of source building, bug #489938)
diff --git a/sci-mathematics/pspp/files/pspp-0.6.0-as-needed.patch b/sci-mathematics/pspp/files/pspp-0.6.0-as-needed.patch
deleted file mode 100644
index 88257292de6a..000000000000
--- a/sci-mathematics/pspp/files/pspp-0.6.0-as-needed.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur pspp-0.6.0/src/ui/terminal/automake.mk pspp-0.6.0.new/src/ui/terminal/automake.mk
---- pspp-0.6.0/src/ui/terminal/automake.mk 2008-05-03 01:59:39.000000000 -0400
-+++ pspp-0.6.0.new/src/ui/terminal/automake.mk 2008-10-28 09:20:50.000000000 -0400
-@@ -37,7 +37,7 @@
- $(NCURSES_LIBS) \
- $(LIBICONV) \
- gl/libgl.la \
-- @LIBINTL@ @LIBREADLINE@
-+ @LIBINTL@ -lreadline
-
-
-
diff --git a/sci-mathematics/pspp/files/pspp-0.6.2-gtk.patch b/sci-mathematics/pspp/files/pspp-0.6.2-gtk.patch
deleted file mode 100644
index 2dbb37c4fb3a..000000000000
--- a/sci-mathematics/pspp/files/pspp-0.6.2-gtk.patch
+++ /dev/null
@@ -1,56 +0,0 @@
---- a/lib/gtksheet/gtkitementry.c
-+++ b/lib/gtksheet/gtkitementry.c
-@@ -145,7 +145,7 @@ static void gtk_entry_draw_cursor (GtkEntry *entry,
- static PangoLayout *gtk_entry_ensure_layout (GtkEntry *entry,
- gboolean include_preedit);
- static void gtk_entry_queue_draw (GtkEntry *entry);
--static void gtk_entry_reset_im_context (GtkEntry *entry);
-+static void pspp_gtk_entry_reset_im_context (GtkEntry *entry);
- static void gtk_entry_recompute (GtkEntry *entry);
- static void gtk_entry_get_cursor_locations (GtkEntry *entry,
- CursorType type,
-@@ -694,7 +694,7 @@ gtk_entry_real_set_position (GtkEditable *editable,
- if (position != entry->current_pos ||
- position != entry->selection_bound)
- {
-- gtk_entry_reset_im_context (entry);
-+ pspp_gtk_entry_reset_im_context (entry);
- gtk_entry_set_positions (entry, position, position);
- }
- }
-@@ -895,7 +895,7 @@ gtk_entry_move_cursor (GtkEntry *entry,
- {
- gint new_pos = entry->current_pos;
-
-- gtk_entry_reset_im_context (entry);
-+ pspp_gtk_entry_reset_im_context (entry);
-
- if (entry->current_pos != entry->selection_bound && !extend_selection)
- {
-@@ -989,7 +989,7 @@ gtk_entry_insert_at_cursor (GtkEntry *entry,
-
- if (entry->editable)
- {
-- gtk_entry_reset_im_context (entry);
-+ pspp_gtk_entry_reset_im_context (entry);
-
- gtk_editable_insert_text (editable, str, -1, &pos);
- gtk_editable_set_position (editable, pos);
-@@ -1005,7 +1005,7 @@ gtk_entry_delete_from_cursor (GtkEntry *entry,
- gint start_pos = entry->current_pos;
- gint end_pos = entry->current_pos;
-
-- gtk_entry_reset_im_context (entry);
-+ pspp_gtk_entry_reset_im_context (entry);
-
- if (!entry->editable)
- return;
-@@ -1777,7 +1777,7 @@ gtk_entry_queue_draw (GtkEntry *entry)
- }
-
- static void
--gtk_entry_reset_im_context (GtkEntry *entry)
-+pspp_gtk_entry_reset_im_context (GtkEntry *entry)
- {
- if (entry->need_im_reset)
- {
diff --git a/sci-mathematics/pspp/files/pspp-0.6.2-no-test-pgsql.patch b/sci-mathematics/pspp/files/pspp-0.6.2-no-test-pgsql.patch
deleted file mode 100644
index 90a330c9f8ec..000000000000
--- a/sci-mathematics/pspp/files/pspp-0.6.2-no-test-pgsql.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- tests/automake.mk.orig 2010-09-29 06:36:55.000000000 +0100
-+++ tests/automake.mk 2010-09-29 06:37:20.000000000 +0100
-@@ -161,9 +161,9 @@
- dist_TESTS += tests/command/get-data-gnm.sh
- endif
-
--if PSQL_SUPPORT
--dist_TESTS += tests/command/get-data-psql.sh
--endif
-+#if PSQL_SUPPORT
-+#dist_TESTS += tests/command/get-data-psql.sh
-+#endif
-
- nodist_TESTS = \
- tests/libpspp/abt-test \
diff --git a/sci-mathematics/pspp/files/pspp-0.8.0-as-needed.patch b/sci-mathematics/pspp/files/pspp-0.8.0-as-needed.patch
deleted file mode 100644
index e8d7a2ab675a..000000000000
--- a/sci-mathematics/pspp/files/pspp-0.8.0-as-needed.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/ui/terminal/automake.mk.orig 2013-08-06 09:28:53.517642699 -0700
-+++ src/ui/terminal/automake.mk 2013-08-06 10:04:37.403409602 -0700
-@@ -24,7 +24,7 @@
- src/libpspp-core.la \
- $(CAIRO_LIBS) \
- $(NCURSES_LIBS) \
-- $(LIBREADLINE) \
-+ $(LTLIBREADLINE) \
- $(GSL_LIBS)
-
-
diff --git a/sci-mathematics/pspp/pspp-0.6.2-r1.ebuild b/sci-mathematics/pspp/pspp-0.6.2-r1.ebuild
deleted file mode 100644
index 41a87f245c0b..000000000000
--- a/sci-mathematics/pspp/pspp-0.6.2-r1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/pspp-0.6.2-r1.ebuild,v 1.7 2012/12/30 17:47:06 tomka Exp $
-
-EAPI=4
-inherit eutils elisp-common autotools multilib
-
-DESCRIPTION="Program for statistical analysis of sampled data."
-HOMEPAGE="http://www.gnu.org/software/pspp/pspp.html"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-SLOT="0"
-LICENSE="GPL-3"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc emacs examples gtk ncurses nls plotutils postgres static-libs"
-
-RDEPEND="
- dev-libs/libxml2:2
- sci-libs/gsl
- sys-libs/readline
- sys-devel/gettext
- sys-libs/zlib
- virtual/libiconv
- emacs? ( virtual/emacs )
- gtk? ( x11-libs/gtk+:2 gnome-base/libglade:2.0 )
- ncurses? ( sys-libs/ncurses )
- plotutils? ( media-libs/plotutils )
- postgres? ( dev-db/postgresql-server )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( virtual/latex-base )"
-
-SITEFILE=50${PN}-gentoo.el
-
-src_prepare() {
- # this patch is hacky, but should not be needed for 0.7
- epatch "${FILESDIR}"/${PN}-0.6.0-as-needed.patch
- epatch "${FILESDIR}"/${PN}-0.6.2-no-test-pgsql.patch
- epatch "${FILESDIR}"/${PN}-0.6.2-gtk.patch
- sed -i \
- -e '/xdate/d' \
- -e '/datediff/d' \
- tests/expressions/expressions.sh || die
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-rpath \
- $(use_enable nls) \
- $(use_enable static-libs static) \
- $(use_with gtk gui) \
- $(use_with ncurses libncurses) \
- $(use_with plotutils libplot) \
- $(use_with postgres libpq)
-}
-
-src_compile() {
- emake pkglibdir="${EPREFIX}/usr/$(get_libdir)"
- use doc && emake html pdf
- use emacs && elisp-compile *.el
-}
-
-src_install() {
- emake pkglibdir="${EPREFIX}/usr/$(get_libdir)" DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog NEWS ONEWS README THANKS TODO
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
- if use doc; then
- dohtml -r doc/pspp{,dev}.html
- dodoc doc/pspp{,-dev}.pdf
- fi
- if use emacs; then
- elisp-install ${PN} *.el *.elc
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
- if use gtk; then
- doicon src/ui/gui/${PN}icon.png
- make_desktop_entry psppire psppire ${PN}icon
- fi
-}
-
-pkg_postinst () {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sci-mathematics/pspp/pspp-0.8.0.ebuild b/sci-mathematics/pspp/pspp-0.8.3.ebuild
index 867a2f0e6a8a..6c406a07e4fc 100644
--- a/sci-mathematics/pspp/pspp-0.8.0.ebuild
+++ b/sci-mathematics/pspp/pspp-0.8.3.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/pspp-0.8.0.ebuild,v 1.3 2013/10/30 17:36:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/pspp-0.8.3.ebuild,v 1.1 2014/05/28 17:01:25 bicatali Exp $
EAPI=5
-AUTOTOOLS_IN_SOURCE_BUILD=1
AUTOTOOLS_AUTORECONF=1
inherit eutils elisp-common autotools-utils multilib
@@ -12,24 +11,27 @@ inherit eutils elisp-common autotools-utils multilib
DESCRIPTION="Program for statistical analysis of sampled data"
HOMEPAGE="http://www.gnu.org/software/pspp/pspp.html"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-LICENSE="GPL-3"
+LICENSE="GPL-3"
+SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
IUSE="cairo doc emacs examples gtk ncurses nls perl postgres static-libs"
RDEPEND="
- dev-libs/libxml2:2
- sci-libs/gsl
- sys-devel/gettext
- sys-libs/readline
- sys-libs/zlib
+ dev-libs/libxml2:2=
+ sci-libs/gsl:0=
+ sys-devel/gettext:0=
+ sys-libs/readline:0=
+ sys-libs/zlib:0=
virtual/libiconv
- cairo? ( x11-libs/cairo )
+ cairo? ( x11-libs/cairo:0= )
emacs? ( virtual/emacs )
- gtk? ( x11-libs/gtk+:2 gnome-base/libglade:2.0 >=x11-libs/gtksourceview-2.2:2.0 )
+ gtk? (
+ gnome-base/libglade:2.0
+ x11-libs/gtk+:2
+ >=x11-libs/gtksourceview-2.2:2.0 )
ncurses? ( sys-libs/ncurses )
- postgres? ( dev-db/postgresql-server )"
+ postgres? ( dev-db/postgresql-server:= )"
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? ( virtual/latex-base )"
@@ -37,13 +39,13 @@ DEPEND="${RDEPEND}
SITEFILE=50${PN}-gentoo.el
PATCHES=(
- "${FILESDIR}"/${PN}-0.8.0-as-needed.patch
"${FILESDIR}"/${PN}-0.8.0-gettext.patch
+ "${FILESDIR}"/${PN}-0.8.1-underlinking.patch
+ "${FILESDIR}"/${PN}-0.8.1-oos.patch
)
src_configure() {
local myeconfargs=(
- --disable-rpath
$(use_enable nls)
$(use_with cairo)
$(use_with gtk gui)
@@ -56,11 +58,16 @@ src_configure() {
src_compile() {
autotools-utils_src_compile pkglibdir="${EPREFIX}/usr/$(get_libdir)"
- use doc && emake html pdf
+ use doc && autotools-utils_src_compile html pdf
use emacs && elisp-compile *.el
}
src_install() {
+ if use doc; then
+ HTML_DOCS=( "${BUILD_DIR}"/doc/pspp{,-dev}.html )
+ DOCS=( "${BUILD_DIR}"/doc/pspp{,-dev}.pdf )
+ fi
+
autotools-utils_src_install pkglibdir="${EPREFIX}/usr/$(get_libdir)"
if use examples; then
@@ -68,11 +75,6 @@ src_install() {
doins -r examples
fi
- if use doc; then
- dohtml -r doc/pspp{,-dev}.html
- dodoc doc/pspp{,-dev}.pdf
- fi
-
if use emacs; then
elisp-install ${PN} *.el *.elc
elisp-site-file-install "${FILESDIR}/${SITEFILE}"