summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-09-29 05:41:18 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-09-29 05:41:18 +0000
commit62d172b57b645c954e199c0899af50d497943583 (patch)
tree7135e7c13cd2e307e8e734fe641cd029805eda53 /sci-mathematics/pspp
parentppc64 stable wrt #337575 (diff)
downloadgentoo-2-62d172b57b645c954e199c0899af50d497943583.tar.gz
gentoo-2-62d172b57b645c954e199c0899af50d497943583.tar.bz2
gentoo-2-62d172b57b645c954e199c0899af50d497943583.zip
Disabling postgres test, bad server starting
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/pspp')
-rw-r--r--sci-mathematics/pspp/files/pspp-0.6.2-no-test-pgsql.patch15
-rw-r--r--sci-mathematics/pspp/pspp-0.6.1.ebuild87
-rw-r--r--sci-mathematics/pspp/pspp-0.6.2.ebuild3
3 files changed, 17 insertions, 88 deletions
diff --git a/sci-mathematics/pspp/files/pspp-0.6.2-no-test-pgsql.patch b/sci-mathematics/pspp/files/pspp-0.6.2-no-test-pgsql.patch
new file mode 100644
index 000000000000..90a330c9f8ec
--- /dev/null
+++ b/sci-mathematics/pspp/files/pspp-0.6.2-no-test-pgsql.patch
@@ -0,0 +1,15 @@
+--- tests/automake.mk.orig 2010-09-29 06:36:55.000000000 +0100
++++ tests/automake.mk 2010-09-29 06:37:20.000000000 +0100
+@@ -161,9 +161,9 @@
+ dist_TESTS += tests/command/get-data-gnm.sh
+ endif
+
+-if PSQL_SUPPORT
+-dist_TESTS += tests/command/get-data-psql.sh
+-endif
++#if PSQL_SUPPORT
++#dist_TESTS += tests/command/get-data-psql.sh
++#endif
+
+ nodist_TESTS = \
+ tests/libpspp/abt-test \
diff --git a/sci-mathematics/pspp/pspp-0.6.1.ebuild b/sci-mathematics/pspp/pspp-0.6.1.ebuild
deleted file mode 100644
index ec11a92d11fe..000000000000
--- a/sci-mathematics/pspp/pspp-0.6.1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/pspp-0.6.1.ebuild,v 1.3 2010/06/17 21:58:57 patrick Exp $
-
-EAPI=2
-inherit eutils elisp-common autotools
-
-DESCRIPTION="Program for statistical analysis of sampled data."
-HOMEPAGE="http://www.gnu.org/software/pspp/pspp.html"
-SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz"
-SLOT="0"
-LICENSE="GPL-3"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc emacs gtk ncurses nls plotutils postgres"
-
-RDEPEND="sci-libs/gsl
- sys-libs/readline
- sys-devel/gettext
- virtual/libiconv
- sys-libs/zlib
- dev-libs/libxml2
- emacs? ( virtual/emacs )
- gtk? ( >=x11-libs/gtk+-2.12 gnome-base/libglade )
- ncurses? ( sys-libs/ncurses )
- plotutils? ( media-libs/plotutils )
- postgres? ( dev-db/postgresql-server )"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- doc? ( virtual/latex-base )"
-
-SITEFILE=50${PN}-gentoo.el
-
-src_prepare() {
- # this patch is hacky, but should not be needed for 0.7
- epatch "${FILESDIR}"/${PN}-0.6.0-as-needed.patch
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-rpath \
- $(use_enable nls) \
- $(use_with gtk gui) \
- $(use_with ncurses libncurses) \
- $(use_with plotutils libplot) \
- $(use_with postgres libpq)
-}
-
-src_compile() {
- emake pkglibdir=/usr/$(get_libdir) || die "emake failed"
- if use doc; then
- emake html || die "emake html failed"
- emake pdf || die "emake pdf failed"
- fi
- use emacs && elisp-compile *.el
-}
-
-src_install() {
- emake pkglibdir=/usr/$(get_libdir) DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS ChangeLog NEWS ONEWS README THANKS TODO
- insinto /usr/share/doc/${PF}
- doins -r examples || die
-
- if use doc; then
- doins -r doc/pspp.html doc/pspp-dev.html || die
- doins doc/pspp.pdf doc/pspp-dev.pdf || die
- fi
- if use emacs; then
- elisp-install ${PN} *.el *.elc
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use gtk; then
- doicon src/ui/gui/${PN}icon.png
- make_desktop_entry psppire psppire ${PN}icon
- fi
-}
-
-pkg_postinst () {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sci-mathematics/pspp/pspp-0.6.2.ebuild b/sci-mathematics/pspp/pspp-0.6.2.ebuild
index 6c4314f27cd5..d6108558621f 100644
--- a/sci-mathematics/pspp/pspp-0.6.2.ebuild
+++ b/sci-mathematics/pspp/pspp-0.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/pspp-0.6.2.ebuild,v 1.3 2010/06/17 21:58:57 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/pspp-0.6.2.ebuild,v 1.4 2010/09/29 05:41:18 bicatali Exp $
EAPI=2
inherit eutils elisp-common autotools
@@ -34,6 +34,7 @@ SITEFILE=50${PN}-gentoo.el
src_prepare() {
# this patch is hacky, but should not be needed for 0.7
epatch "${FILESDIR}"/${PN}-0.6.0-as-needed.patch
+ epatch "${FILESDIR}"/${PN}-0.6.2-no-test-pgsql.patch
eautoreconf
}