summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-10-30 18:03:29 +0000
committerJustin Lecher <jlec@gentoo.org>2013-10-30 18:03:29 +0000
commit1f9d7fc4a75b1efffe5f07598b2e8297b9011774 (patch)
tree033b548d5f799d5eebd20499879457bed467826a /sci-mathematics/pspp
parentDrop old (diff)
downloadgentoo-2-1f9d7fc4a75b1efffe5f07598b2e8297b9011774.tar.gz
gentoo-2-1f9d7fc4a75b1efffe5f07598b2e8297b9011774.tar.bz2
gentoo-2-1f9d7fc4a75b1efffe5f07598b2e8297b9011774.zip
sci-mathematics/pspp: Fixing out-of-source doc build
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-mathematics/pspp')
-rw-r--r--sci-mathematics/pspp/ChangeLog5
-rw-r--r--sci-mathematics/pspp/pspp-0.8.1-r1.ebuild16
2 files changed, 12 insertions, 9 deletions
diff --git a/sci-mathematics/pspp/ChangeLog b/sci-mathematics/pspp/ChangeLog
index 31733d5309ca..2ff0652c8c58 100644
--- a/sci-mathematics/pspp/ChangeLog
+++ b/sci-mathematics/pspp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/pspp
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/ChangeLog,v 1.26 2013/10/30 17:36:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/ChangeLog,v 1.27 2013/10/30 18:03:29 jlec Exp $
+
+ 30 Oct 2013; Justin Lecher <jlec@gentoo.org> pspp-0.8.1-r1.ebuild:
+ Fixing out-of-source doc build
*pspp-0.8.1-r1 (30 Oct 2013)
diff --git a/sci-mathematics/pspp/pspp-0.8.1-r1.ebuild b/sci-mathematics/pspp/pspp-0.8.1-r1.ebuild
index fb0d545222c7..372c41884248 100644
--- a/sci-mathematics/pspp/pspp-0.8.1-r1.ebuild
+++ b/sci-mathematics/pspp/pspp-0.8.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/pspp-0.8.1-r1.ebuild,v 1.1 2013/10/30 17:36:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/pspp-0.8.1-r1.ebuild,v 1.2 2013/10/30 18:03:29 jlec Exp $
EAPI=5
@@ -59,11 +59,16 @@ src_configure() {
src_compile() {
autotools-utils_src_compile pkglibdir="${EPREFIX}/usr/$(get_libdir)"
- use doc && emake html pdf
- use emacs && elisp-compile *.el
+ use doc && autotools-utils_src_compile html pdf
+ use emacs && cd "${BUILD_DIR}" && elisp-compile *.el
}
src_install() {
+ if use doc; then
+ HTML_DOCS=( "${BUILD_DIR}"/doc/pspp{,-dev}.html )
+ DOCS=( "${BUILD_DIR}"/doc/pspp{,-dev}.pdf )
+ fi
+
autotools-utils_src_install pkglibdir="${EPREFIX}/usr/$(get_libdir)"
if use examples; then
@@ -71,11 +76,6 @@ src_install() {
doins -r examples
fi
- if use doc; then
- dohtml -r doc/pspp{,-dev}.html
- dodoc doc/pspp{,-dev}.pdf
- fi
-
if use emacs; then
elisp-install ${PN} *.el *.elc
elisp-site-file-install "${FILESDIR}/${SITEFILE}"