summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2007-10-02 14:33:42 +0000
committerJeroen Roovers <jer@gentoo.org>2007-10-02 14:33:42 +0000
commiteb7905e41ed0043c06e31b7795a106bb3c8ce30a (patch)
treee290bbe3225bcfd8f97b4fd91c1b89af88f6e7b0 /sci-mathematics/pari
parentStable on alpha (bug #191216) (diff)
downloadgentoo-2-eb7905e41ed0043c06e31b7795a106bb3c8ce30a.tar.gz
gentoo-2-eb7905e41ed0043c06e31b7795a106bb3c8ce30a.tar.bz2
gentoo-2-eb7905e41ed0043c06e31b7795a106bb3c8ce30a.zip
Revision bump to fix HPPA build problem, and trivial changes in whitespace and other QA conventions (bug #194456).
(Portage version: 2.1.3.9)
Diffstat (limited to 'sci-mathematics/pari')
-rw-r--r--sci-mathematics/pari/ChangeLog9
-rw-r--r--sci-mathematics/pari/files/digest-pari-2.3.2-r13
-rw-r--r--sci-mathematics/pari/files/pari-2.3.2-strip.patch11
-rw-r--r--sci-mathematics/pari/pari-2.3.2-r1.ebuild107
4 files changed, 129 insertions, 1 deletions
diff --git a/sci-mathematics/pari/ChangeLog b/sci-mathematics/pari/ChangeLog
index 899abb979f29..ae58a35f751f 100644
--- a/sci-mathematics/pari/ChangeLog
+++ b/sci-mathematics/pari/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/pari
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/ChangeLog,v 1.49 2007/10/01 17:03:36 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/ChangeLog,v 1.50 2007/10/02 14:33:41 jer Exp $
+
+*pari-2.3.2-r1 (02 Oct 2007)
+
+ 02 Oct 2007; Jeroen Roovers <jer@gentoo.org>
+ +files/pari-2.3.2-strip.patch, +pari-2.3.2-r1.ebuild:
+ Revision bump to fix HPPA build problem, and trivial changes in whitespace
+ and other QA conventions (bug #194456).
01 Oct 2007; Jeroen Roovers <jer@gentoo.org> pari-2.3.2.ebuild:
DON'T hide build output.
diff --git a/sci-mathematics/pari/files/digest-pari-2.3.2-r1 b/sci-mathematics/pari/files/digest-pari-2.3.2-r1
new file mode 100644
index 000000000000..9b6b3b422cbc
--- /dev/null
+++ b/sci-mathematics/pari/files/digest-pari-2.3.2-r1
@@ -0,0 +1,3 @@
+MD5 54f8b7cb615db6d216f1a31a575c8223 pari-2.3.2.tar.gz 2015734
+RMD160 d2394fd31bfa6efcbfce25081d75234ccb1005be pari-2.3.2.tar.gz 2015734
+SHA256 514799c0722376ba7d163588f091662731bca0a4b3cd2a93d01eb6bec9d1f47a pari-2.3.2.tar.gz 2015734
diff --git a/sci-mathematics/pari/files/pari-2.3.2-strip.patch b/sci-mathematics/pari/files/pari-2.3.2-strip.patch
new file mode 100644
index 000000000000..0fee947fd556
--- /dev/null
+++ b/sci-mathematics/pari/files/pari-2.3.2-strip.patch
@@ -0,0 +1,11 @@
+--- config/Makefile.SH. 2007-10-01 23:45:45.000000000 +0200
++++ config/Makefile.SH 2007-10-01 23:55:10.000000000 +0200
+@@ -208,7 +208,7 @@
+ MV = mv -f
+ LN = $ln_s
+ CP_F = cp -f
+-STRIP = strip
++STRIP = true
+ STRIPFLAGS =
+
+ # Change these installation directories to suit your needs.
diff --git a/sci-mathematics/pari/pari-2.3.2-r1.ebuild b/sci-mathematics/pari/pari-2.3.2-r1.ebuild
new file mode 100644
index 000000000000..5d6c81bff938
--- /dev/null
+++ b/sci-mathematics/pari/pari-2.3.2-r1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.3.2-r1.ebuild,v 1.1 2007/10/02 14:33:41 jer Exp $
+
+inherit elisp-common eutils flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="A software package for computer-aided number theory"
+HOMEPAGE="http://pari.math.u-bordeaux.fr/"
+SRC_URI="http://pari.math.u-bordeaux.fr/pub/pari/unix/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="doc emacs X"
+
+DEPEND="doc? ( virtual/tetex )
+ sys-libs/readline
+ X? ( x11-libs/libX11 )
+ emacs? ( virtual/emacs )"
+SITEFILE=50${PN}-gentoo.el
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-strip.patch"
+
+ # disable default building of docs during install
+ sed -e "s:install-doc install-examples:install-examples:" \
+ -i config/Makefile.SH || die "Failed to fix makefile"
+}
+
+src_compile() {
+ #need to force optimization here, as it breaks without
+ if is-flag -O0; then
+ replace-flags -O0 -O2
+ elif ! is-flag -O?; then
+ append-flags -O2
+ fi
+
+ ./Configure \
+ --prefix=/usr \
+ --datadir=/usr/share/${P} \
+ --libdir=/usr/$(get_libdir) \
+ --mandir=/usr/share/man/man1 || die "./Configure failed"
+
+ if use hppa; then
+ mymake=DLLD\=/usr/bin/gcc\ DLLDFLAGS\=-shared\ -Wl,-soname=\$\(LIBPARI_SONAME\)\ -lm
+ fi
+
+ # Shared libraries should be PIC on ALL architectures.
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/31
+ # Fixes BUG #49583
+ einfo "Building shared library..."
+ cd Olinux-* || die "Bad directory. File a BUG!"
+ emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" lib-dyn || die "Building shared library failed!"
+
+ einfo "Building executables..."
+ emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp || die "Building executables failed!"
+
+ if use doc; then
+ cd "${S}"
+ emake docpdf || die "Failed to generate docs"
+ fi
+
+ if use emacs; then
+ cd "${S}/emacs"
+ elisp-comp *.el || die "elisp-comp failed"
+ fi
+}
+
+src_test() {
+ cd "${S}"
+
+ make test-kernel
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install || \
+ die "Install failed"
+
+ if use emacs; then
+ elisp-install ${PN} emacs/*.el emacs/*.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ dodoc AUTHORS Announce.2.1 CHANGES README TODO NEW
+ if use doc; then
+ emake DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install-doc \
+ || die "Failed to install docs"
+ insinto /usr/share/doc/${PF}
+ doins doc/*.pdf || die "Failed to install pdf docs"
+ fi
+
+ #remove superfluous doc directory
+ rm -fr "${D}/usr/share/${P}/doc" || \
+ die "Failed to clean up doc directory"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}