summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2005-06-26 13:49:26 +0000
committerGuy Martin <gmsoft@gentoo.org>2005-06-26 13:49:26 +0000
commit22cd255183828847fd82df15606db8a913a43a45 (patch)
treed5e1f5f22226808bbfd6e7278e495fea0cfbd963 /sci-mathematics/pari/pari-2.1.5-r4.ebuild
parentFixed fail to compile on amd64. (diff)
downloadgentoo-2-22cd255183828847fd82df15606db8a913a43a45.tar.gz
gentoo-2-22cd255183828847fd82df15606db8a913a43a45.tar.bz2
gentoo-2-22cd255183828847fd82df15606db8a913a43a45.zip
Stable on hppa.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sci-mathematics/pari/pari-2.1.5-r4.ebuild')
-rw-r--r--sci-mathematics/pari/pari-2.1.5-r4.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sci-mathematics/pari/pari-2.1.5-r4.ebuild b/sci-mathematics/pari/pari-2.1.5-r4.ebuild
index 4127e28ad08c..85ce1a661107 100644
--- a/sci-mathematics/pari/pari-2.1.5-r4.ebuild
+++ b/sci-mathematics/pari/pari-2.1.5-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.5-r4.ebuild,v 1.1 2005/01/07 09:40:26 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.5-r4.ebuild,v 1.2 2005/06/26 13:49:26 gmsoft Exp $
inherit eutils
@@ -10,7 +10,7 @@ SRC_URI="http://www.gn-50uma.de/ftp/pari-2.1/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~ppc ~sparc alpha ~mips ~hppa amd64"
+KEYWORDS="x86 ~ppc ~sparc alpha ~mips hppa amd64"
IUSE="doc emacs"
@@ -46,6 +46,13 @@ src_compile() {
emake CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" lib-dyn || die "Building shared library failed!"
einfo "Building executables..."
emake CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp || die "Building exec tu ables failed!"
+ elif use hppa; then
+ einfo "Building shared library..."
+ cd Olinux-hppa*
+ mymake=DLLD\=/usr/bin/gcc\ DLLDFLAGS\=-shared\ -Wl,-soname=\$\(LIBPARI_SONAME\)\ -lm
+ emake CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" ${mymake} lib-dyn || die "Building shared library failed!"
+ einfo "Building executables..."
+ emake CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp || die "Building exec tu ables failed!"
else
emake CFLAGS="${CFLAGS} -DGCC_INLINE" gp || die
fi