summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-05-11 09:14:54 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-05-11 09:14:54 +0000
commit8c5964a5ed7f3e95cb8f5863d2034f72c41b6868 (patch)
tree6779eb3cb2f75c9d0c2146c92205ab44ba4e18a8 /sci-mathematics/octave
parentStable on hppa (bug #132931). (diff)
downloadgentoo-2-8c5964a5ed7f3e95cb8f5863d2034f72c41b6868.tar.gz
gentoo-2-8c5964a5ed7f3e95cb8f5863d2034f72c41b6868.tar.bz2
gentoo-2-8c5964a5ed7f3e95cb8f5863d2034f72c41b6868.zip
Clean up ebuild a bit more for CC/CXX/LDFLAGS definitions.
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'sci-mathematics/octave')
-rw-r--r--sci-mathematics/octave/ChangeLog5
-rw-r--r--sci-mathematics/octave/octave-2.1.72.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index e6f4cd612bd8..5d8dae2d4537 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/octave
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.30 2006/05/11 08:04:49 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.31 2006/05/11 09:14:54 robbat2 Exp $
+
+ 11 May 2006; Robin H. Johnson <robbat2@gentoo.org> octave-2.1.72.ebuild:
+ Clean up ebuild a bit more for CC/CXX/LDFLAGS definitions. octave-2.1.72.ebuild
11 May 2006; Robin H. Johnson <robbat2@gentoo.org> octave-2.1.72.ebuild:
Compile fix - clean up usage of LDFLAGS/CC/CXX to allow them to work with
diff --git a/sci-mathematics/octave/octave-2.1.72.ebuild b/sci-mathematics/octave/octave-2.1.72.ebuild
index f4301c410922..f83147b3f337 100644
--- a/sci-mathematics/octave/octave-2.1.72.ebuild
+++ b/sci-mathematics/octave/octave-2.1.72.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.72.ebuild,v 1.5 2006/05/11 08:04:49 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.72.ebuild,v 1.6 2006/05/11 09:14:54 robbat2 Exp $
inherit flag-o-matic fortran
@@ -62,11 +62,11 @@ src_compile() {
myconf="${myconf} --with-mpi=mpi"
fi
else
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
myconf="${myconf} --without-mpi"
fi
-
- LDFLAGS="${LDFLAGS}" \
CC="${CC}" CXX="${CXX}" \
econf \
$(use_with hdf5) \