summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-12-18 10:29:01 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-12-18 10:29:01 +0000
commit7e3b6e6a3e06a25f2301ce26f1cc6e3745bede74 (patch)
tree3e431e02c9acf87900c48a9df66ddd4f37900a06 /sci-mathematics/octave
parentAdded pyblosxom 1.4.2 and removed all older versions. The older versions had (diff)
downloadgentoo-2-7e3b6e6a3e06a25f2301ce26f1cc6e3745bede74.tar.gz
gentoo-2-7e3b6e6a3e06a25f2301ce26f1cc6e3745bede74.tar.bz2
gentoo-2-7e3b6e6a3e06a25f2301ce26f1cc6e3745bede74.zip
Added xemacs support to ebuild (fixes bug #193430).
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'sci-mathematics/octave')
-rw-r--r--sci-mathematics/octave/ChangeLog7
-rw-r--r--sci-mathematics/octave/octave-2.1.73-r2.ebuild23
2 files changed, 21 insertions, 9 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index dff1b00cbe5a..a6184dc3bad5 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/octave
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.49 2007/11/20 14:46:56 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.50 2007/12/18 10:29:01 markusle Exp $
+
+ 18 Dec 2007; Markus Dittrich <markusle@gentoo.org>
+ octave-2.1.73-r2.ebuild:
+ Added xemacs support to ebuild (fixes bug #193430). Thanks much to
+ Ulrich Mueller <ulm@gentoo.org> for his patch.
20 Nov 2007; Markus Dittrich <markusle@gentoo.org>
octave-2.1.57-r1.ebuild, octave-2.1.69.ebuild, octave-2.1.71-r2.ebuild,
diff --git a/sci-mathematics/octave/octave-2.1.73-r2.ebuild b/sci-mathematics/octave/octave-2.1.73-r2.ebuild
index 2bd51ecea313..9ce075319a5a 100644
--- a/sci-mathematics/octave/octave-2.1.73-r2.ebuild
+++ b/sci-mathematics/octave/octave-2.1.73-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73-r2.ebuild,v 1.3 2007/11/20 14:46:56 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73-r2.ebuild,v 1.4 2007/12/18 10:29:01 markusle Exp $
-inherit flag-o-matic fortran autotools
+inherit flag-o-matic fortran autotools xemacs-elisp-common
DESCRIPTION="GNU Octave is a high-level language (MatLab compatible) intended for numerical computations"
LICENSE="GPL-2"
@@ -11,7 +11,7 @@ SRC_URI="ftp://ftp.octave.org/pub/octave/bleeding-edge/${P}.tar.bz2
ftp://ftp.math.uni-hamburg.de/pub/soft/math/octave/${P}.tar.bz2"
SLOT="0"
-IUSE="emacs static readline zlib doc hdf5 mpi"
+IUSE="emacs static readline zlib doc hdf5 mpi xemacs"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
DEPEND="virtual/libc
@@ -26,7 +26,10 @@ DEPEND="virtual/libc
hdf5? ( sci-libs/hdf5 )
doc? ( virtual/latex-base )
mpi? ( virtual/mpi )
+ xemacs? ( virtual/xemacs )
!=app-text/texi2html-1.70"
+RDEPEND="${DEPEND}
+ emacs? ( virtual/emacs )"
# NOTE: octave supports blas/lapack from intel but this is not open
# source nor is it free (as in beer OR speech) Check out...
@@ -83,6 +86,11 @@ src_compile() {
|| die "econf failed"
emake || die "emake failed"
+
+ if use xemacs; then
+ cd "${S}/emacs"
+ xemacs-elisp-comp *.el
+ fi
}
src_install() {
@@ -90,15 +98,14 @@ src_install() {
if use doc; then
octave-install-doc || die "Octave doc install failed"
fi
- if use emacs; then
+ if use emacs || use xemacs; then
cd emacs
exeinto /usr/bin
doexe otags || die
doman otags.1 || die
- for emacsdir in /usr/share/emacs/site-lisp /usr/lib/xemacs/site-lisp; do
- insinto ${emacsdir}
- doins *.el || die
- done
+ if use xemacs; then
+ xemacs-elisp-install ${PN} *.el *.elc
+ fi
cd ..
fi
dodir /etc/env.d || die