summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-02-27 18:27:27 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-02-27 18:27:27 +0000
commit19f164b2ecdbb82d4515ec5c750b3916d6e7258c (patch)
tree5f350dbd65586629982256eb9c4aa8cd031fe0bf /sci-mathematics/octave
parentdev-ruby/nagios_analyzer: Initial version (diff)
downloadgentoo-2-19f164b2ecdbb82d4515ec5c750b3916d6e7258c.tar.gz
gentoo-2-19f164b2ecdbb82d4515ec5c750b3916d6e7258c.tar.bz2
gentoo-2-19f164b2ecdbb82d4515ec5c750b3916d6e7258c.zip
Version bump, add a gnuplot flag (bug #402705), and fix occasional failures on install (bug #401189)
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/octave')
-rw-r--r--sci-mathematics/octave/ChangeLog8
-rw-r--r--sci-mathematics/octave/octave-3.6.1.ebuild106
2 files changed, 113 insertions, 1 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index 6296e01ef6eb..28b74cac0445 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/octave
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.119 2012/02/16 19:31:48 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.120 2012/02/27 18:27:27 bicatali Exp $
+
+*octave-3.6.1 (27 Feb 2012)
+
+ 27 Feb 2012; Sébastien Fabbro <bicatali@gentoo.org> +octave-3.6.1.ebuild:
+ Version bump, add a gnuplot flag (bug #402705), and fix occasional failures
+ on install (bug #401189)
16 Feb 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> octave-3.4.3-r1.ebuild:
x86 stable wrt bug #402199
diff --git a/sci-mathematics/octave/octave-3.6.1.ebuild b/sci-mathematics/octave/octave-3.6.1.ebuild
new file mode 100644
index 000000000000..e5f6c86157ec
--- /dev/null
+++ b/sci-mathematics/octave/octave-3.6.1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.6.1.ebuild,v 1.1 2012/02/27 18:27:27 bicatali Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+inherit autotools-utils toolchain-funcs
+
+DESCRIPTION="High-level interactive language for numerical computations"
+LICENSE="GPL-3"
+HOMEPAGE="http://www.octave.org/"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+IUSE="curl doc fftw +glpk gnuplot +imagemagick opengl +qhull +qrupdate
+ readline +sparse static-libs X zlib"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-libs/libpcre
+ app-text/ghostscript-gpl
+ sys-libs/ncurses
+ virtual/lapack
+ curl? ( net-misc/curl )
+ fftw? ( sci-libs/fftw:3.0 )
+ glpk? ( sci-mathematics/glpk )
+ gnuplot? ( sci-visualization/gnuplot )
+ imagemagick? ( || (
+ media-gfx/graphicsmagick[cxx]
+ media-gfx/imagemagick[cxx] ) )
+ opengl? (
+ media-libs/freetype:2
+ media-libs/fontconfig
+ >=x11-libs/fltk-1.3:1[opengl] )
+ qhull? ( media-libs/qhull )
+ qrupdate? ( sci-libs/qrupdate )
+ readline? ( sys-libs/readline )
+ sparse? (
+ sci-libs/arpack
+ sci-libs/camd
+ sci-libs/ccolamd
+ sci-libs/cholmod
+ sci-libs/colamd
+ sci-libs/cxsparse
+ sci-libs/umfpack )
+ X? ( x11-libs/libX11 )
+ zlib? ( sys-libs/zlib )"
+
+DEPEND="${RDEPEND}
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-genericrecommended
+ sys-apps/texinfo )
+ dev-util/gperf
+ dev-util/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.4.3-{pkgbuilddir,help,texi}.patch )
+
+src_configure() {
+ # occasional fail on install, force regeneration see bug #401189
+ rm -f doc/interpreter/contributors.texi || die
+
+ # hdf5 disabled because not really useful (bug #299876)
+ local myconf="--without-magick"
+ if use imagemagick; then
+ if has_version media-gfx/graphicsmagick[cxx]; then
+ myconf="--with-magick=GraphicsMagick"
+ else
+ myconf="--with-magick=ImageMagick"
+ fi
+ fi
+
+ myeconfargs+=(
+ --localstatedir="${EPREFIX}/var/state/octave"
+ --without-hdf5
+ --with-blas="$(pkg-config --libs blas)"
+ --with-lapack="$(pkg-config --libs lapack)"
+ $(use_enable doc docs)
+ $(use_enable readline)
+ $(use_with curl)
+ $(use_with fftw fftw3)
+ $(use_with fftw fftw3f)
+ $(use_with glpk)
+ $(use_with opengl)
+ $(use_with qhull)
+ $(use_with qrupdate)
+ $(use_with sparse arpack)
+ $(use_with sparse umfpack)
+ $(use_with sparse colamd)
+ $(use_with sparse ccolamd)
+ $(use_with sparse cholmod)
+ $(use_with sparse cxsparse)
+ $(use_with X x)
+ $(use_with zlib z)
+ ${myconf}
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dodoc $(find doc -name \*.pdf)
+ [[ -e test/fntests.log ]] && dodoc test/fntests.log
+ echo "LDPATH=${EPREFIX}/usr/$(get_libdir)/${P}" > 99octave
+ doenvd 99octave
+}