summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-06-04 21:52:41 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-06-04 21:52:41 +0000
commit8c2ade216b0a658186b7f26174b787aee959718b (patch)
treed883ac5870cec20574e263b3e89ee4e779bc835b /sci-mathematics/octave/octave-2.1.57-r1.ebuild
parentFixed broken Manifest. (diff)
downloadgentoo-2-8c2ade216b0a658186b7f26174b787aee959718b.tar.gz
gentoo-2-8c2ade216b0a658186b7f26174b787aee959718b.tar.bz2
gentoo-2-8c2ade216b0a658186b7f26174b787aee959718b.zip
Added warning about agressive CFLAGS. (See bug #76067.)
(Portage version: 2.0.51.19)
Diffstat (limited to 'sci-mathematics/octave/octave-2.1.57-r1.ebuild')
-rw-r--r--sci-mathematics/octave/octave-2.1.57-r1.ebuild20
1 files changed, 19 insertions, 1 deletions
diff --git a/sci-mathematics/octave/octave-2.1.57-r1.ebuild b/sci-mathematics/octave/octave-2.1.57-r1.ebuild
index e749d09cad20..5173b50d1060 100644
--- a/sci-mathematics/octave/octave-2.1.57-r1.ebuild
+++ b/sci-mathematics/octave/octave-2.1.57-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.57-r1.ebuild,v 1.5 2005/04/18 16:19:36 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.57-r1.ebuild,v 1.6 2005/06/04 21:52:41 ribosome Exp $
inherit flag-o-matic
@@ -90,6 +90,24 @@ src_install() {
fi
}
+pkg_postinst() {
+ echo
+ einfo "Some users have reported failures at running simple tests if"
+ einfo "octave was built with agressive optimisations. You can check if"
+ einfo "your setup is affected by this bug by running the following test"
+ einfo "(inside the octave interpreter):"
+ einfo
+ einfo "octave:1> y = [1 3 4 2 1 5 3 5 6 7 4 5 7 10 11 3];"
+ einfo "octave:2> g = [1 1 1 1 1 1 1 1 2 2 2 2 2 3 3 3];"
+ einfo "octave:3> anova(y, g)"
+ einfo
+ einfo "If these commands complete successfully with no error message,"
+ einfo "your installation should be ok. Otherwise, try recompiling"
+ einfo "octave using less agressive \"CFLAGS\" (combining \"-O3\" and"
+ einfo "\"-march=pentium4\" is known to cause problems)."
+ echo
+}
+
octave-install-doc() {
echo "Installing documentation..."
insinto /usr/share/doc/${PF}