summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-12-03 12:27:02 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-12-03 12:27:02 +0000
commitfd2079c6d44e90f6486c85e953d3038f8d9a132a (patch)
tree112e28b145b33b95af1bd659f766136d41d55b76 /sci-mathematics/mathomatic
parentVersion bump (diff)
downloadgentoo-2-fd2079c6d44e90f6486c85e953d3038f8d9a132a.tar.gz
gentoo-2-fd2079c6d44e90f6486c85e953d3038f8d9a132a.tar.bz2
gentoo-2-fd2079c6d44e90f6486c85e953d3038f8d9a132a.zip
Version bump
(Portage version: 2.2_rc16/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-mathematics/mathomatic')
-rw-r--r--sci-mathematics/mathomatic/ChangeLog8
-rw-r--r--sci-mathematics/mathomatic/mathomatic-14.2.4.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/sci-mathematics/mathomatic/ChangeLog b/sci-mathematics/mathomatic/ChangeLog
index b0323addfb14..ce9ad9a54078 100644
--- a/sci-mathematics/mathomatic/ChangeLog
+++ b/sci-mathematics/mathomatic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/mathomatic
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.35 2008/10/21 14:39:37 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.36 2008/12/03 12:27:02 bicatali Exp $
+
+*mathomatic-14.2.4 (03 Dec 2008)
+
+ 03 Dec 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +mathomatic-14.2.4.ebuild:
+ Version bump
*mathomatic-14.2.1 (21 Oct 2008)
diff --git a/sci-mathematics/mathomatic/mathomatic-14.2.4.ebuild b/sci-mathematics/mathomatic/mathomatic-14.2.4.ebuild
new file mode 100644
index 000000000000..69dee488b0c9
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-14.2.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-14.2.4.ebuild,v 1.1 2008/12/03 12:27:02 bicatali Exp $
+
+inherit eutils
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.com/"
+SRC_URI="http://www.panix.com/~gesslein/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses"
+
+src_compile() {
+ # respect user flags
+ sed -i \
+ -e '/^CFLAGS/ s/-O.//' \
+ -e '/^LDFLAGS/s/+= -lm/:= -lm $(LDFLAGS)/' \
+ makefile primes/makefile || die "sed failed"
+ emake READLINE=1 || die "emake failed"
+ emake -C primes || die "emake in primes failed"
+}
+
+src_test() {
+ emake test || die "emake test failed"
+ emake -C primes test || die "emake test in primes failed"
+}
+
+src_install() {
+ # It was easier just to install the files manually
+ dobin mathomatic primes/matho-{primes,pascal,sumsq} || die
+ dodoc changes.txt README.txt AUTHORS || die
+ doman mathomatic.1 primes/*.1 || die
+ doicon icons/mathomatic.png || die
+ domenu icons/mathomatic.desktop || die
+ newdoc primes/README.txt README-primes.txt || die
+ if use doc; then
+ dohtml doc/* || die
+ insinto /usr/share/doc/${PF}
+ doins -r tests factorial m4 || die
+ fi
+}