summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2006-10-06 18:43:22 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2006-10-06 18:43:22 +0000
commitf1675f7a9bb419e8ce487f2637f05ea00dcf9561 (patch)
treef5710b8e855c9e2a78ba45a221b4bdd1325b3206 /sci-mathematics/mathomatic/mathomatic-12.6.4.ebuild
parentfixed bugref in Changelog (diff)
downloadgentoo-2-f1675f7a9bb419e8ce487f2637f05ea00dcf9561.tar.gz
gentoo-2-f1675f7a9bb419e8ce487f2637f05ea00dcf9561.tar.bz2
gentoo-2-f1675f7a9bb419e8ce487f2637f05ea00dcf9561.zip
Version bump.
(Portage version: 2.1.2_pre2)
Diffstat (limited to 'sci-mathematics/mathomatic/mathomatic-12.6.4.ebuild')
-rw-r--r--sci-mathematics/mathomatic/mathomatic-12.6.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-mathematics/mathomatic/mathomatic-12.6.4.ebuild b/sci-mathematics/mathomatic/mathomatic-12.6.4.ebuild
new file mode 100644
index 000000000000..6c2f5a2790f5
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-12.6.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-12.6.4.ebuild,v 1.1 2006/10/06 18:43:22 cryos Exp $
+
+inherit eutils
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.com/"
+SRC_URI="http://www.panix.com/~gesslein/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc icc"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses
+ icc? ( dev-lang/icc )"
+
+src_compile() {
+ if use icc; then
+ CC="icc" CFLAGS="-O3 -axKWNBP -ipo" LDFLAGS="-O3 -axKWNBP -ipo -limf" emake READLINE=1 || die "emake failed"
+ else
+ emake READLINE=1 || die "emake failed"
+ fi
+}
+
+src_install() {
+ # It was easier just to install the files manually
+ dobin mathomatic
+ dodoc changes.txt README.txt
+ doman mathomatic.1
+
+ if use doc; then
+ dohtml doc/*
+ insinto /usr/share/doc/${PF}/examples
+ doins tests/*.in
+ fi
+}