summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-06 14:42:24 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-06 14:42:24 +0000
commitfff52f08e4bd5cc02d19bb26e75faec2717dd71c (patch)
tree6f421c3b9ae61302ddbcf9cd8ac9d2493621e541 /sci-mathematics/lybniz
parentAnother minor fix for my previous change suggested by Arfrever. (diff)
downloadgentoo-2-fff52f08e4bd5cc02d19bb26e75faec2717dd71c.tar.gz
gentoo-2-fff52f08e4bd5cc02d19bb26e75faec2717dd71c.tar.bz2
gentoo-2-fff52f08e4bd5cc02d19bb26e75faec2717dd71c.zip
Use Python 2 (bug #316233).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/lybniz')
-rw-r--r--sci-mathematics/lybniz/ChangeLog8
-rw-r--r--sci-mathematics/lybniz/lybniz-1.3.2.ebuild20
2 files changed, 20 insertions, 8 deletions
diff --git a/sci-mathematics/lybniz/ChangeLog b/sci-mathematics/lybniz/ChangeLog
index cea0cb8145ed..b676e31b8454 100644
--- a/sci-mathematics/lybniz/ChangeLog
+++ b/sci-mathematics/lybniz/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/lybniz
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/lybniz/ChangeLog,v 1.1 2008/03/25 00:04:02 bicatali Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/lybniz/ChangeLog,v 1.2 2010/07/06 14:42:24 arfrever Exp $
+
+ 06 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ lybniz-1.3.2.ebuild:
+ Use Python 2 (bug #316233).
*lybniz-1.3.2 (25 Mar 2008)
diff --git a/sci-mathematics/lybniz/lybniz-1.3.2.ebuild b/sci-mathematics/lybniz/lybniz-1.3.2.ebuild
index 641a5ff5f96f..59ed0f1ea9bd 100644
--- a/sci-mathematics/lybniz/lybniz-1.3.2.ebuild
+++ b/sci-mathematics/lybniz/lybniz-1.3.2.ebuild
@@ -1,23 +1,31 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/lybniz/lybniz-1.3.2.ebuild,v 1.1 2008/03/25 00:04:02 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/lybniz/lybniz-1.3.2.ebuild,v 1.2 2010/07/06 14:42:24 arfrever Exp $
-NEED_PYTHON=2.4
+EAPI="3"
+PYTHON_DEPEND="2"
inherit distutils
DESCRIPTION="A function plotter program written in PyGTK"
HOMEPAGE="http://lybniz2.sourceforge.net/"
SRC_URI="mirror://sourceforge/lybniz2/${P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+
DEPEND=">=dev-python/pygtk-2.6"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
-src_unpack() {
- unpack ${A}
+src_prepare() {
sed -i \
-e 's/Education;/Education;Math;/' \
- "${S}"/${PN}.desktop || die
+ ${PN}.desktop || die
}