summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2008-07-27 22:21:48 +0000
committerCarsten Lohrke <carlo@gentoo.org>2008-07-27 22:21:48 +0000
commit429774608aa530934d215c40e33b5f5b7a69cd1f (patch)
treeff962f52e4bcaa2025e15a719cb0a83eda2e8772 /sci-mathematics/kseg/kseg-0.403.ebuild
parent QA: Get rid of deprecated qt_min_version(). (diff)
downloadgentoo-2-429774608aa530934d215c40e33b5f5b7a69cd1f.tar.gz
gentoo-2-429774608aa530934d215c40e33b5f5b7a69cd1f.tar.bz2
gentoo-2-429774608aa530934d215c40e33b5f5b7a69cd1f.zip
QA: Get rid of deprecated qt_min_version().
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-mathematics/kseg/kseg-0.403.ebuild')
-rw-r--r--sci-mathematics/kseg/kseg-0.403.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sci-mathematics/kseg/kseg-0.403.ebuild b/sci-mathematics/kseg/kseg-0.403.ebuild
index e5ba61e29297..9a889fdc9321 100644
--- a/sci-mathematics/kseg/kseg-0.403.ebuild
+++ b/sci-mathematics/kseg/kseg-0.403.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/kseg/kseg-0.403.ebuild,v 1.4 2007/07/18 02:11:03 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/kseg/kseg-0.403.ebuild,v 1.5 2008/07/27 22:21:48 carlo Exp $
+
+EAPI=1
inherit eutils qt3
@@ -11,20 +13,20 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 ~x86"
IUSE="examples"
-DEPEND="$(qt_min_version 3.3)"
+DEPEND="x11-libs/qt:3"
S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# Fix silly hardcoded help file path and CCFLAGS.
#epatch ${FILESDIR}/${P}-gentoo.patch
sed -i -e "s|KSEG_HELP_DIR|${PF}/help|" main.cpp
}
src_compile() {
- ${QTDIR}/bin/qmake QMAKE=${QTDIR}/bin/qmake || die 'qmake failed.'
+ "${QTDIR}"/bin/qmake QMAKE="${QTDIR}"/bin/qmake || die 'qmake failed.'
emake || die 'emake failed.'
}