summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2012-10-15 18:45:41 +0000
committerThomas Kahle <tomka@gentoo.org>2012-10-15 18:45:41 +0000
commita33c31abffe92dcd8a8acf775ca744aad27fb253 (patch)
tree0e3f506d2cbe6295ed6fa0d50e18cecf29c2c88f /sci-mathematics/jags
parentAdd the executable bit to the lxde session file. Bug #437010. Move it directl... (diff)
downloadgentoo-2-a33c31abffe92dcd8a8acf775ca744aad27fb253.tar.gz
gentoo-2-a33c31abffe92dcd8a8acf775ca744aad27fb253.tar.bz2
gentoo-2-a33c31abffe92dcd8a8acf775ca744aad27fb253.zip
Bump to 3.3.0 per bug 436942.
(Portage version: 2.1.11.27/cvs/Linux x86_64, signed Manifest commit with key 0x565C32BC)
Diffstat (limited to 'sci-mathematics/jags')
-rw-r--r--sci-mathematics/jags/ChangeLog8
-rw-r--r--sci-mathematics/jags/jags-3.3.0.ebuild44
2 files changed, 50 insertions, 2 deletions
diff --git a/sci-mathematics/jags/ChangeLog b/sci-mathematics/jags/ChangeLog
index 0433b09bab4e..8caadb3ba7a9 100644
--- a/sci-mathematics/jags/ChangeLog
+++ b/sci-mathematics/jags/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/jags
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/jags/ChangeLog,v 1.8 2012/05/04 07:46:51 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/jags/ChangeLog,v 1.9 2012/10/15 18:45:41 tomka Exp $
+
+*jags-3.3.0 (15 Oct 2012)
+
+ 15 Oct 2012; Thomas Kahle <tomka@gentoo.org> +jags-3.3.0.ebuild:
+ Bump to 3.3.0 per bug 436942.
04 May 2012; Jeff Horelick <jdhore@gentoo.org> jags-3.2.0.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -40,4 +45,3 @@
+metadata.xml:
Initial import. Modififed ebuild from originally submitted by Xavier
Fernández i Marín, bug #317741
-
diff --git a/sci-mathematics/jags/jags-3.3.0.ebuild b/sci-mathematics/jags/jags-3.3.0.ebuild
new file mode 100644
index 000000000000..c236db5d7122
--- /dev/null
+++ b/sci-mathematics/jags/jags-3.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/jags/jags-3.3.0.ebuild,v 1.1 2012/10/15 18:45:41 tomka Exp $
+
+EAPI=4
+inherit autotools-utils
+
+MYP="JAGS-${PV}"
+
+DESCRIPTION="Just Another Gibbs Sampler for Bayesian MCMC simulation"
+HOMEPAGE="http://www-fis.iarc.fr/~martyn/software/jags/"
+SRC_URI="mirror://sourceforge/project/mcmc-jags/JAGS/3.x/Source/${MYP}.tar.gz"
+LICENSE="GPL-2"
+IUSE="doc"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( virtual/latex-base
+ dev-texlive/texlive-latexextra
+ )"
+
+S="${WORKDIR}/${MYP}"
+
+src_configure() {
+ myeconfargs=(
+ --with-blas="$(pkg-config --libs blas)"
+ --with-lapack="$(pkg-config --libs lapack)"
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile all $(use doc && echo docs)
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dodoc ${AUTOTOOLS_BUILD_DIR}/doc/manual/*.pdf
+}