summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-01 12:18:25 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-01 12:18:25 +0000
commit0764ba3d94493d759b57d85a21882860da24e18e (patch)
tree1ad8aefc559d840993a6a3c99d306b04de642389 /sci-mathematics/gsl-shell
parentStable for ia64, wrt bug #459326 (diff)
downloadgentoo-2-0764ba3d94493d759b57d85a21882860da24e18e.tar.gz
gentoo-2-0764ba3d94493d759b57d85a21882860da24e18e.tar.bz2
gentoo-2-0764ba3d94493d759b57d85a21882860da24e18e.zip
sci-mathematics/gsl-shell: Use pkg-config to detect gsl, libagg, freetype (#459474) and fox
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-mathematics/gsl-shell')
-rw-r--r--sci-mathematics/gsl-shell/ChangeLog6
-rw-r--r--sci-mathematics/gsl-shell/files/gsl-shell-2.2.0-pkg-config.patch33
-rw-r--r--sci-mathematics/gsl-shell/gsl-shell-2.2.0.ebuild13
3 files changed, 47 insertions, 5 deletions
diff --git a/sci-mathematics/gsl-shell/ChangeLog b/sci-mathematics/gsl-shell/ChangeLog
index 1c0ec79e1838..d3799adc95e8 100644
--- a/sci-mathematics/gsl-shell/ChangeLog
+++ b/sci-mathematics/gsl-shell/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/gsl-shell
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gsl-shell/ChangeLog,v 1.9 2013/02/27 15:07:24 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gsl-shell/ChangeLog,v 1.10 2013/03/01 12:18:24 jlec Exp $
+
+ 01 Mar 2013; Justin Lecher <jlec@gentoo.org> gsl-shell-2.2.0.ebuild,
+ +files/gsl-shell-2.2.0-pkg-config.patch:
+ Use pkg-config to detect gsl, libagg, freetype (#459474) and fox
27 Feb 2013; Justin Lecher <jlec@gentoo.org> gsl-shell-2.2.0.ebuild:
Add missing dep on virtual/pkgconfig
diff --git a/sci-mathematics/gsl-shell/files/gsl-shell-2.2.0-pkg-config.patch b/sci-mathematics/gsl-shell/files/gsl-shell-2.2.0-pkg-config.patch
new file mode 100644
index 000000000000..8bb28635df2b
--- /dev/null
+++ b/sci-mathematics/gsl-shell/files/gsl-shell-2.2.0-pkg-config.patch
@@ -0,0 +1,33 @@
+ makepackages | 16 ++++++++--------
+ 1 file changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/makepackages b/makepackages
+index afeef79..a724e82 100644
+--- a/makepackages
++++ b/makepackages
+@@ -52,17 +52,17 @@ else
+ PTHREADS_LIBS = -lpthread
+
+ else
+- AGG_INCLUDES = -I/usr/include/agg2
+- AGG_LIBS = -lagg -lX11
++ AGG_INCLUDES = $(shell $(PKG_CONFIG) --cflags libagg)
++ AGG_LIBS = $(shell $(PKG_CONFIG) --libs libagg) -lX11
+
+- GSL_INCLUDES =
+- GSL_LIBS = -lgsl -lblas
++ GSL_INCLUDES = $(shell $(PKG_CONFIG) --cflags gsl)
++ GSL_LIBS = $(shell $(PKG_CONFIG) --libs gsl)
+
+- FOX_INCLUDES := $(shell pkg-config fox --cflags)
+- FOX_LIBS = $(shell pkg-config fox --libs)
++ FOX_INCLUDES := $(shell $(PKG_CONFIG) fox --cflags)
++ FOX_LIBS = $(shell $(PKG_CONFIG) fox --libs)
+
+- FREETYPE_INCLUDES = -I/usr/include/freetype2
+- FREETYPE_LIBS = -lfreetype
++ FREETYPE_INCLUDES = $(shell $(PKG_CONFIG) --cflags freetype2)
++ FREETYPE_LIBS = $(shell $(PKG_CONFIG) --libs freetype2)
+
+ PTHREADS_LIBS = -lpthread
+ endif
diff --git a/sci-mathematics/gsl-shell/gsl-shell-2.2.0.ebuild b/sci-mathematics/gsl-shell/gsl-shell-2.2.0.ebuild
index 368831376059..95c19af3c3c2 100644
--- a/sci-mathematics/gsl-shell/gsl-shell-2.2.0.ebuild
+++ b/sci-mathematics/gsl-shell/gsl-shell-2.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gsl-shell/gsl-shell-2.2.0.ebuild,v 1.4 2013/02/27 15:07:24 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gsl-shell/gsl-shell-2.2.0.ebuild,v 1.5 2013/03/01 12:18:24 jlec Exp $
EAPI=4
@@ -30,7 +30,12 @@ DEPEND="${DEPEND}
S="${WORKDIR}"/${PN}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-font.patch "${FILESDIR}"/${PN}-strip.patch "${FILESDIR}"/${PN}-usr.patch
+ tc-export PKG_CONFIG
+ epatch \
+ "${FILESDIR}"/${PN}-font.patch \
+ "${FILESDIR}"/${PN}-strip.patch \
+ "${FILESDIR}"/${PN}-usr.patch \
+ "${FILESDIR}"/${P}-pkg-config.patch
use fox || epatch "${FILESDIR}"/${PN}-nogui.patch
}
@@ -40,10 +45,10 @@ src_compile() {
if use fox; then
local FOX_INCLUDES=`WANT_FOX=1.6 fox-config --cflags`
local FOX_LIBS=`WANT_FOX=1.6 fox-config --libs`
- emake -j1 CFLAGS="${CFLAGS}" GSL_LIBS="-lgsl ${BLAS}" \
+ emake -j1 CFLAGS="${CFLAGS}" GSL_LIBS="$($(tc-getPKG_CONFIG) --libs gsl) ${BLAS}" \
FOX_INCLUDES="${FOX_INCLUDES}" FOX_LIBS="${FOX_LIBS}"
else
- emake -j1 CFLAGS="${CFLAGS}" GSL_LIBS="-lgsl ${BLAS}"
+ emake -j1 CFLAGS="${CFLAGS}" GSL_LIBS="$($(tc-getPKG_CONFIG) --libs gsl) ${BLAS}"
fi
if use doc; then