summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-05-25 16:48:12 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-05-25 16:48:12 +0000
commite55e505261b908c67ed2d8534357f30cedb0cdef (patch)
tree63f0e46fbe0e9a019265b31eaf816651b5df0623 /sci-mathematics/ginac
parentUse Python 2 (bug #311683). (diff)
downloadgentoo-2-e55e505261b908c67ed2d8534357f30cedb0cdef.tar.gz
gentoo-2-e55e505261b908c67ed2d8534357f30cedb0cdef.tar.bz2
gentoo-2-e55e505261b908c67ed2d8534357f30cedb0cdef.zip
Fix build with GCC-4.5 wrt bug 321411. Thanks Diego for report
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/ginac')
-rw-r--r--sci-mathematics/ginac/ChangeLog6
-rw-r--r--sci-mathematics/ginac/files/ginac-1.5.7-gcc45.patch16
-rw-r--r--sci-mathematics/ginac/ginac-1.5.7.ebuild3
3 files changed, 23 insertions, 2 deletions
diff --git a/sci-mathematics/ginac/ChangeLog b/sci-mathematics/ginac/ChangeLog
index f8e3c3486dba..cbd045659860 100644
--- a/sci-mathematics/ginac/ChangeLog
+++ b/sci-mathematics/ginac/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/ginac
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ginac/ChangeLog,v 1.45 2010/04/09 01:34:04 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ginac/ChangeLog,v 1.46 2010/05/25 16:48:12 xarthisius Exp $
+
+ 25 May 2010; Kacper Kowalik <xarthisius@gentoo.org> ginac-1.5.7.ebuild,
+ +files/ginac-1.5.7-gcc45.patch:
+ Fix build with GCC-4.5 wrt bug 321411. Thanks Diego for report
*ginac-1.5.7 (09 Apr 2010)
diff --git a/sci-mathematics/ginac/files/ginac-1.5.7-gcc45.patch b/sci-mathematics/ginac/files/ginac-1.5.7-gcc45.patch
new file mode 100644
index 000000000000..df0a61d79f3c
--- /dev/null
+++ b/sci-mathematics/ginac/files/ginac-1.5.7-gcc45.patch
@@ -0,0 +1,16 @@
+Fixing build with gcc 4.5.
+Upstream fix e22d2ed95925d870876c4fcd922ea2a9cfdbdab1
+
+http://bugs.gentoo.org/show_bug.cgi?id=321411
+
+--- ginac/function.pl
++++ ginac/function.pl
+@@ -1314,7 +1314,7 @@
+
+ // No derivative defined? Then return abstract derivative object
+ if (opt.power_f == NULL)
+- return (new power::power(*this, power_param))->setflag(status_flags::dynallocated |
++ return (new GiNaC::power(*this, power_param))->setflag(status_flags::dynallocated |
+ status_flags::evaluated);
+
+ current_serial = serial;
diff --git a/sci-mathematics/ginac/ginac-1.5.7.ebuild b/sci-mathematics/ginac/ginac-1.5.7.ebuild
index 90f6918fceb3..359744e9777a 100644
--- a/sci-mathematics/ginac/ginac-1.5.7.ebuild
+++ b/sci-mathematics/ginac/ginac-1.5.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ginac/ginac-1.5.7.ebuild,v 1.1 2010/04/09 01:34:04 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ginac/ginac-1.5.7.ebuild,v 1.2 2010/05/25 16:48:12 xarthisius Exp $
EAPI=2
inherit eutils
@@ -25,6 +25,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.5.1-pkgconfig.patch
+ epatch "${FILESDIR}"/${P}-gcc45.patch
}
src_compile() {