summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-28 05:28:11 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-28 05:28:11 +0000
commitd72f30e5a4ec18abd8ee62dc3843096fb4cd74c3 (patch)
tree8edef15f22b056904d0246ad33afc8888517e3b1 /sci-mathematics/geomview/geomview-1.8.1-r3.ebuild
parentMoving to sci-mathematics/geomview (diff)
downloadgentoo-2-d72f30e5a4ec18abd8ee62dc3843096fb4cd74c3.tar.gz
gentoo-2-d72f30e5a4ec18abd8ee62dc3843096fb4cd74c3.tar.bz2
gentoo-2-d72f30e5a4ec18abd8ee62dc3843096fb4cd74c3.zip
Moved from app-sci/geomview to sci-mathematics/geomview.
Diffstat (limited to 'sci-mathematics/geomview/geomview-1.8.1-r3.ebuild')
-rw-r--r--sci-mathematics/geomview/geomview-1.8.1-r3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-mathematics/geomview/geomview-1.8.1-r3.ebuild b/sci-mathematics/geomview/geomview-1.8.1-r3.ebuild
new file mode 100644
index 000000000000..b9d772af16b1
--- /dev/null
+++ b/sci-mathematics/geomview/geomview-1.8.1-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/geomview/geomview-1.8.1-r3.ebuild,v 1.1 2004/12/28 05:28:11 ribosome Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Interactive Geometry Viewer"
+SRC_URI="http://ftp1.sourceforge.net/geomview/geomview-1.8.1.tar.gz"
+HOMEPAGE="http://geomview.sourceforge.net"
+
+KEYWORDS="~x86 ~sparc ~ppc"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-lang/tk
+ x11-libs/xforms
+ x11-libs/lesstif
+ virtual/opengl"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-stdiostream.diff
+ epatch ${FILESDIR}/${P}-configure.diff
+}
+
+src_compile() {
+ append-flags "-DGL_GLEXT_LEGACY"
+ econf || die "could not configure"
+ make || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install
+}