summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2010-09-14 15:17:54 +0000
committerAndrey Grozin <grozin@gentoo.org>2010-09-14 15:17:54 +0000
commite14b4d832eaaf6cf307698bf0476a83b514272fc (patch)
treed341317bcc6cfe16e36649a87608ef81c34b6cad /sci-mathematics/genius
parentUpdated ebuild by Jaco Kroon, closes bug #337280. Updated linux-headers depen... (diff)
downloadgentoo-2-e14b4d832eaaf6cf307698bf0476a83b514272fc.tar.gz
gentoo-2-e14b4d832eaaf6cf307698bf0476a83b514272fc.tar.bz2
gentoo-2-e14b4d832eaaf6cf307698bf0476a83b514272fc.zip
Version bump, closing bug #337066, thanks to Joe Sapp <nixphoeni@gentoo.org>. Fix spacing in the Makefile, closing bug # 333871, thanks to Jory A. Pratt <anarchy@gentoo.org>.
(Portage version: 2.2_rc80/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics/genius')
-rw-r--r--sci-mathematics/genius/ChangeLog10
-rw-r--r--sci-mathematics/genius/files/genius-make.patch73
-rw-r--r--sci-mathematics/genius/genius-1.0.11.ebuild59
3 files changed, 141 insertions, 1 deletions
diff --git a/sci-mathematics/genius/ChangeLog b/sci-mathematics/genius/ChangeLog
index 4b7aea7bfa31..064da4d9bf45 100644
--- a/sci-mathematics/genius/ChangeLog
+++ b/sci-mathematics/genius/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-mathematics/genius
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/genius/ChangeLog,v 1.2 2010/09/14 09:26:44 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/genius/ChangeLog,v 1.3 2010/09/14 15:17:54 grozin Exp $
+
+*genius-1.0.11 (14 Sep 2010)
+
+ 14 Sep 2010; Andrey Grozin <grozin@gentoo.org> +genius-1.0.11.ebuild,
+ +files/genius-make.patch:
+ Version bump, closing bug #337066, thanks to Joe Sapp
+ <nixphoeni@gentoo.org>. Fix spacing in the Makefile, closing bug # 333871,
+ thanks to Jory A. Pratt <anarchy@gentoo.org>.
14 Sep 2010; Markos Chandras <hwoarang@gentoo.org> ChangeLog:
Keyworded for amd64. Bug #337063. Thanks to Joe Sapp
diff --git a/sci-mathematics/genius/files/genius-make.patch b/sci-mathematics/genius/files/genius-make.patch
new file mode 100644
index 000000000000..b9754325aea4
--- /dev/null
+++ b/sci-mathematics/genius/files/genius-make.patch
@@ -0,0 +1,73 @@
+--- gtkextra/Makefile.in-orig 2010-08-22 16:18:31.099596456 -0500
++++ gtkextra/Makefile.in 2010-08-22 16:20:46.375575923 -0500
+@@ -106,16 +106,16 @@
+ first=`echo "$$dir1" | sed -e "$$sed_first"`; \
+ if test "$$first" != "."; then \
+ if test "$$first" = ".."; then \
+- dir2=`echo "$$dir0" | sed -e "$$sed_last"`/"$$dir2"; \
+- dir0=`echo "$$dir0" | sed -e "$$sed_butlast"`; \
++ dir2=`echo "$$dir0" | sed -e "$$sed_last"`/"$$dir2"; \
++ dir0=`echo "$$dir0" | sed -e "$$sed_butlast"`; \
+ else \
+- first2=`echo "$$dir2" | sed -e "$$sed_first"`; \
+- if test "$$first2" = "$$first"; then \
+- dir2=`echo "$$dir2" | sed -e "$$sed_rest"`; \
+- else \
+- dir2="../$$dir2"; \
+- fi; \
+- dir0="$$dir0"/"$$first"; \
++ first2=`echo "$$dir2" | sed -e "$$sed_first"`; \
++ if test "$$first2" = "$$first"; then \
++ dir2=`echo "$$dir2" | sed -e "$$sed_rest"`; \
++ else \
++ dir2="../$$dir2"; \
++ fi; \
++ dir0="$$dir0"/"$$first"; \
+ fi; \
+ fi; \
+ dir1=`echo "$$dir1" | sed -e "$$sed_rest"`; \
+@@ -391,7 +391,7 @@
+ case '$(am__configure_deps)' in \
+ *$$dep*) \
+ ( cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh ) \
+- && { if test -f $@; then exit 0; else break; fi; }; \
++ && { if test -f $@; then exit 0; else break; fi; }; \
+ exit 1;; \
+ esac; \
+ done; \
+@@ -670,12 +670,12 @@
+ echo " am__remove_distdir=: am__skip_length_check=: am__skip_mode_fix=: distdir)"; \
+ ($(am__cd) $$subdir && \
+ $(MAKE) $(AM_MAKEFLAGS) \
+- top_distdir="$$new_top_distdir" \
+- distdir="$$new_distdir" \
++ top_distdir="$$new_top_distdir" \
++ distdir="$$new_distdir" \
+ am__remove_distdir=: \
+ am__skip_length_check=: \
+ am__skip_mode_fix=: \
+- distdir) \
++ distdir) \
+ || exit 1; \
+ fi; \
+ done
+@@ -800,13 +800,13 @@
+
+
+ $(srcdir)/gtkextra-marshal.h: gtkextra-marshal.list
+- ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --header > gtkextra-marshal.tmp \
+- && mv gtkextra-marshal.tmp gtkextra-marshal.h ) \
+- || ( rm -f gtkextra-marshal.tmp && exit 1 )
++ ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --header > gtkextra-marshal.tmp \
++ && mv gtkextra-marshal.tmp gtkextra-marshal.h ) \
++ || ( rm -f gtkextra-marshal.tmp && exit 1 )
+ $(srcdir)/gtkextra-marshal.c: gtkextra-marshal.h
+- ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --body > gtkextra-marshal.tmp \
+- && mv gtkextra-marshal.tmp gtkextra-marshal.c ) \
+- || ( rm -f gtkextra-marshal.tmp && exit 1 )
++ ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --body > gtkextra-marshal.tmp \
++ && mv gtkextra-marshal.tmp gtkextra-marshal.c ) \
++ || ( rm -f gtkextra-marshal.tmp && exit 1 )
+
+ $(srcdir)/gtkextratypebuiltins.h: $(public_h_sources)
+ ( cd $(srcdir) && glib-mkenums \
diff --git a/sci-mathematics/genius/genius-1.0.11.ebuild b/sci-mathematics/genius/genius-1.0.11.ebuild
new file mode 100644
index 000000000000..876a5275f393
--- /dev/null
+++ b/sci-mathematics/genius/genius-1.0.11.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/genius/genius-1.0.11.ebuild,v 1.1 2010/09/14 15:17:54 grozin Exp $
+
+EAPI=2
+inherit eutils gnome2
+
+DESCRIPTION="Genius Mathematics Tool and the GEL Language"
+HOMEPAGE="http://www.jirka.org/genius.html"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gnome nls"
+SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/${PN}/1.0/${P}.tar.bz2
+ doc? ( http://www.jirka.org/${PN}-reference.pdf )"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/gmp
+ dev-libs/mpfr
+ dev-libs/popt
+ sys-libs/ncurses
+ sys-libs/readline
+ gnome? ( x11-libs/gtk+:2
+ gnome-base/libgnome
+ gnome-base/libgnomeui
+ gnome-base/libglade
+ x11-libs/gtksourceview
+ x11-libs/vte )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ || ( sys-devel/bison
+ dev-util/yacc )
+ sys-devel/flex
+ app-text/scrollkeeper
+ nls? ( sys-devel/gettext )"
+
+G2CONF="${G2CONF} $(use_enable gnome) $(use_enable nls) \
+ --disable-update-mimedb --disable-scrollkeeper \
+ --disable-extra-gcc-optimization"
+# gnome2.eclass adds --disable-gtk-doc or --enable-gtk-doc to G2CONF
+# if there is the USE flag doc, thus leading to QA warnings
+GCONF_DEBUG="no"
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+USE_DESTDIR="1"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # bug #333871
+ epatch "${FILESDIR}"/${PN}-make.patch
+}
+
+src_install() {
+ gnome2_src_install
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}"/${PN}-reference.pdf
+ fi
+}