summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-10-18 18:30:08 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-10-18 18:30:08 +0000
commit4e738231eb26526c58d0317eb1a90fa2607483d3 (patch)
tree44e3dde6e0ce83bad22dc42ae7cbcfc6282f56b2 /sci-mathematics/coq
parentRemoving older versions. Made the remaining version block php 5.3 (diff)
downloadgentoo-2-4e738231eb26526c58d0317eb1a90fa2607483d3.tar.gz
gentoo-2-4e738231eb26526c58d0317eb1a90fa2607483d3.tar.bz2
gentoo-2-4e738231eb26526c58d0317eb1a90fa2607483d3.zip
Fix ./configure with make >= 3.82 wrt #341187 by Diego E. Pettenò.
(Portage version: 2.2_rc97/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/coq')
-rw-r--r--sci-mathematics/coq/ChangeLog6
-rw-r--r--sci-mathematics/coq/coq-8.2_p2.ebuild15
-rw-r--r--sci-mathematics/coq/files/coq-8.2_p2-make-3.82.patch13
3 files changed, 27 insertions, 7 deletions
diff --git a/sci-mathematics/coq/ChangeLog b/sci-mathematics/coq/ChangeLog
index e1fe41f51aa5..53c584e57fdf 100644
--- a/sci-mathematics/coq/ChangeLog
+++ b/sci-mathematics/coq/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/coq
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.53 2010/09/27 04:31:52 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.54 2010/10/18 18:30:07 ssuominen Exp $
+
+ 18 Oct 2010; Samuli Suominen <ssuominen@gentoo.org> coq-8.2_p2.ebuild,
+ +files/coq-8.2_p2-make-3.82.patch:
+ Fix ./configure with make >= 3.82 wrt #341187 by Diego E. Pettenò.
*coq-8.2_p2 (27 Sep 2010)
diff --git a/sci-mathematics/coq/coq-8.2_p2.ebuild b/sci-mathematics/coq/coq-8.2_p2.ebuild
index 087137cc57fe..c414565740bc 100644
--- a/sci-mathematics/coq/coq-8.2_p2.ebuild
+++ b/sci-mathematics/coq/coq-8.2_p2.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.2_p2.ebuild,v 1.1 2010/09/27 04:31:52 bicatali Exp $
-
-EAPI="2"
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.2_p2.ebuild,v 1.2 2010/10/18 18:30:07 ssuominen Exp $
+EAPI=2
inherit eutils multilib
-MY_PV="${PV/_p/pl}"
-MY_P="${PN}-${MY_PV}"
+MY_PV=${PV/_p/pl}
+MY_P=${PN}-${MY_PV}
DESCRIPTION="Coq is a proof assistant written in O'Caml"
HOMEPAGE="http://coq.inria.fr/"
@@ -31,7 +30,11 @@ DEPEND="${RDEPEND}
|| ( dev-texlive/texlive-mathextra app-text/ptex )
)"
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-make-3.82.patch
+}
src_configure() {
ocaml_lib=`ocamlc -where`
diff --git a/sci-mathematics/coq/files/coq-8.2_p2-make-3.82.patch b/sci-mathematics/coq/files/coq-8.2_p2-make-3.82.patch
new file mode 100644
index 000000000000..af46977b932c
--- /dev/null
+++ b/sci-mathematics/coq/files/coq-8.2_p2-make-3.82.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/341187
+
+--- configure
++++ configure
+@@ -327,6 +327,8 @@
+ case $MAKEVERSION in
+ "GNU Make 3.81")
+ echo "You have GNU Make 3.81. Good!";;
++ "GNU Make 3.82")
++ echo "You have GNU Make 3.82. Good!";;
+ *)
+ OK="no"
+ if [ -x ./make ]; then