summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-01-09 12:17:29 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-01-09 12:17:29 +0000
commita6edcdf638550ad928baeae54eb55327fe5b8f41 (patch)
tree72bdd620c93ab37f8c23fa720dd55e2fc1f87129 /sci-mathematics/cgal
parentUpdate some dependencies (diff)
downloadgentoo-2-a6edcdf638550ad928baeae54eb55327fe5b8f41.tar.gz
gentoo-2-a6edcdf638550ad928baeae54eb55327fe5b8f41.tar.bz2
gentoo-2-a6edcdf638550ad928baeae54eb55327fe5b8f41.zip
Version bump wrt #258304, thanks to Antonio Quartulli for reporting.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/cgal')
-rw-r--r--sci-mathematics/cgal/ChangeLog9
-rw-r--r--sci-mathematics/cgal/cgal-3.5.1.ebuild75
2 files changed, 82 insertions, 2 deletions
diff --git a/sci-mathematics/cgal/ChangeLog b/sci-mathematics/cgal/ChangeLog
index b19b4e84504a..413bfd054014 100644
--- a/sci-mathematics/cgal/ChangeLog
+++ b/sci-mathematics/cgal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/cgal
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/ChangeLog,v 1.4 2009/08/12 21:29:10 bicatali Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/ChangeLog,v 1.5 2010/01/09 12:17:29 ssuominen Exp $
+
+*cgal-3.5.1 (09 Jan 2010)
+
+ 09 Jan 2010; Samuli Suominen <ssuominen@gentoo.org> +cgal-3.5.1.ebuild:
+ Version bump wrt #258304, thanks to Antonio Quartulli for reporting.
12 Aug 2009; Sébastien Fabbro <bicatali@gentoo.org> cgal-3.3.1.ebuild,
+files/cgal-3.3.1-gcc44.patch:
diff --git a/sci-mathematics/cgal/cgal-3.5.1.ebuild b/sci-mathematics/cgal/cgal-3.5.1.ebuild
new file mode 100644
index 000000000000..916c644218b6
--- /dev/null
+++ b/sci-mathematics/cgal/cgal-3.5.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/cgal-3.5.1.ebuild,v 1.1 2010/01/09 12:17:29 ssuominen Exp $
+
+EAPI=2
+CMAKE_BUILD_TYPE=Release
+inherit base multilib cmake-utils
+
+MY_P=CGAL-${PV}
+
+DESCRIPTION="C++ library for geometric algorithms and data structures"
+HOMEPAGE="http://www.cgal.org/"
+SRC_URI="http://gforge.inria.fr/frs/download.php/25109/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 MIT QPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cxx examples +gmp lapack qt4"
+
+RDEPEND="dev-libs/boost
+ dev-libs/mpfr
+ sci-libs/taucs
+ sys-libs/zlib
+ x11-libs/libX11
+ virtual/opengl
+ gmp? (
+ dev-libs/gmp
+ cxx? ( dev-libs/gmp[-nocxx] )
+ )
+ lapack? ( virtual/lapack )
+ qt4? ( x11-libs/qt-gui:4
+ x11-libs/qt-opengl:4 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS CHANGES* README"
+
+src_prepare() {
+ base_src_prepare
+
+ sed -i \
+ -e '/install(FILES AUTHORS/d' \
+ CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs
+
+ if use gmp; then
+ mycmakeargs+=( $(cmake-utils_use_with cxx GMPXX) )
+ else
+ mycmakeargs+=( "-DWITH_GMPXX=OFF" )
+ fi
+
+ mycmakeargs+=(
+ "-DCGAL_INSTALL_LIB_DIR=$(get_libdir)"
+ "-DWITH_CGAL_Qt3=OFF"
+ $(cmake-utils_use_with qt4 CGAL_Qt4)
+ $(cmake-utils_use_with lapack CPACK)
+ $(cmake-utils_use_with gmp)
+ "-DWITH_LEDA=OFF"
+ $(cmake-utils_use_with examples DEMOS)
+ $(cmake-utils_use_with examples)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ dohtml -r doc_html/* || die
+}