summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-05-08 18:27:58 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-05-08 18:27:58 +0000
commit7676575bc0650599c21af626be2c24e200a411cf (patch)
treee20fec61a1790268a9bb05c4d0b0fc39e55ca547 /sci-mathematics/cgal
parentStable on amd64 wrt bug #414241 (diff)
downloadgentoo-2-7676575bc0650599c21af626be2c24e200a411cf.tar.gz
gentoo-2-7676575bc0650599c21af626be2c24e200a411cf.tar.bz2
gentoo-2-7676575bc0650599c21af626be2c24e200a411cf.zip
Fix for gcc-4.7, thanks Jimmy Jazz (bug #414029)
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/cgal')
-rw-r--r--sci-mathematics/cgal/ChangeLog6
-rw-r--r--sci-mathematics/cgal/cgal-4.0.ebuild3
-rw-r--r--sci-mathematics/cgal/files/cgal-4.0-gcc47.patch11
3 files changed, 18 insertions, 2 deletions
diff --git a/sci-mathematics/cgal/ChangeLog b/sci-mathematics/cgal/ChangeLog
index 751a550c9500..692d752bb0e5 100644
--- a/sci-mathematics/cgal/ChangeLog
+++ b/sci-mathematics/cgal/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/cgal
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/ChangeLog,v 1.14 2012/05/04 07:46:50 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/ChangeLog,v 1.15 2012/05/08 18:27:58 bicatali Exp $
+
+ 08 May 2012; Sébastien Fabbro <bicatali@gentoo.org> cgal-4.0.ebuild,
+ +files/cgal-4.0-gcc47.patch:
+ Fix for gcc-4.7, thanks Jimmy Jazz (bug #414029)
04 May 2012; Jeff Horelick <jdhore@gentoo.org> cgal-3.7.ebuild,
cgal-3.9.ebuild, cgal-4.0.ebuild:
diff --git a/sci-mathematics/cgal/cgal-4.0.ebuild b/sci-mathematics/cgal/cgal-4.0.ebuild
index 13d10922278b..cb1d7fd6413d 100644
--- a/sci-mathematics/cgal/cgal-4.0.ebuild
+++ b/sci-mathematics/cgal/cgal-4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/cgal-4.0.ebuild,v 1.2 2012/05/04 07:46:50 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/cgal-4.0.ebuild,v 1.3 2012/05/08 18:27:58 bicatali Exp $
EAPI=4
CMAKE_BUILD_TYPE=Release
@@ -39,6 +39,7 @@ S="${WORKDIR}/${MY_P}"
DOCS="AUTHORS CHANGES* README"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc47.patch
base_src_prepare
sed -i \
-e '/install(FILES AUTHORS/d' \
diff --git a/sci-mathematics/cgal/files/cgal-4.0-gcc47.patch b/sci-mathematics/cgal/files/cgal-4.0-gcc47.patch
new file mode 100644
index 000000000000..a2ed0e488803
--- /dev/null
+++ b/sci-mathematics/cgal/files/cgal-4.0-gcc47.patch
@@ -0,0 +1,11 @@
+--- ./include/CGAL/Mesh_2/Do_not_refine_edges.h.ori 2012-04-25 23:14:26.132198961 +0200
++++ ./include/CGAL/Mesh_2/Do_not_refine_edges.h 2012-04-25 23:14:46.304953789 +0200
+@@ -80,7 +80,7 @@
+ const Face_handle& fh = eit->first;
+ const int& i = eit->second;
+
+- if(fh->is_constrained(i) && !is_locally_conform(this->tr, fh, i, p))
++ if(fh->is_constrained(i) && !this->is_locally_conform(this->tr, fh, i, p))
+ {
+ return CONFLICT_AND_ELEMENT_SHOULD_BE_DROPPED;
+ }