summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-28 05:00:44 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-28 05:00:44 +0000
commit7e9f72eb06f1b1e2883f3c0993ed1bd31d985a46 (patch)
treeb87fd18e80731d0b003de5c906217927526270b4 /sci-mathematics/calc/calc-2.11.10.1.ebuild
parentMoving to sci-mathematics/calc (diff)
downloadgentoo-2-7e9f72eb06f1b1e2883f3c0993ed1bd31d985a46.tar.gz
gentoo-2-7e9f72eb06f1b1e2883f3c0993ed1bd31d985a46.tar.bz2
gentoo-2-7e9f72eb06f1b1e2883f3c0993ed1bd31d985a46.zip
Moved from app-sci/calc to sci-mathematics/calc.
Diffstat (limited to 'sci-mathematics/calc/calc-2.11.10.1.ebuild')
-rw-r--r--sci-mathematics/calc/calc-2.11.10.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-mathematics/calc/calc-2.11.10.1.ebuild b/sci-mathematics/calc/calc-2.11.10.1.ebuild
new file mode 100644
index 000000000000..a06089af60d4
--- /dev/null
+++ b/sci-mathematics/calc/calc-2.11.10.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/calc/calc-2.11.10.1.ebuild,v 1.1 2004/12/28 05:00:44 ribosome Exp $
+
+DESCRIPTION="An arbitrary precision C-like arithmetic system"
+HOMEPAGE="http://www.isthe.com/chongo/tech/comp/calc/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86 ~ppc ~amd64 ~alpha ~ppc-macos"
+
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.2
+ >=sys-libs/readline-4.2"
+
+RDEPEND=">=sys-apps/less-348"
+
+src_compile() {
+ make \
+ T=${D} \
+ DEBUG="${CFLAGS}" \
+ CALCPAGER=less \
+ USE_READLINE="-DUSE_READLINE" \
+ READLINE_LIB="-lreadline -lhistory -lncurses" \
+ all \
+ || die
+ if echo "${LD_PRELOAD}" | grep -q "sandbox"; then
+ ewarn "Can't run check when running in sandbox - see bug #59676"
+ else
+ make chk || die "Check failed"
+ fi
+}
+
+src_install() {
+ make T=${D} install || die
+ dodoc BUGS CHANGES COPYING COPYING-LGPL LIBRARY README
+}