summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-12-10 11:46:28 +0000
committerMark Wright <gienah@gentoo.org>2013-12-10 11:46:28 +0000
commita45a99ba2d88e431b04d885f4ed1238878109b7b (patch)
tree9d46d01f297784cd82c65286427e38e0540584ef /sci-mathematics/agda-stdlib
parentFixed compilation with >=media-libs/freetype-2.5.1 (bug #493594) (diff)
downloadgentoo-2-a45a99ba2d88e431b04d885f4ed1238878109b7b.tar.gz
gentoo-2-a45a99ba2d88e431b04d885f4ed1238878109b7b.tar.bz2
gentoo-2-a45a99ba2d88e431b04d885f4ed1238878109b7b.zip
Thanks to vikraman: The agda-lib-ffi package provides some additional haskell modules which are needed by the agda standard library, such as during compilation using the MAlonzo backend. It is available inside the ffi/ directory and needs to be built and installed by the ebuild.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'sci-mathematics/agda-stdlib')
-rw-r--r--sci-mathematics/agda-stdlib/ChangeLog11
-rw-r--r--sci-mathematics/agda-stdlib/agda-stdlib-0.7-r1.ebuild (renamed from sci-mathematics/agda-stdlib/agda-stdlib-0.7_pre20121118.ebuild)33
-rw-r--r--sci-mathematics/agda-stdlib/agda-stdlib-0.7_pre20130109.ebuild59
3 files changed, 38 insertions, 65 deletions
diff --git a/sci-mathematics/agda-stdlib/ChangeLog b/sci-mathematics/agda-stdlib/ChangeLog
index 81bcac32115b..c3e4be5dc4bf 100644
--- a/sci-mathematics/agda-stdlib/ChangeLog
+++ b/sci-mathematics/agda-stdlib/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-mathematics/agda-stdlib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda-stdlib/ChangeLog,v 1.4 2013/09/13 06:56:46 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda-stdlib/ChangeLog,v 1.5 2013/12/10 11:46:28 gienah Exp $
+
+*agda-stdlib-0.7-r1 (10 Dec 2013)
+
+ 10 Dec 2013; Mark Wright <gienah@gentoo.org> +agda-stdlib-0.7-r1.ebuild,
+ -agda-stdlib-0.7_pre20121118.ebuild, -agda-stdlib-0.7_pre20130109.ebuild:
+ Thanks to vikraman: The agda-lib-ffi package provides some additional haskell
+ modules which are needed by the agda standard library, such as during
+ compilation using the MAlonzo backend. It is available inside the ffi/
+ directory and needs to be built and installed by the ebuild.
*agda-stdlib-0.7 (13 Sep 2013)
diff --git a/sci-mathematics/agda-stdlib/agda-stdlib-0.7_pre20121118.ebuild b/sci-mathematics/agda-stdlib/agda-stdlib-0.7-r1.ebuild
index 91926c8a1ce5..89c9da53abc3 100644
--- a/sci-mathematics/agda-stdlib/agda-stdlib-0.7_pre20121118.ebuild
+++ b/sci-mathematics/agda-stdlib/agda-stdlib-0.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda-stdlib/agda-stdlib-0.7_pre20121118.ebuild,v 1.2 2013/01/10 12:31:25 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda-stdlib/agda-stdlib-0.7-r1.ebuild,v 1.1 2013/12/10 11:46:28 gienah Exp $
EAPI=5
@@ -9,16 +9,25 @@ inherit haskell-cabal elisp-common
DESCRIPTION="Agda standard library"
HOMEPAGE="http://wiki.portal.chalmers.se/agda/"
-SRC_URI="http://dev.gentoo.org/~gienah/snapshots/${P}.tar.gz"
+SRC_URI="http://www.cse.chalmers.se/~nad/software/lib-${PV}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="profile"
-DEPEND=">=sci-mathematics/agda-executable-2.3.0.1"
-RDEPEND="=sci-mathematics/agda-2.3.2*[profile?]
- =dev-haskell/filemanip-0.3*[profile?]"
+# filemanip is used in lib.cabal to make the GenerateEverything and
+# AllNonAsciiChars executables, so agda-stdlib does not require a subslot
+# dependency on filemanip.
+
+RDEPEND="=sci-mathematics/agda-2.3.2*:=[profile?]
+ =dev-haskell/filemanip-0.3*[profile?]
+ >=sci-mathematics/agda-executable-2.3.0.1:=
+ >=dev-lang/ghc-6.12.1
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
SITEFILE="50${PN}-gentoo.el"
@@ -28,6 +37,14 @@ src_prepare() {
cabal-mksetup
}
+src_configure() {
+ haskell-cabal_src_configure
+ pushd "${S}/ffi"
+ cabal-bootstrap
+ cabal-configure
+ popd
+}
+
src_compile() {
haskell-cabal_src_compile
"${S}"/dist/build/GenerateEverything/GenerateEverything \
@@ -44,6 +61,9 @@ src_compile() {
# /usr/share/agda-9999/ghc-7.4.1/Agda.css: copyFile: does not exist
local cssdir=$(egrep 'datadir *=' "${S}/dist/build/autogen/Paths_lib.hs" | sed -e 's@datadir = \(.*\)@\1@')
agda --html -i "${S}" -i "${S}"/src --css="${cssdir}/Agda.css" "${S}"/README.agda || die
+ pushd "${S}/ffi"
+ cabal_src_compile
+ popd
}
src_test() {
@@ -56,4 +76,7 @@ src_install() {
doins -r src/*
dodoc -r html/*
elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ pushd "${S}/ffi"
+ cabal_src_install
+ popd
}
diff --git a/sci-mathematics/agda-stdlib/agda-stdlib-0.7_pre20130109.ebuild b/sci-mathematics/agda-stdlib/agda-stdlib-0.7_pre20130109.ebuild
deleted file mode 100644
index 0e2b5becbc60..000000000000
--- a/sci-mathematics/agda-stdlib/agda-stdlib-0.7_pre20130109.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda-stdlib/agda-stdlib-0.7_pre20130109.ebuild,v 1.1 2013/01/10 12:31:25 gienah Exp $
-
-EAPI=5
-
-CABAL_FEATURES="bin"
-inherit haskell-cabal elisp-common
-
-DESCRIPTION="Agda standard library"
-HOMEPAGE="http://wiki.portal.chalmers.se/agda/"
-SRC_URI="http://dev.gentoo.org/~gienah/snapshots/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="profile"
-
-DEPEND=">=sci-mathematics/agda-executable-2.3.0.1"
-RDEPEND="=sci-mathematics/agda-2.3.2*[profile?]
- =dev-haskell/filemanip-0.3*[profile?]"
-
-SITEFILE="50${PN}-gentoo.el"
-
-S="${WORKDIR}/lib-${PV}"
-
-src_prepare() {
- cabal-mksetup
-}
-
-src_compile() {
- haskell-cabal_src_compile
- "${S}"/dist/build/GenerateEverything/GenerateEverything \
- || die "GenerateEverything failed"
- local prof
- use profile && prof="--ghc-flag=-prof"
- agda +RTS -K1G -RTS ${prof} \
- -i "${S}" -i "${S}"/src "${S}"/Everything.agda || die
- # Although my agda-9999 build has
- # /var/tmp/portage/sci-mathematics/agda-9999/work/agda-9999/dist/build/autogen/Paths_Agda.hs
- # containing:
- # datadir = "/usr/share/agda-9999/ghc-7.6.1"
- # it fails without the --css option like:
- # /usr/share/agda-9999/ghc-7.4.1/Agda.css: copyFile: does not exist
- local cssdir=$(egrep 'datadir *=' "${S}/dist/build/autogen/Paths_lib.hs" | sed -e 's@datadir = \(.*\)@\1@')
- agda --html -i "${S}" -i "${S}"/src --css="${cssdir}/Agda.css" "${S}"/README.agda || die
-}
-
-src_test() {
- agda -i "${S}" -i "${S}"/src README.agda || die
-}
-
-src_install() {
- insinto usr/share/agda-stdlib
- export INSOPTIONS=--preserve-timestamps
- doins -r src/*
- dodoc -r html/*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
-}