summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-03-28 12:20:04 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-03-28 12:20:04 +0000
commitf9b7ac08846073b25c09f37f4d556b7a5020f8ed (patch)
treeb270829f7ccba2e4a37563713cdab60df67b5e1b /sci-libs
parentFix python eclass usage (diff)
downloadgentoo-2-f9b7ac08846073b25c09f37f4d556b7a5020f8ed.tar.gz
gentoo-2-f9b7ac08846073b25c09f37f4d556b7a5020f8ed.tar.bz2
gentoo-2-f9b7ac08846073b25c09f37f4d556b7a5020f8ed.zip
Fixed header locations for metis, added support for pkg-config for lapack and metis, cleaned up autotools and ebuild
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cholmod/ChangeLog10
-rw-r--r--sci-libs/cholmod/cholmod-1.6.0-r1.ebuild (renamed from sci-libs/cholmod/cholmod-1.6.0.ebuild)28
-rw-r--r--sci-libs/cholmod/files/cholmod-1.6.0-autotools.patch35
3 files changed, 43 insertions, 30 deletions
diff --git a/sci-libs/cholmod/ChangeLog b/sci-libs/cholmod/ChangeLog
index c81970709c49..688e6bf8e1a7 100644
--- a/sci-libs/cholmod/ChangeLog
+++ b/sci-libs/cholmod/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/cholmod
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/ChangeLog,v 1.2 2008/03/27 19:12:30 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/ChangeLog,v 1.3 2008/03/28 12:20:03 bicatali Exp $
+
+*cholmod-1.6.0-r1 (28 Mar 2008)
+
+ 28 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ files/cholmod-1.6.0-autotools.patch, -cholmod-1.6.0.ebuild,
+ +cholmod-1.6.0-r1.ebuild:
+ Fixed header locations for metis, added support for pkg-config for lapack
+ and metis, cleaned up autotools and ebuild
27 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org> cholmod-1.6.0.ebuild:
Added parmetis as a possible graph partitoner
diff --git a/sci-libs/cholmod/cholmod-1.6.0.ebuild b/sci-libs/cholmod/cholmod-1.6.0-r1.ebuild
index 533e05e5fc27..41778ba8b131 100644
--- a/sci-libs/cholmod/cholmod-1.6.0.ebuild
+++ b/sci-libs/cholmod/cholmod-1.6.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/cholmod-1.6.0.ebuild,v 1.2 2008/03/27 19:12:30 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/cholmod-1.6.0-r1.ebuild,v 1.1 2008/03/28 12:20:03 bicatali Exp $
inherit autotools eutils
@@ -15,12 +15,16 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc metis minimal supernodal"
-DEPEND="supernodal? ( virtual/lapack )
+RDEPEND="supernodal? ( virtual/lapack )
sci-libs/amd
sci-libs/colamd
metis? ( sci-libs/camd
sci-libs/ccolamd
- || ( sci-libs/parmetis sci-libs/metis ) )"
+ || ( sci-libs/metis sci-libs/parmetis ) )"
+
+DEPEND="${RDEPEND}
+ supernodal? ( dev-util/pkgconfig )
+ metis? ( dev-util/pkgconfig )"
S="${WORKDIR}/${MY_PN}"
@@ -54,17 +58,13 @@ src_unpack() {
}
src_compile() {
- local myconf=""
-
- # Minimal is used to build only the LGPL libraries...
- if use minimal; then
- myconf="--disable-mod-modify
- --disable-mod-matrixops"
- fi
-
+ local lapack_libs=no
+ use supernodal && lapack_libs=$(pkg-config --libs lapack)
econf \
- ${myconf} \
+ --with-lapack="${lapack_libs}" \
$(use_enable supernodal mod-supernodal) \
+ $(use_enable !minimal mod-modify) \
+ $(use_enable !minimal mod-matrix-ops) \
$(use_enable metis mod-partition) \
|| die "econf failed"
emake || die "emake failed"
@@ -73,8 +73,8 @@ src_compile() {
src_test() {
if ! use supernodal || ! use metis || use minimal; then
ewarn "According to your useflags, some modules were not built on"
- ewarn "purpose. This can cause the tests included with Cholmod"
- ewarn "to fail. Rebuild with USE=\"supernodal metis -minimal\""
+ ewarn "purpose. This can cause the tests included with Cholmod"
+ ewarn "to fail. Rebuild with USE=\"supernodal metis -minimal\""
ewarn "if you care."
fi
cd "${S}"/Demo
diff --git a/sci-libs/cholmod/files/cholmod-1.6.0-autotools.patch b/sci-libs/cholmod/files/cholmod-1.6.0-autotools.patch
index 692d3d197e9c..d019b1360e13 100644
--- a/sci-libs/cholmod/files/cholmod-1.6.0-autotools.patch
+++ b/sci-libs/cholmod/files/cholmod-1.6.0-autotools.patch
@@ -1,6 +1,6 @@
--- configure.ac 1970-01-01 01:00:00.000000000 +0100
-+++ configure.ac 2008-02-01 19:12:59.582510299 +0000
-@@ -0,0 +1,137 @@
++++ configure.ac 2008-03-28 11:20:10.017415063 +0000
+@@ -0,0 +1,142 @@
+# -*- Autoconf -*-
+AC_PREREQ(2.59)
+AC_INIT(cholmod, 1.6.0, davis@cise.ufl.edu)
@@ -16,42 +16,42 @@
+ [build the check module])],
+ [mod_check=$enableval],
+ [mod_check="yes"])
-+AC_MSG_RESULT($mod_check)
++AC_MSG_RESULT([Enabling mod-check: $mod_check])
+
+AC_ARG_ENABLE(mod-cholesky,
+ [AC_HELP_STRING([--enable-mod-cholesky],
+ [build the cholesky module])],
+ [mod_cholesky=$enableval],
+ [mod_cholesky="yes"])
-+AC_MSG_RESULT($mod_cholesky)
++AC_MSG_RESULT([Enabling mod-cholesku: $mod_cholesky])
+
+AC_ARG_ENABLE(mod-partition,
+ [AC_HELP_STRING([--enable-mod-partition],
+ [build the partition module])],
+ [mod_partition=$enableval],
+ [mod_partition="yes"])
-+AC_MSG_RESULT($mod_partition)
++AC_MSG_RESULT([Enabling mod-partition: $mod_partition])
+
+AC_ARG_ENABLE(mod-matrixops,
+ [AC_HELP_STRING([--enable-mod-matrixops],
+ [build the matrixops module])],
+ [mod_matrixops=$enableval],
+ [mod_matrixops="yes"])
-+AC_MSG_RESULT($mod_matrixops)
++AC_MSG_RESULT([Enabling mod-matrixops: $mod_matrixops])
+
+AC_ARG_ENABLE(mod-modify,
+ [AC_HELP_STRING([--enable-mod-modify],
+ [build the modify module])],
+ [mod_modify=$enableval],
+ [mod_modify="yes"])
-+AC_MSG_RESULT($mod_modify)
++AC_MSG_RESULT([Enabling mod-modify: $mod_modify])
+
+AC_ARG_ENABLE(mod-supernodal,
+ [AC_HELP_STRING([--enable-mod-supernodal],
+ [build the supernodal module])],
+ [mod_supernodal=$enableval],
+ [mod_supernodal="yes"])
-+AC_MSG_RESULT($mod_supernodal)
++AC_MSG_RESULT([Enabling mod-supernoda: $mod_supernodal])
+
+if test x$mod_check = xno; then
+ AC_DEFINE(NCHECK)
@@ -69,9 +69,14 @@
+ AC_DEFINE(NPARTITION)
+else
+ MODULES="$MODULES Partition"
-+ AC_CHECK_HEADERS(metis.h)
-+ AC_CHECK_LIB(metis, METIS_NodeND, [], \
-+ [AC_MSG_ERROR([Cannot find libmetis])])
++ PKG_PROG_PKG_CONFIG
++ if test -n "$PKG_CONFIG"; then
++ PKG_CHECK_MODULES([metis], [metis])
++ else
++ AC_CHECK_HEADERS(metis.h)
++ AC_CHECK_LIB(metis, METIS_NodeND, [metis_LIBS=-lmetis], \
++ [AC_MSG_ERROR([Cannot find libmetis])])
++ fi
+
+ AC_CHECK_HEADERS(ccolamd.h)
+ AC_CHECK_LIB(ccolamd, ccolamd_report, [], \
@@ -615,16 +620,16 @@
+ cholmod_core.h \
+ cholmod_io64.h
--- ./Partition/Makefile.am 1970-01-01 01:00:00.000000000 +0100
-+++ ./Partition/Makefile.am 2008-02-01 18:53:12.292468792 +0000
++++ ./Partition/Makefile.am 2008-03-28 11:18:36.527105814 +0000
@@ -0,0 +1,6 @@
-+AM_CPPFLAGS = -I$(top_srcdir)/Include
++AM_CPPFLAGS = -I$(top_srcdir)/Include @metis_CFLAGS@
+noinst_LTLIBRARIES = libpart.la libpartl.la
+libpart_la_SOURCES = cholmod_camd.c cholmod_csymamd.c cholmod_nesdis.c cholmod_ccolamd.c cholmod_metis.c
+
+libpartl_la_SOURCES = $(libpart_la_SOURCES)
+libpartl_la_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
--- ./Makefile.am 1970-01-01 01:00:00.000000000 +0100
-+++ ./Makefile.am 2008-02-01 18:53:12.288468564 +0000
++++ ./Makefile.am 2008-03-28 11:20:54.705608972 +0000
@@ -0,0 +1,42 @@
+SUBDIRS = Include Demo Core $(MODULES)
+EXTRA_DIST = README.txt
@@ -644,7 +649,7 @@
+if MOD_PARTITION
+PARTITION = $(top_builddir)/Partition/libpart.la \
+ $(top_builddir)/Partition/libpartl.la \
-+ -lmetis -lccolamd -lcamd
++ @metis_LIBS@ -lccolamd -lcamd
+endif
+
+if MOD_MATRIXOPS