summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-26 15:33:18 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-26 15:33:18 +0000
commitf4179ea6f351d31bab39b9db0cfd5333c16426f7 (patch)
treecf5bda533e66483ff459a5a2ce269ad351036bb0 /sci-libs
parentFix buffer overflow with GCC 4.5 and _U_FORTIFY_SOURCE=2 wrt #324863 by Haral... (diff)
downloadgentoo-2-f4179ea6f351d31bab39b9db0cfd5333c16426f7.tar.gz
gentoo-2-f4179ea6f351d31bab39b9db0cfd5333c16426f7.tar.bz2
gentoo-2-f4179ea6f351d31bab39b9db0cfd5333c16426f7.zip
Fix dependencies, set RESTRICT_PYTHON_ABIS and call python_pkg_setup() (bug #316221).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/geos/ChangeLog7
-rw-r--r--sci-libs/geos/geos-3.2.0-r1.ebuild16
2 files changed, 17 insertions, 6 deletions
diff --git a/sci-libs/geos/ChangeLog b/sci-libs/geos/ChangeLog
index e22acb819e6a..a1d2d10606f3 100644
--- a/sci-libs/geos/ChangeLog
+++ b/sci-libs/geos/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/geos
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.43 2010/06/26 11:50:13 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.44 2010/06/26 15:33:18 arfrever Exp $
+
+ 26 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ geos-3.2.0-r1.ebuild:
+ Fix dependencies, set RESTRICT_PYTHON_ABIS and call python_pkg_setup()
+ (bug #316221).
*geos-3.2.0-r1 (26 Jun 2010)
diff --git a/sci-libs/geos/geos-3.2.0-r1.ebuild b/sci-libs/geos/geos-3.2.0-r1.ebuild
index 407c60901acb..57aaf2c12241 100644
--- a/sci-libs/geos/geos-3.2.0-r1.ebuild
+++ b/sci-libs/geos/geos-3.2.0-r1.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.2.0-r1.ebuild,v 1.1 2010/06/26 11:50:13 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.2.0-r1.ebuild,v 1.2 2010/06/26 15:33:18 arfrever Exp $
EAPI=2
-PYTHON_DEPEND="2"
+PYTHON_DEPEND="python? 2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit autotools eutils python
@@ -18,17 +19,22 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
IUSE="doc python ruby"
-RDEPEND="ruby? ( virtual/ruby )
- python? ( virtual/python )"
+RDEPEND="ruby? ( virtual/ruby )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
ruby? ( dev-lang/swig )
python? ( dev-lang/swig )"
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
src_prepare() {
epatch "${FILESDIR}"/${PV}-multipy.patch
eautoreconf
- echo "#!/${EPREFIX}/bin/bash" > py-compile
+ echo "#!/bin/bash" > py-compile
}
src_configure() {