summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-09 13:35:22 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-09 13:35:22 +0000
commitedac7f40baa6b2a7e92cdc979ced6d7101463815 (patch)
treefb25e2e7949484ff3b8eaa4359ed44cf8c40d2d2 /sci-libs
parentppc stable #278483 (diff)
downloadgentoo-2-edac7f40baa6b2a7e92cdc979ced6d7101463815.tar.gz
gentoo-2-edac7f40baa6b2a7e92cdc979ced6d7101463815.tar.bz2
gentoo-2-edac7f40baa6b2a7e92cdc979ced6d7101463815.zip
Fix building with GLIBC 2.10+ wrt #274282.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/mathgl/ChangeLog6
-rw-r--r--sci-libs/mathgl/files/mathgl-1.8.1-gcc44.patch21
-rw-r--r--sci-libs/mathgl/mathgl-1.8.1.ebuild15
3 files changed, 35 insertions, 7 deletions
diff --git a/sci-libs/mathgl/ChangeLog b/sci-libs/mathgl/ChangeLog
index b06debd10bac..02c1c01ceddf 100644
--- a/sci-libs/mathgl/ChangeLog
+++ b/sci-libs/mathgl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/mathgl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.5 2009/04/24 19:08:19 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.6 2009/08/09 13:35:22 ssuominen Exp $
+
+ 09 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> mathgl-1.8.1.ebuild,
+ +files/mathgl-1.8.1-gcc44.patch:
+ Fix building with GLIBC 2.10+ wrt #274282.
24 Apr 2009; Andrey Grozin <grozin@gentoo.org>
+files/mathgl-1.8.1-gcc43.patch, mathgl-1.8.1:
diff --git a/sci-libs/mathgl/files/mathgl-1.8.1-gcc44.patch b/sci-libs/mathgl/files/mathgl-1.8.1-gcc44.patch
new file mode 100644
index 000000000000..58eac42ce025
--- /dev/null
+++ b/sci-libs/mathgl/files/mathgl-1.8.1-gcc44.patch
@@ -0,0 +1,21 @@
+diff -ur mathgl-1.8.1.orig/mgl/mgl_addon.cpp mathgl-1.8.1/mgl/mgl_addon.cpp
+--- mathgl-1.8.1.orig/mgl/mgl_addon.cpp 2009-03-04 15:22:03.000000000 +0200
++++ mathgl-1.8.1/mgl/mgl_addon.cpp 2009-08-09 16:33:40.000000000 +0300
+@@ -28,7 +28,7 @@
+ //---------------------------------------------------------------------------
+ int mgl_strpos(const char *str,char *fnd)
+ {
+- char *p=strstr(str,fnd);
++ const char *p=strstr(str,fnd);
+ int res;
+ if(p) res = p-str;
+ else res = -1;
+@@ -37,7 +37,7 @@
+ //---------------------------------------------------------------------------
+ int mgl_strpos(const char *str,char ch)
+ {
+- char *p=strchr(str,ch);
++ const char *p=strchr(str,ch);
+ int res;
+ if(p) res = p-str;
+ else res = -1;
diff --git a/sci-libs/mathgl/mathgl-1.8.1.ebuild b/sci-libs/mathgl/mathgl-1.8.1.ebuild
index 8a009ade15d9..32f9996c49f1 100644
--- a/sci-libs/mathgl/mathgl-1.8.1.ebuild
+++ b/sci-libs/mathgl/mathgl-1.8.1.ebuild
@@ -1,17 +1,19 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.8.1.ebuild,v 1.2 2009/04/24 19:08:19 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.8.1.ebuild,v 1.3 2009/08/09 13:35:22 ssuominen Exp $
+
EAPI=2
WX_GTK_VER=2.8
inherit autotools wxwidgets python versionator toolchain-funcs
+
DESCRIPTION="Math Graphics Library"
-IUSE="doc fltk gif glut gsl hdf5 jpeg octave python qt4 wxwindows"
HOMEPAGE="http://mathgl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
-
-SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fltk gif glut gsl hdf5 jpeg octave python qt4 wxwindows"
RDEPEND="media-libs/libpng
virtual/glu
@@ -25,7 +27,6 @@ RDEPEND="media-libs/libpng
octave? ( sci-mathematics/octave )
qt4? ( x11-libs/qt-gui:4 )
wxwindows? ( x11-libs/wxGTK:2.8 )"
-
DEPEND="${RDEPEND}
doc? ( app-text/texi2html virtual/texi2dvi )
python? ( dev-lang/swig )
@@ -41,6 +42,8 @@ pkg_setup() {
src_prepare() {
# bug #267061
epatch "${FILESDIR}"/${P}-gcc43.patch
+ # bug 274282
+ epatch "${FILESDIR}"/${P}-gcc44.patch
# correct location of numpy/arrayobject.h
if use python; then