summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-21 22:05:32 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-21 22:05:32 +0000
commite378c5349a7cb2cbc9ef42825f2d0e6af1c0b4de (patch)
treea3faec7c54efed2888036d64979b5e9f6461acf9 /sci-libs
parentsci-libs/gerris: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of ... (diff)
downloadgentoo-2-e378c5349a7cb2cbc9ef42825f2d0e6af1c0b4de.tar.gz
gentoo-2-e378c5349a7cb2cbc9ef42825f2d0e6af1c0b4de.tar.bz2
gentoo-2-e378c5349a7cb2cbc9ef42825f2d0e6af1c0b4de.zip
sci-libs/punc: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config; add missing dep
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/punc/ChangeLog8
-rw-r--r--sci-libs/punc/metadata.xml10
-rw-r--r--sci-libs/punc/punc-1.5.ebuild15
3 files changed, 19 insertions, 14 deletions
diff --git a/sci-libs/punc/ChangeLog b/sci-libs/punc/ChangeLog
index bb5d6c97d47c..ed0680d778e9 100644
--- a/sci-libs/punc/ChangeLog
+++ b/sci-libs/punc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/punc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/ChangeLog,v 1.17 2012/10/16 20:08:39 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/ChangeLog,v 1.18 2013/02/21 22:05:32 jlec Exp $
+
+ 21 Feb 2013; Justin Lecher <jlec@gentoo.org> punc-1.5.ebuild, metadata.xml:
+ Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config;
+ add missing dep
16 Oct 2012; Justin Lecher <jlec@gentoo.org> -punc-0.2_p1.ebuild,
-punc-1.4-r1.ebuild, punc-1.5.ebuild:
diff --git a/sci-libs/punc/metadata.xml b/sci-libs/punc/metadata.xml
index 6a2ed5438995..149f0dfc9c6f 100644
--- a/sci-libs/punc/metadata.xml
+++ b/sci-libs/punc/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <maintainer>
- <email>jlec@gentoo.org</email>
- </maintainer>
- <longdescription>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
PUNC (Portable Understructure for Numerical Computing) is a small standard
collection of software libraries for numerical computing. The PUNC
collection includes reference implementations of the standard (dense matrix)
diff --git a/sci-libs/punc/punc-1.5.ebuild b/sci-libs/punc/punc-1.5.ebuild
index d7c1eb5b2055..0c206c976562 100644
--- a/sci-libs/punc/punc-1.5.ebuild
+++ b/sci-libs/punc/punc-1.5.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/punc-1.5.ebuild,v 1.7 2012/10/16 20:08:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/punc-1.5.ebuild,v 1.8 2013/02/21 22:05:32 jlec Exp $
EAPI=4
AUTOTOOLS_AUTORECONF=yes
-inherit autotools-utils fortran-2 multilib
+inherit autotools-utils fortran-2 multilib toolchain-funcs
DESCRIPTION="Portable Understructure for Numerical Computing"
HOMEPAGE="http://fetk.org/codes/punc/index.html"
@@ -28,8 +28,8 @@ RDEPEND="
virtual/blas
virtual/lapack
mpi? ( virtual/mpi )"
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
doc? (
media-gfx/graphviz
app-doc/doxygen )"
@@ -38,7 +38,8 @@ S="${WORKDIR}/${PN}"
PATCHES=(
"${FILESDIR}"/${PV}-linking.patch
- "${FILESDIR}"/1.4-doc.patch )
+ "${FILESDIR}"/1.4-doc.patch
+ )
src_prepare() {
sed 's:punc/slu_ddefs.h:superlu/slu_ddefs.h:g' src/superlu/punc/vsuperlu.h > vsuperlu.h || die
@@ -63,7 +64,7 @@ src_configure() {
fetk_lib="${EPREFIX}"/usr/$(get_libdir)
export FETK_INCLUDE="${fetk_include}"
export FETK_LIBRARY="${fetk_lib}"
- export FETK_LAPACK_LIBRARY="$(pkg-config --libs lapack)"
+ export FETK_LAPACK_LIBRARY="$($(tc-getPKG_CONFIG) --libs lapack)"
export FETK_BLAS_LIBRARY="${fetk_lib}"
export FETK_SUPERLU_LIBRARY="-lsuperlu"
export FETK_ARPACK_LIBRARY="${fetk_lib}"