summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-01-21 10:03:47 +0000
committerJustin Lecher <jlec@gentoo.org>2012-01-21 10:03:47 +0000
commitdcc811392f4eafb6a07cadd7aea7b55b5ac2f083 (patch)
treed379edc293c00af37e253cd0eca507dca7e61711 /sci-libs
parentRemoving mask of pruned packages (diff)
downloadgentoo-2-dcc811392f4eafb6a07cadd7aea7b55b5ac2f083.tar.gz
gentoo-2-dcc811392f4eafb6a07cadd7aea7b55b5ac2f083.tar.bz2
gentoo-2-dcc811392f4eafb6a07cadd7aea7b55b5ac2f083.zip
Fix out of source build, #399521
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/colamd/ChangeLog6
-rw-r--r--sci-libs/colamd/colamd-2.7.4.ebuild8
-rw-r--r--sci-libs/colamd/files/colamd-2.7.4-autotools.patch58
3 files changed, 66 insertions, 6 deletions
diff --git a/sci-libs/colamd/ChangeLog b/sci-libs/colamd/ChangeLog
index ff9e5d5707e5..87464ef97466 100644
--- a/sci-libs/colamd/ChangeLog
+++ b/sci-libs/colamd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/colamd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/colamd/ChangeLog,v 1.24 2012/01/21 09:13:23 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/colamd/ChangeLog,v 1.25 2012/01/21 10:03:46 jlec Exp $
+
+ 21 Jan 2012; Justin Lecher <jlec@gentoo.org> colamd-2.7.4.ebuild,
+ +files/colamd-2.7.4-autotools.patch:
+ Fix out of source build, #399521
21 Jan 2012; Kacper Kowalik <xarthisius@gentoo.org> colamd-2.7.4.ebuild:
Readd AUTOTOOLS_IN_SOURCE_BUILD=1, drop quotes
diff --git a/sci-libs/colamd/colamd-2.7.4.ebuild b/sci-libs/colamd/colamd-2.7.4.ebuild
index a40a8249b0c4..4bae997961b0 100644
--- a/sci-libs/colamd/colamd-2.7.4.ebuild
+++ b/sci-libs/colamd/colamd-2.7.4.ebuild
@@ -1,15 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/colamd/colamd-2.7.4.ebuild,v 1.2 2012/01/21 09:13:23 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/colamd/colamd-2.7.4.ebuild,v 1.3 2012/01/21 10:03:46 jlec Exp $
EAPI=4
-AUTOTOOLS_AUTORECONF=yes
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
inherit autotools-utils
MY_PN=COLAMD
+
DESCRIPTION="Column approximate minimum degree ordering algorithm"
HOMEPAGE="http://www.cise.ufl.edu/research/sparse/colamd/"
SRC_URI="http://www.cise.ufl.edu/research/sparse/${PN}/${MY_PN}-${PV}.tar.gz"
@@ -23,7 +21,7 @@ DEPEND="sci-libs/ufconfig"
RDEPEND="${DEPEND}"
DOCS=( README.txt Doc/ChangeLog )
-PATCHES=( "${FILESDIR}"/${PN}-2.7.1-autotools.patch )
+PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
# Needs manual inspection of the result, useless.
RESTRICT="test"
diff --git a/sci-libs/colamd/files/colamd-2.7.4-autotools.patch b/sci-libs/colamd/files/colamd-2.7.4-autotools.patch
new file mode 100644
index 000000000000..f58464cd987f
--- /dev/null
+++ b/sci-libs/colamd/files/colamd-2.7.4-autotools.patch
@@ -0,0 +1,58 @@
+--- Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Makefile.am 2008-01-29 19:06:31.000000000 +0000
+@@ -0,0 +1,3 @@
++SUBDIRS = Source Demo
++include_HEADERS = $(top_srcdir)/Include/colamd.h
++EXTRA_DIST = README.txt
+--- configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ configure.ac 2008-01-29 19:06:31.000000000 +0000
+@@ -0,0 +1,12 @@
++# -*- Autoconf -*-
++AC_PREREQ(2.59)
++AC_INIT(colamd, 2.7.1, davis@cise.ufl.edu)
++AM_INIT_AUTOMAKE([foreign])
++AC_PROG_INSTALL
++AC_PROG_LIBTOOL
++AC_CHECK_LIB(m, sqrt)
++AC_CHECK_HEADER( UFconfig.h )
++AC_OUTPUT(
++ Makefile \
++ Demo/Makefile \
++ Source/Makefile)
+--- Source/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Source/Makefile.am 2008-01-29 19:06:31.000000000 +0000
+@@ -0,0 +1,11 @@
++AM_CFLAGS = -I$(top_srcdir)/Include
++lib_LTLIBRARIES = libcolamd.la
++noinst_LTLIBRARIES = libcolamdi.la libcolamdl.la
++
++libcolamdl_la_SOURCES = colamd.c
++libcolamdl_la_CPPFLAGS = -DDLONG
++
++libcolamdi_la_SOURCES = colamd.c
++
++libcolamd_la_SOURCES = colamd_global.c
++libcolamd_la_LIBADD = libcolamdi.la libcolamdl.la
+--- Demo/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Demo/Makefile.am 2008-01-29 19:06:31.000000000 +0000
+@@ -0,0 +1,20 @@
++LDADD = $(top_builddir)/Source/libcolamd.la
++AM_CPPFLAGS = -I$(top_srcdir)/Include
++
++check_PROGRAMS = colamd_example colamd_l_example
++colamd_example_SOURCES = colamd_example.c
++colamd_l_example_SOURCES = colamd_l_example.c
++colamd_l_example_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
++
++check-local: $(check_PROGRAMS)
++ @for i in $(check_PROGRAMS); do \
++ echo "Testing $$i"; \
++ ./$$i > my_$$i.out; \
++ if ! diff $(srcdir)/$$i.out my_$$i.out; then \
++ echo "Testing $$i failed"; \
++ exit 1; \
++ fi \
++ done;
++
++clean-local:
++ rm -f my*.out