summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-11-17 12:19:37 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-11-17 12:19:37 +0000
commitdc34caff0f3de2c8e9c392beac6663d9e11fbbfe (patch)
tree4e6cec1836e6a732134c6ff14ff6619be9374711 /sci-libs
parentMarked stable on AMD64 based on arch testing by Agostino "ago" Sarubbo in sec... (diff)
downloadgentoo-2-dc34caff0f3de2c8e9c392beac6663d9e11fbbfe.tar.gz
gentoo-2-dc34caff0f3de2c8e9c392beac6663d9e11fbbfe.tar.bz2
gentoo-2-dc34caff0f3de2c8e9c392beac6663d9e11fbbfe.zip
Version bump wrt #390811 by Tolga Dalman, fixes bug #383843 by Cedric
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hdf5/ChangeLog8
-rw-r--r--sci-libs/hdf5/files/hdf5-1.8.8-buildsystem.patch33
-rw-r--r--sci-libs/hdf5/hdf5-1.8.8.ebuild108
-rw-r--r--sci-libs/hdf5/metadata.xml18
4 files changed, 161 insertions, 6 deletions
diff --git a/sci-libs/hdf5/ChangeLog b/sci-libs/hdf5/ChangeLog
index e5d9dcc8c8c8..115613f1a475 100644
--- a/sci-libs/hdf5/ChangeLog
+++ b/sci-libs/hdf5/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/hdf5
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.75 2011/10/23 11:40:12 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.76 2011/11/17 12:19:37 xarthisius Exp $
+
+*hdf5-1.8.8 (17 Nov 2011)
+
+ 17 Nov 2011; Kacper Kowalik <xarthisius@gentoo.org>
+ +files/hdf5-1.8.8-buildsystem.patch, +hdf5-1.8.8.ebuild, metadata.xml:
+ Version bump wrt #390811 by Tolga Dalman, fixes bug #383843 by Cedric
23 Oct 2011; Tomáš Chvátal <scarabeus@gentoo.org> -hdf5-1.8.6.ebuild,
hdf5-1.8.7.ebuild:
diff --git a/sci-libs/hdf5/files/hdf5-1.8.8-buildsystem.patch b/sci-libs/hdf5/files/hdf5-1.8.8-buildsystem.patch
new file mode 100644
index 000000000000..0f85cf5ed245
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.8.8-buildsystem.patch
@@ -0,0 +1,33 @@
+Prevent build system with messing up LD_LIBRARY_PATH
+
+--- a/configure.in
++++ b/configure.in
+@@ -2328,8 +2328,6 @@
+ dnl
+ AC_MSG_CHECKING([how to print long long])
+ AC_CACHE_VAL([hdf5_cv_printf_ll],
+-LD_LIBRARY_PATH="$LD_LIBRARY_PATH`echo $AM_LDFLAGS $LDFLAGS | sed -e 's/-L/:/g' -e 's/ //g'`"
+-export LD_LIBRARY_PATH
+
+ for hdf5_cv_printf_ll in l ll L q unknown; do
+ AC_TRY_RUN([
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -125,8 +125,6 @@
+ # Remove the generated .c file if errors occur unless HDF5_Make_Ignore
+ # is set to ignore the error.
+ H5Tinit.c: H5detect$(EXEEXT)
+- LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
+- sed -e 's/-L/:/g' -e 's/ //g'`" \
+ $(RUNSERIAL) ./H5detect$(EXEEXT) > $@ || \
+ (test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
+ ($(RM) $@ ; exit 1)
+@@ -137,8 +135,6 @@
+ # Remove the generated .c file if errors occur unless HDF5_Make_Ignore
+ # is set to ignore the error.
+ H5lib_settings.c: H5make_libsettings$(EXEEXT) libhdf5.settings
+- LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
+- sed -e 's/-L/:/g' -e 's/ //g'`" \
+ $(RUNSERIAL) ./H5make_libsettings$(EXEEXT) > $@ || \
+ (test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
+ ($(RM) $@ ; exit 1)
diff --git a/sci-libs/hdf5/hdf5-1.8.8.ebuild b/sci-libs/hdf5/hdf5-1.8.8.ebuild
new file mode 100644
index 000000000000..3310cb052610
--- /dev/null
+++ b/sci-libs/hdf5/hdf5-1.8.8.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.8.ebuild,v 1.1 2011/11/17 12:19:37 xarthisius Exp $
+
+EAPI=4
+
+inherit autotools eutils fortran-2
+
+DESCRIPTION="General purpose library and file format for storing scientific data"
+HOMEPAGE="http://www.hdfgroup.org/HDF5/"
+SRC_URI="http://www.hdfgroup.org/ftp/HDF5/releases/${P}/src/${P}.tar.bz2"
+
+LICENSE="NCSA-HDF"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="cxx debug examples fortran fortran2003 mpi static-libs szip threads zlib"
+REQUIRED_USE="fortran2003? ( fortran )"
+
+RDEPEND="
+ fortran? ( virtual/fortran )
+ mpi? ( virtual/mpi[romio] )
+ szip? ( >=sci-libs/szip-2.1 )
+ zlib? ( sys-libs/zlib )"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool:2"
+
+pkg_setup() {
+ if use fortran; then
+ use fortran2003 && FORTRAN_STANDARD=2003
+ fortran-2_pkg_setup
+ fi
+ if use mpi; then
+ if has_version 'sci-libs/hdf5[-mpi]'; then
+ ewarn "Installing hdf5 with mpi enabled with a previous hdf5 with mpi disabled may fail."
+ ewarn "Try to uninstall the current hdf5 prior to enabling mpi support."
+ fi
+ if use cxx; then
+ ewarn "Simultaneous mpi and cxx is not supported by ${PN}"
+ ewarn "Will disable cxx interface"
+ fi
+ export CC=mpicc
+ use fortran && export FC=mpif90
+ elif has_version 'sci-libs/hdf5[mpi]'; then
+ ewarn "Installing hdf5 with mpi disabled while having hdf5 installed with mpi enabled may fail."
+ ewarn "Try to uninstall the current hdf5 prior to disabling mpi support."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-buildsystem.patch
+ # respect gentoo examples directory
+ sed \
+ -e "s:hdf5_examples:doc/${PF}/examples:g" \
+ -i $(find . -name Makefile.am) $(find . -name "run*.sh.in") || die
+ sed \
+ -e '/docdir/d' \
+ -i config/commence.am || die
+ eautoreconf
+ # enable shared libs by default for h5cc config utility
+ sed -i -e "s/SHLIB:-no/SHLIB:-yes/g" tools/misc/h5cc.in || die
+}
+
+src_configure() {
+ # threadsafe incompatible with many options
+ local myconf="--disable-threadsafe"
+ use debug && myconf="${myconf} --enable-codestack"
+ use threads && ! use fortran && ! use cxx && ! use mpi \
+ && myconf="--enable-threadsafe"
+
+ if use mpi; then
+ myconf="${myconf} --disable-cxx"
+ else
+ # workaround for bug 285148
+ if use cxx; then
+ myconf="${myconf} $(use_enable cxx) CXX=$(tc-getCXX)"
+ fi
+ if use fortran; then
+ myconf="${myconf} FC=$(tc-getFC)"
+ fi
+ fi
+
+ econf \
+ --disable-sharedlib-rpath \
+ --enable-production \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --enable-deprecated-symbols \
+ --enable-shared \
+ --disable-silent-rules \
+ $(use_enable static-libs static) \
+ $(use_enable debug debug all) \
+ $(use_enable fortran) \
+ $(use_enable fortran2003) \
+ $(use_enable mpi parallel) \
+ $(use_with szip szlib) \
+ $(use_with threads pthread) \
+ $(use_with zlib) \
+ ${myconf}
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
+
+ if use examples; then
+ emake DESTDIR="${D}" install-examples
+ fi
+}
diff --git a/sci-libs/hdf5/metadata.xml b/sci-libs/hdf5/metadata.xml
index 2058812bfd6c..6b6f68735c02 100644
--- a/sci-libs/hdf5/metadata.xml
+++ b/sci-libs/hdf5/metadata.xml
@@ -2,10 +2,18 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci</herd>
+ <maintainer>
+ <email>xarthisius@gentoo.org</email>
+ <name>Kacper Kowalik</name>
+ </maintainer>
<longdescription>
- HDF5 is a file format and library for storing scientific data. HDF5
- was designed and implemented to address the deficiencies of HDF4.x. It
- has a more powerful and flexible data model, supports files larger
- than 2 GB, and supports parallel I/O.
-</longdescription>
+ HDF5 is a file format and library for storing scientific data. HDF5
+ was designed and implemented to address the deficiencies of HDF4.x. It
+ has a more powerful and flexible data model, supports files larger
+ than 2 GB, and supports parallel I/O.
+ </longdescription>
+ <use>
+ <flag name="fortran2003">enable new features that require Fortran 2003
+ (http://www.hdfgroup.org/HDF5/doc/fortran/NewFeatures_F2003.pdf)</flag>
+ </use>
</pkgmetadata>