summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-09-13 21:19:14 +0000
committerJustin Lecher <jlec@gentoo.org>2011-09-13 21:19:14 +0000
commitd83c80c89cd28c32589fdedbb2b9d2798e3c3278 (patch)
treef43fd7d843d4edd23dd5290590158369d06aeb9a /sci-libs
parentadd missing test to IUSE (diff)
downloadgentoo-2-d83c80c89cd28c32589fdedbb2b9d2798e3c3278.tar.gz
gentoo-2-d83c80c89cd28c32589fdedbb2b9d2798e3c3278.tar.bz2
gentoo-2-d83c80c89cd28c32589fdedbb2b9d2798e3c3278.zip
Version Bump
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/getdata/ChangeLog7
-rw-r--r--sci-libs/getdata/getdata-0.7.3.ebuild92
2 files changed, 98 insertions, 1 deletions
diff --git a/sci-libs/getdata/ChangeLog b/sci-libs/getdata/ChangeLog
index c0864533591d..fb7d0807ade1 100644
--- a/sci-libs/getdata/ChangeLog
+++ b/sci-libs/getdata/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/getdata
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/getdata/ChangeLog,v 1.6 2011/09/13 21:06:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/getdata/ChangeLog,v 1.7 2011/09/13 21:19:14 jlec Exp $
+
+*getdata-0.7.3 (13 Sep 2011)
+
+ 13 Sep 2011; Justin Lecher <jlec@gentoo.org> +getdata-0.7.3.ebuild:
+ Version Bump
13 Sep 2011; Justin Lecher <jlec@gentoo.org> getdata-0.6.3-r1.ebuild:
Fix: build contains leading spaces on line
diff --git a/sci-libs/getdata/getdata-0.7.3.ebuild b/sci-libs/getdata/getdata-0.7.3.ebuild
new file mode 100644
index 000000000000..6d4310f84092
--- /dev/null
+++ b/sci-libs/getdata/getdata-0.7.3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/getdata/getdata-0.7.3.ebuild,v 1.1 2011/09/13 21:19:14 jlec Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+
+FORTRAN_STANDARD="95"
+
+inherit autotools fortran-2 python
+
+DESCRIPTION="Reference implementation of the Dirfile, format for time-ordered binary data"
+HOMEPAGE="http://getdata.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 fortran lzma python static-libs"
+
+DEPEND="
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ use fortran && fortran-2_pkg_setup
+}
+
+src_prepare() {
+ # Python bindings are built/tested/installed manually.
+ sed -e "/PY_SUBDIR/s/python//" -i bindings/Makefile.am
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-idl \
+ --without-libslim \
+ --with-libz \
+ --enable-shared \
+ --docdir="${EPREFIX}/usr/share/doc/${P}" \
+ $(use_enable fortran) \
+ $(use_enable fortran fortran95) \
+ $(use_enable python) \
+ $(use_enable static-libs static) \
+ $(use_with bzip2 libbz2) \
+ $(use_with lzma liblzma)
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ python_copy_sources bindings/python
+ building() {
+ sed "s:-lpython...:$(python_get_library --linker-option):g" -i Makefile || die
+ emake \
+ PYTHON_VERSION="$(python_get_version)" \
+ NUMPY_CPPFLAGS="-I${EPREFIX}$(python_get_sitedir)/numpy/core/include" \
+ PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir bindings/python building
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ if use python; then
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ PYTHON_VERSION="$(python_get_version)" \
+ NUMPY_CPPFLAGS="-I${EPREFIX}$(python_get_sitedir)/numpy/core/include" \
+ PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
+ PYTHON_VERSION="$(python_get_version)" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)" \
+ install
+ if use static-libs; then
+ find "${ED}/$(python_get_sitedir)" -type f -name "*.a" -delete || die
+ fi
+ }
+ python_execute_function -s --source-dir bindings/python installation
+ python_clean_installation_image
+ fi
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "Installing docs failed"
+}